Page 1 sur 1

Chemins d'accès

MessagePosté: Jeudi 03 Mai 2018, 16:19
par Euher
Bonjour à tous,

Depuis plusieurs années, j'ai pris l'habitude de placer mon préambule dans un dossier, et de l'appeler par un input dans mes documents.

Voici deux jours, j'ai dû réinstaller Miktex et Texmaker, en suivant rigoureusement la procédure donnée sur xm1math.
Depuis, mes documents ne compilent plus. J'ai remarqué que c'est sans doute le chemin d'accès de mon préambule qui pose problème, puisque si je le mets dans le même dossier que mon document, la compilation fonctionne.
Pourtant, je n'ai rien changé (le chemin d'accès contient des espaces et des caractères accentués, mais auparavant cela fonctionnait sans problème).

La mise à jour de MikTex a-t-elle changé la donne dans la façon de déclarer le chemin dans un input ?

Merci d'avance pour les réponses éclairées !

Re: Chemins d'accès

MessagePosté: Jeudi 03 Mai 2018, 17:44
par Denis Bitouzé
Bien que la procédure que j'y indique concerne, comme distribution TeX, la TeX Live et non la MiKTeX, vous serez peut-être intéressé par la section « Où définir les macros personnelles ? » (transparents 29 à 42) du diaporama http://gte.univ-littoral.fr/members/dbi ... ligne3.pdf de mon cours LaTeX.

Re: Chemins d'accès

MessagePosté: Jeudi 03 Mai 2018, 18:04
par Euher
Merci beaucoup pour cette réponse rapide.

Malheureusement, tout intéressante qu'elle soit, la méthode proposée ne me conviendra pas. En effet, le dossier dans lequel je stocke mon préambule est synchronisé avec un cloud, de sorte que je puisse l'utiliser aussi bien avec mon PC fixe qu'avec mon portable. Il faut donc que mon préambule soit dans un dossier bien précis de ma machine.

Et d'autre part, cela ne répond pas à la question : pourquoi mes documents compilaient-ils il y a deux jours, et plus depuis ma réinstallation de MikTex ?

Pour préciser ma question initiale, j'ai pu constater que ce sont les chemins d'accès avec accents qui posent problème, mais pas ceux qui contiennent des espaces.

Si quelqu'un a une idée ?

Re: Chemins d'accès

MessagePosté: Jeudi 03 Mai 2018, 18:12
par Denis Bitouzé
En effet, le dossier dans lequel je stocke mon préambule est synchronisé avec un cloud, de sorte que je puisse l'utiliser aussi bien avec mon PC fixe qu'avec mon portable. Il faut donc que mon préambule soit dans un dossier bien précis de ma machine.


Je n'ai pas creusé la question, mais ça ne me paraît pas incompatible : quand on synchronise avec le cloud, n'a-t-on pas le choix du (sous-)dossier ?

Re: Chemins d'accès

MessagePosté: Jeudi 03 Mai 2018, 18:18
par Euher
Malheureusement je ne crois pas, mais je me trompe peut-être (il s'agit de OneDrive, qui crée un dossier du même nom sur mon PC, et c'est ce dossier tout entier qui est synchronisé).

Re: Chemins d'accès

MessagePosté: Jeudi 03 Mai 2018, 18:21
par Denis Bitouzé
Je ne connais que très mal Windows, mais peut-être pouvez-vous créer un lien symbolique ?

Re: Chemins d'accès

MessagePosté: Jeudi 03 Mai 2018, 18:27
par Euher
Je suis tout à fait désolé compte tenu du temps que vous prenez pour me répondre, mais la notion de "lien symbolique" m'échappe...

Re: Chemins d'accès

MessagePosté: Jeudi 03 Mai 2018, 18:29
par Euher
... ceci étant, je pense pouvoir me débrouiller avec le Beamer que vous m'avez indiqué initialement. Merci beaucoup !

Re: Chemins d'accès

MessagePosté: Jeudi 03 Mai 2018, 18:35
par Denis Bitouzé
Je suis tout à fait désolé compte tenu du temps que vous prenez pour me répondre, mais la notion de "lien symbolique" m'échappe...

Ceci peut aider à comprendre la notion de lien symbolique et à la mettre en œuvre sous Windows : https://www.linuxtricks.fr/wiki/les-lie ... us-windows.

Re: Chemins d'accès

MessagePosté: Vendredi 04 Mai 2018, 07:30
par pg
Euher a écrit:Depuis, mes documents ne compilent plus. J'ai remarqué que c'est sans doute le chemin d'accès de mon préambule qui pose problème, puisque si je le mets dans le même dossier que mon document, la compilation fonctionne.

La bonne façon de faire est de déclarer le répertoire contenant le préambule comme un "TEXMF root directory". Il faut aller dans "MikTeX Settings" onglet "Settings > Directories" et ajouter le répertoire. La procédure est détaillée par exemple ici (les captures d'écran concernent une veille version de windows, mais le principe a peu changé).

Attention, le répertoire choisi doit normalement avoir une structure particulière (voir ici). Mettre les fichiers de macros et préambule dans un sous-répertoire "tex" de ce répertoire devrait fonctionner.