Page 1 sur 1

Pb avec pygmentize

MessagePosté: Mercredi 03 Janvier 2018, 15:34
par fred_maths
Bonjour ,

j'ai ce problème a la compilation d'un doc latex sous windows 8:
Package minted Error: You must have `pygmentize' installed to use this package. \RequirePackage{minted}[2011/09/17]
j'ai regardé du coté de Python j'ai la dernière version et dans le dossier Scripts de
python j'ai bien Pygmentize.exe qui est installé
je ne piges pas pourquoi cela ne compile pas ...
Merci

Texlive 2017
Tex studio
windows 8

Re: Pb avec pygmentize

MessagePosté: Mercredi 03 Janvier 2018, 15:43
par fred_maths
j'ai essayé :

c:\Python36\Scripts>pip3.exe install Pygments
Requirement already satisfied: Pygments in c:\python36\lib\site-packages

ce qui m'indique que Pygments est déjà installé
je n'y piges rien
help !

Re: Pb avec pygmentize

MessagePosté: Mercredi 03 Janvier 2018, 16:20
par rebouxo
fred_maths a écrit:j'ai essayé :

c:\Python36\Scripts>pip3.exe install Pygments
Requirement already satisfied: Pygments in c:\python36\lib\site-packages

ce qui m'indique que Pygments est déjà installé
je n'y piges rien
help !


Ce n'est pas parce que c'est installé que c'est trouvé, manifestement c'est le problème. Un problème de PATH ? Tu as bien évidemment autorisé TeX à lancer des programmes externes ?
Autre possibilité, minted est en version 2.5 une grosse évolution.

Olivier

Re: Pb avec pygmentize

MessagePosté: Mercredi 03 Janvier 2018, 19:40
par OG
Bonsoir

Il faut aussi vérifier que la compilation LaTeX se fait avec l'option `shell-escape`
(puisqu'un programme annexe est lancé).

O.G.

Re: Pb avec pygmentize

MessagePosté: Mercredi 03 Janvier 2018, 20:45
par marco56
Et c'est quoi, le code ?