Page 1 sur 1

Version 2.10 et graph_pi

MessagePosté: Mardi 21 Juin 2011, 18:53
par maurice
Bonjour, depuis que je suis passé à la version 2.10 d'asymptote (hier), quand je compile un code avec l'extension graph_pi, j'obtiens le message d'erreur suivant :

Code: Tout sélectionner
$ asy ds9-1.asy
/home/Maurice/.asy/base_pi.asy: 32.53: no matching field or type of name 'userMin' in 'picture'
/home/Maurice/.asy/base_pi.asy: 32.67: no matching field or type of name 'userMin' in 'picture'
/home/Maurice/.asy/base_pi.asy: 33.53: no matching field or type of name 'userMax' in 'picture'
/home/Maurice/.asy/base_pi.asy: 33.67: no matching field or type of name 'userMax' in 'picture'
/home/Maurice/.asy/graph_pi.asy: 117.43: no matching variable 'pic.userMin.x'
/home/Maurice/.asy/graph_pi.asy: 118.43: no matching variable 'pic.userMax.x'
/home/Maurice/.asy/graph_pi.asy: 119.43: no matching variable 'pic.userMin.y'
/home/Maurice/.asy/graph_pi.asy: 120.43: no matching variable 'pic.userMax.y'
/home/Maurice/.asy/graph_pi.asy: 147.24: no matching field or type of name 'userMin' in 'picture'
/home/Maurice/.asy/graph_pi.asy: 147.49: no matching field or type of name 'userMax' in 'picture'
/home/Maurice/.asy/graph_pi.asy: 148.24: no matching field or type of name 'userMin' in 'picture'
/home/Maurice/.asy/graph_pi.asy: 148.49: no matching field or type of name 'userMax' in 'picture'
/home/Maurice/.asy/graph_pi.asy: 178.41: no matching variable 'pic.userMin.x'
/home/Maurice/.asy/graph_pi.asy: 179.40: no matching variable 'pic.userMax.x'
/home/Maurice/.asy/graph_pi.asy: 180.41: no matching variable 'pic.userMin.y'
/home/Maurice/.asy/graph_pi.asy: 181.40: no matching variable 'pic.userMax.y'
/home/Maurice/.asy/graph_pi.asy: 397.37: no matching variable 'pic.userMin.x'
/home/Maurice/.asy/graph_pi.asy: 397.54: no matching variable 'pic.userMax.x'
/home/Maurice/.asy/graph_pi.asy: 397.61: use of variable 'join' is ambiguous
/home/Maurice/.asy/graph_pi.asy: 417.21: no matching variable 'pic.userMin.x'
/home/Maurice/.asy/graph_pi.asy: 418.21: no matching variable 'pic.userMax.x'
/home/Maurice/.asy/graph_pi.asy: 421.21: no matching variable 'pic.userMin.y'
/home/Maurice/.asy/graph_pi.asy: 422.21: no matching variable 'pic.userMax.y'


Quelqu'un a-t-il remarqué la même chose ?

merci
Maurice

Re: Version 2.10 et graph_pi

MessagePosté: Mardi 21 Juin 2011, 21:05
par chellier
Même problème...

Christophe

Re: Version 2.10 et graph_pi

MessagePosté: Mardi 21 Juin 2011, 22:11
par OG
Bonsoir

N'est ce pas cette histoire de pic.userMin.x à changer en pic.userMin().x
et tous ses copains Min et y ?
(ça marche après avoir tout modifié)

O.G.

Re: Version 2.10 et graph_pi

MessagePosté: Mercredi 22 Juin 2011, 11:00
par chellier
Bien vu :wink:
En remplaçant tous les userMin et userMax en userMin() et userMax() dans graph_pi et base_pi, ça fonctionne.

Christophe

Re: Version 2.10 et graph_pi

MessagePosté: Mercredi 22 Juin 2011, 18:32
par Francky
Pourriez-vous mettre à disposition une version corrigée ?
À moins que pivaldi ne s'en occupe, on vient de le croiser.
Merci.

Re: Version 2.10 et graph_pi

MessagePosté: Mercredi 22 Juin 2011, 21:22
par OG
Voici

par contre il y avait eu des modifications à propos
du fil post112563.html?hilit=graph_pi#p112563
et je n'ai pas vérifier les miens.

Sous toute réserve

O.G.

Re: Version 2.10 et graph_pi

MessagePosté: Jeudi 23 Juin 2011, 17:38
par chellier
OG a écrit:Voici

par contre il y avait eu des modifications à propos
du fil post112563.html?hilit=graph_pi#p112563
et je n'ai pas vérifier les miens.

Sous toute réserve

O.G.

S'il y a des soucis, dites-le, je posterai ma version modifiée.

Christophe

Re: Version 2.10 et graph_pi

MessagePosté: Mercredi 29 Juin 2011, 12:10
par Ph. Ivaldi
Bonjour,

chellier a écrit:S'il y a des soucis, dites-le, je posterai ma version modifiée.
Christophe


S'il y a 36 versions des extensions qui se baladent sur le net ça vite devenir difficile de savoir laquelle est la bonne.
S'il y a un bug ou un problème dans un projet libre il faut commencer par contacter l'auteur pour l'en informer ; il me semble que c'est la moindre des choses.
Ensuite, s'il n'y a pas de réaction, on peut/doit effectivement forker ou patcher le projet.

J'en profite pour signaler la nouvelle adresse de mes extensions non officielles pour Asymptote.
Pour récupérer les extensions versionnées il suffit d'installer git et de lancer la commande
Code: Tout sélectionner
git clone git://piprime.fr/asymptote/pi-packages.git

Par la suite on met le code à jour, après s'être placé dans le répertoire du projet, par
Code: Tout sélectionner
git pull

Si quelqu'un veut un accès en écriture à un de mes dépôts git public il suffit de me contacter.
Si vous ne voulez pas utiliser git, il suffit de cliquer sur le lien snapshot de la dernière version.

Re: Version 2.10 et graph_pi

MessagePosté: Mercredi 29 Juin 2011, 20:47
par OG
Merci Philippe pour ce nouveau site et ces mises à jour.

Ok ok promis on ne bidouille plus tes fichiers sans t'en parler :)

O.G.