Page 1 sur 1

[Bug] Signature et édition

MessagePosté: Vendredi 29 Décembre 2006, 13:02
par kilébo
Bonjour,

Pourquoi la signature disparait après l'édition d'un message ?

Enfin, c'est ce qu'il me semble.

MessagePosté: Vendredi 29 Décembre 2006, 13:07
par Arnaud
On en a parlé dans le forum des modos, c'est un bug phpbb et on n'a pas encore trouvé ni la raison, ni la solution.

[Edit : dans tuto LaTeX pour être précis]

MessagePosté: Vendredi 29 Décembre 2006, 13:43
par nirosis
Oui on avait déjà vu. J'avais pas trouvé la solution... J'ai trouvé l'endroit où c'est géré dans le code mais c'est tout. Faudrait comparer avec le code original de phpbb voir si on a modifié qqchose par erreur... je regarderais encore un de ces 4 !

MessagePosté: Vendredi 29 Décembre 2006, 13:48
par Arnaud
Tu pourrais me c/c le code en question ? ( et me dire de quel fichier cela provient )

[Tentative d'edit pour tester]

MessagePosté: Vendredi 29 Décembre 2006, 17:01
par nirosis
Bug corrigé ;) enfin !
Cela se situait dans posting.php.

Code: Tout sélectionner
$select_sql = (!$submit) ? ', t.topic_title, p.enable_bbcode, p.enable_html, p.enable_smilies, p.enable_sig, p.post_username, pt.post_subject, pt.post_text, pt.bbcode_uid, u.username, u.user_id, u.user_sig_bbcode_uid,u.user_sig' : '';


L'oubli de u.user_sig à la fin de la requète. Je pense qu'on a dû provoquer cela lors d'une mise à jour ou lors de l'ajout d'un mod au forum.

MessagePosté: Vendredi 29 Décembre 2006, 17:08
par Arnaud
Bien joué nirosis :wink:

MessagePosté: Vendredi 29 Décembre 2006, 18:04
par MB
Oui, c'est bien ça.
Ca faisait longtemps qu'il trainait ce bug ! :D

MessagePosté: Vendredi 29 Décembre 2006, 18:20
par kilébo
Merci pour la réactivité !

MessagePosté: Vendredi 29 Décembre 2006, 19:17
par nirosis
De rien ! comme c'est les vacances, j'ai eu du temps pour regarder de plus près.

Sinon, hors sujet, mais pourquoi tu es en mode invisible kilébo ?

MessagePosté: Vendredi 29 Décembre 2006, 19:23
par kilébo
Parce que je trouvais qu'il y avait beaucoup de vert ;-) Je n'ai rien à cacher mais je me disais que cela pouvait inquiéter un néophyte.

MessagePosté: Vendredi 29 Décembre 2006, 22:30
par nirosis
Ah d'accord, je vois le concept ! :wink:

Re: [Bug] Signature et édition

MessagePosté: Lundi 03 Mars 2008, 09:06
par Thibault
Bonjour, puisque ce sujet parle de signature, une petite question... Peut-on mettre du code $\LaTeX$ dans une signature ?

Voilà, merci d'avance.

Re: [Bug] Signature et édition

MessagePosté: Lundi 03 Mars 2008, 18:45
par Arnaud
Cela ne fonctionne pas pour le moment.

Re: [Bug] Signature et édition

MessagePosté: Lundi 03 Mars 2008, 18:59
par Thibault
Ok, merci, ce n'est pas grave.

Re: [Bug] Signature et édition

MessagePosté: Lundi 10 Mars 2008, 17:03
par MB
Bonjour, à priori j'ai pas trop envie d'autoriser le code LaTeX dans les signatures (de même que les images en général) afin de préserver du mieux possible les performances du site (car les signatures sont affichées à de nombreuses reprises et se doivent d'être assez "légères").