[TeXLive] Version (et paquets Debian)

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Re: [TeXLive] Version (et paquets Debian)

Messagepar MB » Dimanche 03 Mai 2009, 11:36

François D. a écrit:je vois mal des composants TeX-Live « anciens » faire bon ménage avec des plus récents apportés par les backports ...


Justement, il semblerait que la version backports ne contiennent pas tous les paquets de la version oldstable (elle contient plutôt les exécutables mais pas spécialement les modules latex). Par exemple, j'ai besoin du module esvect qui est contenu dans texlive-fonts-extra (version oldstable). Mais on ne le trouve pas dans la liste des paquets backports.

Ca serait donc bien que texlive-fonts-extra soit conservé (ce qui semble être le cas au départ puisqu'il apparait dans la liste des paquets qui seront conservés). Mais à la fin on trouve :

Code: Tout sélectionner
Les actions suivantes permettront de résoudre ces dépendances :

Supprimer les paquets suivants :
latex-beamer
latex-xcolor
pgf
preview-latex-style
prosper
texlive
texlive-base
texlive-context
texlive-doc-base
texlive-fonts-extra
texlive-fonts-recommended
texlive-generic-extra
texlive-generic-recommended
texlive-latex-base
texlive-latex-extra
texlive-latex-recommended
texlive-math-extra
texlive-metapost
texlive-pictures
texlive-pstricks
texpower
texpower-manual


Donc on dirait bien qu'il veut me le supprimer au final ... Je ne comprends pas bien les messages (qui me semblent contradictoires) d'aptitude.
MB (Pas d'aide en Message Privé)
Merci d'utiliser $\LaTeX$ (voir ici) et d'éviter le style SMS pour la lisibilité des messages.
MB
Administrateur
 
Messages: 6890
Inscription: Samedi 28 Mai 2005, 13:23
Localisation: Créteil
Statut actuel: Actif et salarié | Enseignant

Publicité

Re: [TeXLive] Version (et paquets Debian)

Messagepar François D. » Dimanche 03 Mai 2009, 11:52

Le système de paquets Debian est robuste et efficace, mais pas infaillible ... Le remplacement de certains paquets, surtout s'ils ne sont pas strico sensu des paquets officels, peut rendre aptitude un peu bizarre.

À titre d'exemple, lorsque j'ai voulu supprimer le paquet d'un plugin inutile pour mon navigateur, le système me disait qu'il fallait aussi supprimer ... Gnome, rien que ça :( .

La solution pourrait être de télécharger les paquets backports et les installer à la main avec dpkg, l'utilitaire le plus basique de chez Debian : il est tellement basique qu'il ne gère pas les dépendances, il se contente de les indiquer en cas de problème.
François D.
Téra-utilisateur
 
Messages: 1370
Inscription: Dimanche 30 Juillet 2006, 09:04
Localisation: Alsace
Statut actuel: Actif et salarié | Enseignant

Re: [TeXLive] Version (et paquets Debian)

Messagepar MB » Dimanche 03 Mai 2009, 11:57

François D. a écrit:La solution pourrait être de télécharger les paquets backports et les installer à la main avec dpkg, l'utilitaire le plus basique de chez Debian : il est tellement basique qu'il ne gère pas les dépendances, il se contente de les indiquer en cas de problème.


ET il va écraser les anciens binaires de TeXLive 2005 ? (tout en conservant les modules)
MB (Pas d'aide en Message Privé)
Merci d'utiliser $\LaTeX$ (voir ici) et d'éviter le style SMS pour la lisibilité des messages.
MB
Administrateur
 
Messages: 6890
Inscription: Samedi 28 Mai 2005, 13:23
Localisation: Créteil
Statut actuel: Actif et salarié | Enseignant

Re: [TeXLive] Version (et paquets Debian)

Messagepar Arnaud » Dimanche 03 Mai 2009, 12:02

François D. a écrit:À titre d'exemple, lorsque j'ai voulu supprimer le paquet d'un plugin inutile pour mon navigateur, le système me disait qu'il fallait aussi supprimer ... Gnome, rien que ça :( .


Cela peut être tout à fait normal.
Le paquet gnome est un méta-paquet, et supprimer l'un de ses composants, supprime aussi le méta-paquet, mais ne désinstalle pas gnome.
Arnaud

Un peu d'info - Pyromaths
LaTeX - Exemples de formules LaTeX

Pas d'aide en MP (non plus)
Arnaud
Modérateur
 
Messages: 7115
Inscription: Lundi 28 Août 2006, 12:18
Localisation: Allemagne
Statut actuel: Actif et salarié | Enseignant

Re: [TeXLive] Version (et paquets Debian)

Messagepar François D. » Dimanche 03 Mai 2009, 13:00

@MB : non, en fait dpkg va installer ce que tu lui dis d'installer, basta, sans installer ou désinstaller automatiquement des paquets supplémentaires pour satisfaire les dépendances. En cas de souci de dépendances, il te dit qu'il y a un problème, c'est tout ; je me demande d'ailleurs s'il n'y a pas une option de dpkg permettant de passer outre un éventuel problème de ce type ...

@Arnaud : euh ... tu as déjà essayé ;) ?
François D.
Téra-utilisateur
 
Messages: 1370
Inscription: Dimanche 30 Juillet 2006, 09:04
Localisation: Alsace
Statut actuel: Actif et salarié | Enseignant

Re: [TeXLive] Version (et paquets Debian)

Messagepar Arnaud » Dimanche 03 Mai 2009, 14:22

François D. a écrit:@Arnaud : euh ... tu as déjà essayé ;) ?


Oui, plusieurs fois, et avec le méta-paquet kde également ;)
Par contre, il semblerait que cela ait effectivement désinstallé tout le paquet kde ( ou gnome ) chez certains ( je viens de voir ça sur le web ).
Je dois être sacrément chanceux.
Arnaud

Un peu d'info - Pyromaths
LaTeX - Exemples de formules LaTeX

Pas d'aide en MP (non plus)
Arnaud
Modérateur
 
Messages: 7115
Inscription: Lundi 28 Août 2006, 12:18
Localisation: Allemagne
Statut actuel: Actif et salarié | Enseignant

Re: [TeXLive] Version (et paquets Debian)

Messagepar MB » Dimanche 03 Mai 2009, 16:10

J'ai bien envie de tenter d'installer la version 2008 en suivant cette procédure issue du blog de mpg.
Vous en pensez quoi ? Quelqu'un a déjà tenté sur un Debien (Etch ou Lenny) ?

Ca me fait penser que j'aurais surement dû utiliser equivs lorsque j'ai installé Asymptote via compilation des sources SVN.

[PS] A quoi correspond la commande ci-dessous ?

Code: Tout sélectionner
cd !$
MB (Pas d'aide en Message Privé)
Merci d'utiliser $\LaTeX$ (voir ici) et d'éviter le style SMS pour la lisibilité des messages.
MB
Administrateur
 
Messages: 6890
Inscription: Samedi 28 Mai 2005, 13:23
Localisation: Créteil
Statut actuel: Actif et salarié | Enseignant

Re: [TeXLive] Version (et paquets Debian)

Messagepar Arnaud » Lundi 04 Mai 2009, 17:43

MB a écrit:[PS] A quoi correspond la commande ci-dessous ?

Code: Tout sélectionner
cd !$


Recopie le dernier chemin donné dans la commande cd, et permet d'économiser du temps d'écriture.

Par exemple :

Code: Tout sélectionner
mkdir trucmuche/delamort/quitue
cd !$


Va produire :

Code: Tout sélectionner
cd trucmuche/delamort/quitue
Arnaud

Un peu d'info - Pyromaths
LaTeX - Exemples de formules LaTeX

Pas d'aide en MP (non plus)
Arnaud
Modérateur
 
Messages: 7115
Inscription: Lundi 28 Août 2006, 12:18
Localisation: Allemagne
Statut actuel: Actif et salarié | Enseignant

Re: [TeXLive] Version (et paquets Debian)

Messagepar MB » Dimanche 10 Mai 2009, 17:21

Après installation de TeXLive 2008 sur une Debian Etch de test, je constate que le problème de décalage entre l'eps produit par Asymptote sous Windows et celui produit par Asymptote sous Linux n'est pas résolu. En utilisant l'option -tex pdflatex j'obtiens deux pdf identiques sous Linux et sous Windows (et les marges semblent correctes). J'obtiens par exemple le résultat suivant à l'affichage sur un phpBB :

formules_inline.png
Formules en ligne
formules_inline.png (6.82 Kio) Vu 617 fois


L'alignement vertical est globalement correct sur ces exemples.

formules_center.png
Formules centrées
formules_center.png (5.71 Kio) Vu 613 fois


On peut cependant constater un effet de flou un peu pénible et que je parviens pas à supprimer avec Imagemagick. J'utilise pour l'instant la commande suivante :

Code: Tout sélectionner
convert -density 900 img.pdf -transparent white -quality 90 -depth 8 -resample 112 img.png


Autre considération importante : la rapidité.

Asymptote est clairement plus rapide sous Linux que sous Windows (pas de problème puisque le serveur est un Linux). Par contre, le traitement des PDF par convert est plus rapide que celui des EPS sous Windows mais plus lent sous Linux. Il aurait donc été préférable de rester avec des EPS (mais je ne sais pas pourquoi on a ce décalage sous Linux).
MB (Pas d'aide en Message Privé)
Merci d'utiliser $\LaTeX$ (voir ici) et d'éviter le style SMS pour la lisibilité des messages.
MB
Administrateur
 
Messages: 6890
Inscription: Samedi 28 Mai 2005, 13:23
Localisation: Créteil
Statut actuel: Actif et salarié | Enseignant

Re: [TeXLive] Version (et paquets Debian)

Messagepar GMaths » Dimanche 10 Mai 2009, 19:12

MB a écrit:On peut cependant constater un effet de flou un peu pénible


effectivement :lol:

  • pas bien sûr que la grande valeur de density améliore quoi que ce soit
  • le flou vient du resample ; sans et avec un density moindre... ce sera plus net, non ?
GMaths
Exa-utilisateur
 
Messages: 2031
Inscription: Lundi 01 Octobre 2007, 09:20
Statut actuel: Actif et salarié | Enseignant

Re: [TeXLive] Version (et paquets Debian)

Messagepar MB » Dimanche 10 Mai 2009, 20:04

Oui, en n'augmentant pas la résolution de lecture on obtient moins de flou (et des fichiers plus légers).
Je voulais éventuellement tenter d'éviter ce genre de problème et j'avais aussi lu cette page concernant l'usage des images vectorielles avec imagemagick.
MB (Pas d'aide en Message Privé)
Merci d'utiliser $\LaTeX$ (voir ici) et d'éviter le style SMS pour la lisibilité des messages.
MB
Administrateur
 
Messages: 6890
Inscription: Samedi 28 Mai 2005, 13:23
Localisation: Créteil
Statut actuel: Actif et salarié | Enseignant

Précédente

Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Grapeshot [Crawler] et 16 invités