Problème Latex, références figures fausses !

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Problème Latex, références figures fausses !

Messagepar bonoboTeX » Lundi 28 Juin 2010, 10:09

Bonjour,

J'écris pour un peu d'aide sous LateX, que j'utilise depuis peu car ayant commencé à rédiger un article avec des mathématiciens (moi je suis écologiste à la base), j'ai bien du m'y mettre !

Cependant j'ai un problème dans mon fichier Latex que je n'arrive pas à résoudre (mes mathématiciens non plus d'ailleur) !

J'ai ajouté des figures, et lorsque je les cites dans le texte, systématiquement il apparaît fig. 5 !!! alors que ben y a une figure 1, 2, 3, 4, 5 .... même pour mes tables ça me met toujours table 5 lorsque je compile !!! j'ai vérifié toutes les occurances, normalement j'ai pas fait de fautes !!

j'ai inclu les figures comme ceci :

Code: Tout sélectionner
\begin{figure}[p]
   \centering
      \includegraphics[width=1.00\textwidth]{Thum.png}
   \label{FTHUM}
   \caption{Example of thumbnails of the ten identified zooplankton taxonomic groups}
\end{figure}

et dans le texte j'utilise \ref{FTHUM} pour les citer ! toutes mes figures sont en png.


Je vois vraiment pas ce qu'il se passe et pourquoi ça marche pas !!

si quelqu'un a déjà eu ce problème je suis à l'écoute !!


j'utilise windows vista 32 bits, TeXniccenter et Miktex 2.8,

l'entête de mon document est la suivante (classe elsarticle depuis elsevier):

Code: Tout sélectionner
\documentclass[review,authoryear,times,12pt]{elsarticle}

\usepackage{amssymb}
\usepackage[latin1]{inputenc}
\usepackage{pifont}
\usepackage{natbib}
\usepackage{multirow}
\usepackage{graphicx}
\usepackage{graphics}
\usepackage{lineno}
\usepackage{array}
\usepackage{booktabs}
\biboptions{semicolon,round}
\usepackage{fancyhdr}


Merci beaucoup !
bonoboTeX
Utilisateur
 
Messages: 2
Inscription: Lundi 28 Juin 2010, 09:59
Statut actuel: Post-bac | Doctorat

Publicité

Re: Problème Latex, références figures fausses !

Messagepar pg » Lundi 28 Juin 2010, 10:20

Mettre les \label après les \caption, pas avant.
pg
Modérateur
 
Messages: 2592
Inscription: Jeudi 14 Juin 2007, 23:31

Re: Problème Latex, références figures fausses !

Messagepar bonoboTeX » Lundi 28 Juin 2010, 10:31

ah oui c'était bien ça !
label après caption ! merci !!!
bonoboTeX
Utilisateur
 
Messages: 2
Inscription: Lundi 28 Juin 2010, 09:59
Statut actuel: Post-bac | Doctorat


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Ahrefs [Bot], Grapeshot [Crawler] et 23 invités