Problème de compilation avec hbox

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Problème de compilation avec hbox

Messagepar Cp1n.N3m0 » Dimanche 12 Janvier 2020, 20:06

Bonjour,
J'essaie de compiler mon document LaTeX et je me retrouve, dans la console, avec une ligne qui me dit :
"Underfull \hbox (badness 10000) in paragraph at lines 10781 -- 10787"
Ce n'est pas la première fois que je vois ce message, et je pensais qu'on pouvait l'ignorer ; que dans le pire des cas il y aurait un saut de ligne pas très naturel. Mais là ma compilation refuse d'aller plus loin. Je l'ai laissé tourner pendant 15 bonnes minutes ça reste bloqué sur cette ligne sans aller plus loin.

Les lignes en question :

Code: Tout sélectionner
\item[$\bullet$] Supposons $\exists Q\in K[X]|P=\displaystyle{\prod_{i=1}^{p+1}{(X-a_{i})^{m_{i}}}}Q$\\
avec $\forall j\in [\![1;p+1]\!]$, $\widetilde{Q}(a_{j})\ne 0$\\
$\forall i \in [\![1;p+1]\!]$, définissions $Q_{i}$ : \\
$Q_{i}=\displaystyle{\prod_{\stackrel{j\in [\![1;p+1]\!]}{j \ne i}}{(X-a_{j})^{m_{j}}}}Q$\\
Alors $P=(X-a_{i})^{m_{i}}Q_{i}$ avec $\widetilde{Q_{i}}(a_{i})=\displaystyle{\prod_{\stackrel{j\in [\![1;p+1]\!]}{j \ne i}}{(a_{i}-a_{j})^{m_{j}}}}\widetilde{Q}(a_{i})\ne 0$\\
Donc $\forall i\in [\![1;p+1]\!]$, $a_{i}$ est une racine de $P$ de multiplicité $m_{i}$\\
\item[$\bullet$] Supposons que $\forall i\in [\![1;p+1]\!]$, $a_{i}$ soit une racine de $P$ de multiplicité $m_{i}$\\


J'ai essayé de retirer les \\ juste avant le second \item, cela a fonctionné ! mais la compilation a alors décidé de bloquer plus haut, sur un problème similaire (\\ avant un \item), et si je les supprimais, ca remontait.

Sauf que je n'ai pas trop envie de remonter mes 11000 lignes de codes pour enlever ces retours à la ligne qui font respirer mon textes.

Mon entête si ca peut aider :

Code: Tout sélectionner
\documentclass[a4paper, 11pt]{report}

\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[french]{babel}
\usepackage{layout}
\usepackage[top=3cm, bottom=3cm, left=2.5cm, right=2.5cm]{geometry}
\usepackage{setspace}
\usepackage{soul}
\usepackage{ulem}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{mathrsfs}
\usepackage{tikz, tkz-tab}
\usepackage{float}
\usepackage{changepage}
\usepackage{mathrsfs}
\usepackage{multirow}

\setcounter{secnumdepth}{0}
\tikzset { domaine/.style 2 args={domain=#1:#2} }
\newcommand{\R}[0]{\mathbb{R}}
\newcommand{\N}[0]{\mathbb{N}}
\newcommand{\C}[0]{\mathbb{C}}
\newcommand{\Z}[0]{\mathbb{Z}}
\newcommand{\mbb}[1]{\mathbb{#1}}
\newcommand{\mscr}[1]{\mathscr{#1}}
\newcommand{\mcal}[1]{\mathcal{#1}}
\newcommand{\mfrak}[1]{\mathfrak{#1}}
\newcommand{\floor}[1]{\lfloor #1 \rfloor}
\newcommand{\ceil}[1]{\lceil #1 \rceil}
\newcommand{\limit}[3]{#1 \underset{#2}{\longrightarrow} #3}

\makeatletter
\newcommand{\parttext}[1]{\def\@parttext{#1}}
\def\@endpart{\vskip 0pt plus 0.5fil
              \begin{formatparttext}
                \@parttext
                \gdef\@parttext{}
             \end{formatparttext}
              \vskip 0pt plus 0.5fil
              \newpage
              \if@twoside
               \if@openright
                \null
                \thispagestyle{empty}
                \newpage
               \fi
              \fi
              \if@tempswa
                \twocolumn
              \fi}
\makeatother
\makeatletter
\renewcommand{\thesection}{\@arabic\c@section}
\makeatother

\newenvironment{formatparttext}{\begin{adjustwidth}{50pt}{50pt}}{\end{adjustwidth}}


Merci d'avance de vos réponses !
Cp1n.N3m0
Utilisateur
 
Messages: 2
Inscription: Dimanche 12 Janvier 2020, 19:56
Statut actuel: Post-bac | CPGE

Publicité

Re: Problème de compilation avec hbox

Messagepar gigiair » Dimanche 12 Janvier 2020, 21:07

Il faudrait confectionner un ECM.
Procéder par dichtomie : diviser le document approximativement en deux partie dont une est commentée (par exemple dans un environnement comment du package éponyme)
Si la compilation ne produit pas d'erreur, déplacer la mise en commentaire sur la partie ne produisant pas d'erreur et recommencer avec la partie qui cause l'erreur.
La convergence étant quadratique, on peut arriver relativement rapidement à un fichier minimal ou quasi-minimal.
Si l'on ne trouve pas l'erreur poster ici l'ECM.
Les causes d'erreur étant innombrables, l'analyseur syntaxique n'identifie que les causes les plus triviales, S'il ne la détecte pas, le message qu'il renvoie n'est en général pas d'une très grande utilité.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2452
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Problème de compilation avec hbox

Messagepar Cp1n.N3m0 » Dimanche 12 Janvier 2020, 22:25

Merci beaucoup !
Je ne sais pas vraiment ce qui causait le problème en lui même, mais cela a permis de repérer pas mal d'erreur (oubli d'accolades, fautes de frappes) qui, je pense, se sont accumulées pour tout casser.
Je retiens la méthode, c'est sur que c'est plus facile que de se retaper tout le texte !
Merci encore.
Cp1n.N3m0
Utilisateur
 
Messages: 2
Inscription: Dimanche 12 Janvier 2020, 19:56
Statut actuel: Post-bac | CPGE


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Bing [Bot], Google [Bot], Grapeshot [Crawler], touhami et 7 invités