Problème d'affichage dvi

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Problème d'affichage dvi

Messagepar Zinky » Dimanche 07 Mai 2017, 16:55

Bonjour tout le monde,
J'utilise LaTeX depuis pas mal de temps. Je viens de réinstaller Miktex et je commence à avoir des bizarreries.
Lorsque je compile un fichier qui contient des commandes PSTricks la commande uput ne fonctionne pas bien. et lorsque, avec le même dvi, je fabrique le ps et ensuite le pdf, l'affichage est correct.
Je vous joins un exemple :
Mon code :
Code: Tout sélectionner
\begin{document}
\pagestyle{fancy}
\begin{pspicture}(0,0)(5,4)
\pspolygon(1,3)(2,1)(4,2)
\uput[ul](1,3){A}
\uput[d](2,1){B}
\uput[r](4,2){C}
\end{pspicture}

Mon dvi
Image

Mon pdf
Image
Merci pour votre aide.
Zinky
Utilisateur
 
Messages: 2
Inscription: Dimanche 07 Mai 2017, 16:23
Statut actuel: Post-bac

Publicité

Re: Problème d'affichage dvi

Messagepar Zinky » Dimanche 07 Mai 2017, 17:04

Rebonjour,
voici mes images
Mon dvi
Image

Mon pdf
Image
Zinky
Utilisateur
 
Messages: 2
Inscription: Dimanche 07 Mai 2017, 16:23
Statut actuel: Post-bac

Re: Problème d'affichage dvi

Messagepar balf » Dimanche 07 Mai 2017, 20:41

Bonsoir,

Je n'ai pas de problème pour compiler ce code. L'affichage des \uput ou \rput, ainsi que les rotations ont toujours eu des problèmes avec Yap.

Cela dit, vous pouvez compiler directement au format .pdf, soit en compilant avec xelatex, soit avec pdflatex en chargeant l'extension auto-pst-pdf (après pstricks), et en lançant pdflatex avec l'option --enable-write18.

B. A.
Dernière édition par balf le Jeudi 18 Mai 2017, 19:55, édité 1 fois.
balf
Zetta-utilisateur
 
Messages: 3584
Inscription: Mercredi 02 Janvier 2008, 23:18
Statut actuel: Actif et salarié | Maître de conférence

Re: Problème d'affichage dvi

Messagepar jcs » Lundi 08 Mai 2017, 09:31

Bonjour

avec yap il y a souvent un problème au départ le RenderMethod est par défaut pk au lieu de Dvips

en changeant cette option ensuite je n'ai pas (trop) de problèmes

je ne sais d'ailleurs pas à quoi correspond cette option pk
jcs
Téra-utilisateur
 
Messages: 1348
Inscription: Lundi 24 Novembre 2008, 22:17
Statut actuel: Actif et salarié | Enseignant

Re: Problème d'affichage dvi

Messagepar balf » Lundi 08 Mai 2017, 10:22

Les fichiers .pk sont des fichiers de police bitmap (adaptés à une imprimante donnée – par défaut, c'es HP LaserJetFour). Donc si l'on zoome l'affichage, on voit apparaître des effets d'escalier à l'écran, mais c'est un affichage très rapide (après que les fichiers bitmap ont été créés). Le rendu via dvips à l'inverse utilise le fichier postcript fabriqué au préalable par dvips, et utilise donc les polices postscript (vectorielles).

Ceci ne concerne que la compilation latex, qui produit uin fichier .dvi (DeVice Independent), transformé ensuite en fichier .ps, puis .pdf, via dvips + pstopdf, ou bien directement en .pdf, via dvipdfm.

B. A.
balf
Zetta-utilisateur
 
Messages: 3584
Inscription: Mercredi 02 Janvier 2008, 23:18
Statut actuel: Actif et salarié | Maître de conférence

Re: Problème d'affichage dvi

Messagepar jcs » Lundi 08 Mai 2017, 11:33

merci beaucoup pour ces informations
jcs
Téra-utilisateur
 
Messages: 1348
Inscription: Lundi 24 Novembre 2008, 22:17
Statut actuel: Actif et salarié | Enseignant


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Bing [Bot], Google [Bot], Google Adsense [Bot], touhami, Yahoo [Bot] et 16 invités