Problème d'accent trema avec Bibtex

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Problème d'accent trema avec Bibtex

Messagepar granfada » Mardi 15 Septembre 2009, 13:24

Bonjour,
j'ai actuellement des problèmes avec la gestion des accents trémas dans bibtex. Les accents \' ,\` ou \^ passe bien mais pour le \" (le trema) je n'obtiens rien et le reste de l'entrée est effacée.
Par exemple pour

Code: Tout sélectionner
@Article{bgvdm,
  author =        " Berlinet, A. and Gy\"orfi, L. and van der Meulen, E. ",
  title =         " Asymptotic normality of relative entropy in multivariate density estimation ",
  journal =       " Publications de l'Institut de Statistiques de l'Universit\'e de Paris  ",
  volume =        " 41 ",
  year =          " 1997 ",
 pages = "  3-27 "
}

J'obtiens [Berlinet and Gy ] sur le pdf généré.

Sa me laisse d'autant plus sans solutions que les tremas passent très bien sur le fichier .tex qui appelle cette biblio.

Merci d'avance.
granfada
Utilisateur
 
Messages: 8
Inscription: Mardi 15 Septembre 2009, 13:18
Statut actuel: Post-bac | Doctorat

Publicité

Re: Problème d'accent trema avec Bibtex

Messagepar pg » Mardi 15 Septembre 2009, 13:39

C'est parce que bibtex croit que le " dans \" marque la fin de l'entrée author = "...". Pour contourner le problème, tu peux soit taper directement le ö si tu utilises inputenc soit mettre des accolades autour du nom qui pose problème :

Code: Tout sélectionner
{Gy\"orfi}
pg
Modérateur
 
Messages: 2592
Inscription: Jeudi 14 Juin 2007, 23:31

Re: Problème d'accent trema avec Bibtex

Messagepar granfada » Mardi 15 Septembre 2009, 13:42

pg a écrit:C'est parce que bibtex croit que le " dans \" marque la fin de l'entrée author = "...". Pour contourner le problème, tu peux soit taper directement le ö si tu utilises inputenc soit mettre des accolades autour du nom qui pose problème :

Code: Tout sélectionner
{Gy\"orfi}


Franchement merci beaucoup j'étais vraiment en train de galérer.

Et là ça marche !
granfada
Utilisateur
 
Messages: 8
Inscription: Mardi 15 Septembre 2009, 13:18
Statut actuel: Post-bac | Doctorat


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Bing [Bot], Google Adsense [Bot], Yandex [Bot] et 14 invités