Problème avec tkzfct, gnuplot et windows 8

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar charles » Samedi 06 Septembre 2014, 15:04

J'avais déjà testé avec "compilation rapide".
Ces nouvelles manipulations n'ont rien changé : c'est l'échec. Je n'ai même plus aucune compilation (la présence du nombre 80, que je change au gré des compilations, dans le code du fichier.tex l'atteste)
charles
Déca-utilisateur
 
Messages: 20
Inscription: Samedi 31 Mai 2014, 13:04
Statut actuel: Actif et salarié | Enseignant

Publicité

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar kojak » Samedi 06 Septembre 2014, 15:08

charles a écrit:J'avais déjà testé avec "compilation rapide".


Oui, mais est ce que tu as bien coché ta commande utilisateur du menu options / configurer/ etc ? voir image jointe
Fichiers joints
compil2.png
pas d'aide par MP
kojak
Modérateur
 
Messages: 10404
Inscription: Samedi 18 Novembre 2006, 19:50
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar charles » Samedi 06 Septembre 2014, 15:22

J'avais déjà testé "compilation rapide".
Après ces nouvelles manipulations appliquées à la lettre, c'est l'échec complet : plus aucune compilation ne se produit (dans mon code, j'ai changé le nombre 80 en 90 mais le fichier pdf n'en tient pas compte après compilation avec "compilation rapide" )
charles
Déca-utilisateur
 
Messages: 20
Inscription: Samedi 31 Mai 2014, 13:04
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar charles » Samedi 06 Septembre 2014, 15:24

Oui, "Utilisateur" est bien cochée
charles
Déca-utilisateur
 
Messages: 20
Inscription: Samedi 31 Mai 2014, 13:04
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar kojak » Samedi 06 Septembre 2014, 15:34

charles a écrit:Oui, "Utilisateur" est bien cochée
où il y a bien la bonne commande ?
Code: Tout sélectionner
latex -shell-escape -interaction=nonstopmode %.tex|dvips -o %.ps %.dvi|ps2pdf %.ps


charles a écrit:plus aucune compilation ne se produit
Quel est le message d'erreur ?

Donc on reprend : déjà tu fais du grand ménage dans tous tes fichiers, de façon à n'avoir plus qu'un seul fichier tex avec le code gnuplot.

Ensuite, tu t'assures que ta commande utilisateur est bien celle rappelée ci dessus ( avec l'option shell escape ) dans le menu compil rapide et quelle est bien cochée.

Tu compiles alors ton fichier tex avec cette commande Compil rapide.

Enfin Voir Pdf et là tu dois avoir ton beau fichier pdf avec tes courbes.
pas d'aide par MP
kojak
Modérateur
 
Messages: 10404
Inscription: Samedi 18 Novembre 2006, 19:50
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar charles » Dimanche 07 Septembre 2014, 09:05

J'ai éliminé tous les fichiers qui faisaient appel à gnuplot, ne gardant que testkz.tex. J'ai suivi les procédures indiquées dans ton dernier message à la lettre :
1) pas de compilation et le message :
Code: Tout sélectionner
testkz.dvi

: No such file or directory

This is dvips(k) 5.993 Copyright 2013 Radical Eye Software (www.radicaleye.com) dvips: DVI file can't be opened:

Process exited with error(s)

2) quand je clique sur "Voir pdf" : fichier non trouvé
3) aucun fichier table.tex n'est généré

J'ai l'impression de régresser car il me semble que gnuplot n'est plus trouvé.
charles
Déca-utilisateur
 
Messages: 20
Inscription: Samedi 31 Mai 2014, 13:04
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar kojak » Dimanche 07 Septembre 2014, 10:37

Bonjour,

Code: Tout sélectionner
testkz.dvi

: No such file or directory

Ceci signifie que le fichier dvi n'a pas été créé, donc la commande latex n'a pas été réalisée. Tu as compilé avec quelle commande ? Dans ta commande utilisateur de compil rapide, qui doit être cochée, as tu bien ceci ?

Code: Tout sélectionner
latex -shell-escape -interaction=nonstopmode %.tex|dvips -o %.ps %.dvi|ps2pdf %.ps


Est ce que tu compiles bien avec Compilation Rapide ?

charles a écrit:2) quand je clique sur "Voir pdf" : fichier non trouvé
Normal car comme il n'y a pas le dvi, il n'y a pas non plus le ps ni le pdf.

charles a écrit:3) aucun fichier table.tex n'est généré
ce qui correspond à ma première remarque.

Réessaie en ligne de commande pour voir si ça fonctionne.

Si tel est le cas, c'est que ton install est toujours correcte, et donc il te faut paramétrer correctement ton éditeur avec les indications données précédemment.
pas d'aide par MP
kojak
Modérateur
 
Messages: 10404
Inscription: Samedi 18 Novembre 2006, 19:50
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar charles » Dimanche 07 Septembre 2014, 13:42

J'ai toujours ce message :
Code: Tout sélectionner
Process started

testkz.dvi

: No such file or directory

This is dvips(k) 5.993 Copyright 2013 Radical Eye Software (www.radicaleye.com) dvips: DVI file can't be opened:

Process exited with error(s)

La commande utilisateur de compil rapide est bien cochée et j'ai copié/collé la commande envoyée.
Oui, je compile bien avec Compilation rapide.
En ligne de commandes, tout fonctionne à merveille ; j'ai beau paramétré mon éditeur texmaker comme indiqué, il ne veut rien savoir !
charles
Déca-utilisateur
 
Messages: 20
Inscription: Samedi 31 Mai 2014, 13:04
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar kojak » Dimanche 07 Septembre 2014, 14:06

C'est donc un pb de paramétrage de Texmaker.

Pour info, tu as quoi dans la ligne Options/ configure Texmaker / Commande et la première ligne latex ?

Tu as bien que ceci ?
Code: Tout sélectionner
latex -interaction=nonstopmode %.tex


Dans la commande utilisateur : tu as bien laissé une espace entre latex et -shell-escape ? une espace entre ceci et -interaction=nonstopmode ? pas d'espace au niveau du = ?

Moi, sous linux, ça fonctionne nickel.

Sinon, faudrait voir avec l’auteur de Texmaker, Pascal. Il passe régulièrement ici, ou sinon lui envoyer un mail que tu trouveras  
pas d'aide par MP
kojak
Modérateur
 
Messages: 10404
Inscription: Samedi 18 Novembre 2006, 19:50
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar charles » Dimanche 07 Septembre 2014, 20:34

Quel est le mail perso de Pascal ? En attendant, un grand merci pour ton aide et ta patience.
charles
Déca-utilisateur
 
Messages: 20
Inscription: Samedi 31 Mai 2014, 13:04
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar charles » Dimanche 07 Septembre 2014, 20:59

Eurêka !
Ta configuration pour texmaker fonctionne ! J'ai fini par trouver ce qui bloquait : dans Options-Configurer texmaker-Commandes, la case "Build" était cochée et ce détail (...) rendait introuvable le fichier dvi car ce dernier se nichait dans le dossier Build automatiquement créé ! Je vais enfin profiter de tkz-fct qui permet de créer la grille de graphique désirée, les axes et qui adapte automatiquement le tracé de la courbe (tu auras compris que j'apprécie beaucoup ce que fait Altermundus)

Je tiens très sincèrement à remercier tous ceux qui ont participé à cette "enquête" et tout particulièrement Kojac pour ses connaissances, son talent mais aussi et surtout pour sa disponibilité et sa patience infinie.
charles
Déca-utilisateur
 
Messages: 20
Inscription: Samedi 31 Mai 2014, 13:04
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar kojak » Mardi 09 Septembre 2014, 07:00

Bonjour,

A la place de ma commande, un peu longue, utilisant la chaine latex+dvips+ps2pdf, tu peux y mettre pdflatex mais sans oublier l'option shell escape.Comme indiqué aussi, tu peux y ajouter à la fin VoirPdf, comme ça, quand tu compiles avec cette commande utilisateur, le pdf s'affiche tout seul à la fin.
pas d'aide par MP
kojak
Modérateur
 
Messages: 10404
Inscription: Samedi 18 Novembre 2006, 19:50
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar adem19s » Mercredi 10 Septembre 2014, 17:36

kojak a écrit:Bonjour,

A la place de ma commande, un peu longue, utilisant la chaine latex+dvips+ps2pdf, tu peux y mettre pdflatex mais sans oublier l'option shell escape.Comme indiqué aussi, tu peux y ajouter à la fin VoirPdf, comme ça, quand tu compiles avec cette commande utilisateur, le pdf s'affiche tout seul à la fin.

bonsoir mr kojak...pour moi le problème n'est pas encore résolu.je reçois toujours l'erreur mon_fichier.table not found.lorsque j'ai ouvert le fichier bin ,j'ai trouvé des fichiers qui portaient le nom gnuplot et d'autres wgnuplot.
sachant que je compile avec compilation d'utilisateur:
Code: Tout sélectionner
latex -shell-escape -interaction=nonstopmode %.tex|dvips -o %.ps %.dvi|ps2pdf %.ps
adem19s
Kilo-utilisateur
 
Messages: 155
Inscription: Mercredi 22 Mai 2013, 18:59
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar kojak » Mercredi 10 Septembre 2014, 17:52

bonjour,

Avant de compiler avec l'éditeur, essaie en ligne de commande afin de vérifier si ton install de gnuplot est correcte.

Code: Tout sélectionner
latex -shell-escape -interaction=nonstopmode mon_beau_fichier.tex
pas d'aide par MP
kojak
Modérateur
 
Messages: 10404
Inscription: Samedi 18 Novembre 2006, 19:50
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar adem19s » Mercredi 10 Septembre 2014, 18:08

kojak a écrit:bonjour,

Avant de compiler avec l'éditeur, essaie en ligne de commande afin de vérifier si ton install de gnuplot est correcte.

Code: Tout sélectionner
latex -shell-escape -interaction=nonstopmode mon_beau_fichier.tex

je pense que gnuplot fonctionne normalement pare ce que j'ai tracé des courbes de quelques fonctions.
adem19s
Kilo-utilisateur
 
Messages: 155
Inscription: Mercredi 22 Mai 2013, 18:59
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar kojak » Mercredi 10 Septembre 2014, 19:19

adem19s a écrit:je pense que gnuplot fonctionne normalement pare ce que j'ai tracé des courbes de quelques fonctions.

C'est pas je pense, c'est qu'il faut en être sur et certain qu'en ligne de commande cça compile bien.

D'après balf, si tu as MikTeX, ce serait pas shell escape mais enable write 18 : voir ton sujet initial. Donc je réitère ma demande, est ce que ça compile en ligne de commande ?
pas d'aide par MP
kojak
Modérateur
 
Messages: 10404
Inscription: Samedi 18 Novembre 2006, 19:50
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar adem19s » Mercredi 10 Septembre 2014, 19:55

kojak a écrit:
adem19s a écrit:je pense que gnuplot fonctionne normalement pare ce que j'ai tracé des courbes de quelques fonctions.

C'est pas je pense, c'est qu'il faut en être sur et certain qu'en ligne de commande cça compile bien.

D'après balf, si tu as MikTeX, ce serait pas shell escape mais enable write 18 : voir ton sujet initial. Donc je réitère ma demande, est ce que ça compile en ligne de commande ?

je travaille sur miktex2.9+texmaker+xp...pour ta question je n'ai pas compris qu'est ce qu'il faut faire!
j'ai placé dans la utilisateur le code suivant:
Code: Tout sélectionner
latex --enable-write18 -interaction=nonstopmode %.tex|dvips -o %.ps %.dvi|ps2pdf %.ps

autre chose ma version de tikz est :
Code: Tout sélectionner
\ProvidesPackageRCS[v\pgfversion] $Header: /cvsroot/pgf/pgf/generic/pgf/frontendlayer/tikz/tikz.code.tex,v 1.76 2010/10/13 09:20:31 ludewich Exp $
adem19s
Kilo-utilisateur
 
Messages: 155
Inscription: Mercredi 22 Mai 2013, 18:59
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar kojak » Jeudi 11 Septembre 2014, 06:59

Pour l'instant, tu laisses tomber ton éditeur, mais tu compiles en ligne de commande afin de voir si ça compile bien. Une fois que ça fonctionnera tel quel, le paramétrage de ton éditeur se fera ensuite.

Pour compiler en ligne de commande, il faut ouvrir une console, se déplacer à coup de cd dans le répertoire de ton fichier tex, et ensuite lancer la commande

Code: Tout sélectionner
latex -shell-escape -interaction=nonstopmode mon_beau_fichier.tex
pas d'aide par MP
kojak
Modérateur
 
Messages: 10404
Inscription: Samedi 18 Novembre 2006, 19:50
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar adem19s » Lundi 29 Septembre 2014, 19:23

kojak a écrit:
charles a écrit:Texmaker est récalcitrant (ou je n'ai pas bien compris les consignes)
C'est plutôt la seconde possibilité :wink:

charles a écrit:aussi un choix intitulé "Utilisateur :( % nom fichier sans extension)". C'est dans la ligne juste au-dessous ce choix que j'ai collé ta commande. J'ai ensuite coché ce choix "Utilisateur" puis j'ai fermé la fenêtre "Configurer Texmaker" en cliquant sur "OK".
Correct

charles a écrit:je clique sur la flèche "PDFLatex"
Ben non, car là tu compiles avec pdflatex et non ta commande utilisateur... Il faut mettre Compilation Rapide : voir image jointe

charles a écrit:Dois-je aussi modifier les deux premières lignes de commandes dans "Configurer Texmaker" ?
Pour l'instant, ces lignes sont :
latex -shell-escape -interaction=nonstopmode %.tex
Ici, tu vires l’option shell escape.

charles a écrit:pdflatex -src -interaction=nonstopmode %.tex
et ça, tu laisses tel quel.

Et donc pour compiler un fichier avec du code gnuplot, tu cocheras ta commande utilisateur et compilation rapide. Ensuite Voir Pdf.

Okay ?

moi j'utlise windows xp et miktex est ce que c'est la meme démarche à suivre?
adem19s
Kilo-utilisateur
 
Messages: 155
Inscription: Mercredi 22 Mai 2013, 18:59
Statut actuel: Actif et salarié | Enseignant

Re: Problème avec tkzfct, gnuplot et windows 8

Messagepar letjl » Mardi 09 Décembre 2014, 20:58

Bonjour,
j'ai le même problème que décrit ci-dessus. Mais j'utilise TeXnicCenter et je ne vois pas ou mettre la ligne : --enable-write18 décrite dans tkz-fct-screen.pdf

Pouvez-vous m'aider ??
Merci
letjl
Déca-utilisateur
 
Messages: 13
Inscription: Mardi 09 Décembre 2014, 20:46
Statut actuel: Actif et salarié | Enseignant

PrécédenteSuivante

Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: DotBot [Crawler], Proximic [Spider] et 28 invités