Pb avec pygmentize

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Pb avec pygmentize

Messagepar fred_maths » Mercredi 03 Janvier 2018, 15:34

Bonjour ,

j'ai ce problème a la compilation d'un doc latex sous windows 8:
Package minted Error: You must have `pygmentize' installed to use this package. \RequirePackage{minted}[2011/09/17]
j'ai regardé du coté de Python j'ai la dernière version et dans le dossier Scripts de
python j'ai bien Pygmentize.exe qui est installé
je ne piges pas pourquoi cela ne compile pas ...
Merci

Texlive 2017
Tex studio
windows 8
PC 1 :Ubuntu 14.04 LTSw 8 + Texlive 2017+emacs 24 avec auctex 11.90 + texstudio v 2.9.4
ou
PC 2 : Windows 8 + Texlve 2016 + texstudio v 2.9.4
fred_maths
Déca-utilisateur
 
Messages: 26
Inscription: Vendredi 02 Janvier 2015, 21:57
Statut actuel: Actif et salarié | Enseignant

Publicité

Re: Pb avec pygmentize

Messagepar fred_maths » Mercredi 03 Janvier 2018, 15:43

j'ai essayé :

c:\Python36\Scripts>pip3.exe install Pygments
Requirement already satisfied: Pygments in c:\python36\lib\site-packages

ce qui m'indique que Pygments est déjà installé
je n'y piges rien
help !
PC 1 :Ubuntu 14.04 LTSw 8 + Texlive 2017+emacs 24 avec auctex 11.90 + texstudio v 2.9.4
ou
PC 2 : Windows 8 + Texlve 2016 + texstudio v 2.9.4
fred_maths
Déca-utilisateur
 
Messages: 26
Inscription: Vendredi 02 Janvier 2015, 21:57
Statut actuel: Actif et salarié | Enseignant

Re: Pb avec pygmentize

Messagepar rebouxo » Mercredi 03 Janvier 2018, 16:20

fred_maths a écrit:j'ai essayé :

c:\Python36\Scripts>pip3.exe install Pygments
Requirement already satisfied: Pygments in c:\python36\lib\site-packages

ce qui m'indique que Pygments est déjà installé
je n'y piges rien
help !


Ce n'est pas parce que c'est installé que c'est trouvé, manifestement c'est le problème. Un problème de PATH ? Tu as bien évidemment autorisé TeX à lancer des programmes externes ?
Autre possibilité, minted est en version 2.5 une grosse évolution.

Olivier
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6835
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Re: Pb avec pygmentize

Messagepar OG » Mercredi 03 Janvier 2018, 19:40

Bonsoir

Il faut aussi vérifier que la compilation LaTeX se fait avec l'option `shell-escape`
(puisqu'un programme annexe est lancé).

O.G.
OG
Modérateur
 
Messages: 2232
Inscription: Lundi 12 Mars 2007, 11:20
Localisation: Rouen
Statut actuel: Actif et salarié | Maître de conférence

Re: Pb avec pygmentize

Messagepar marco56 » Mercredi 03 Janvier 2018, 20:45

Et c'est quoi, le code ?
marco56
Giga-utilisateur
 
Messages: 702
Inscription: Jeudi 25 Novembre 2010, 22:10
Statut actuel: Actif et salarié | Enseignant


Retourner vers LaTeX

Qui est en ligne

Utilisateurs parcourant ce forum: Alexa [Bot], Bing [Bot], Grapeshot [Crawler], Proximic [Spider] et 9 invités