Où télécharger le package french

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Où télécharger le package french

Messagepar Duche » Dimanche 08 Octobre 2006, 19:40

Où est-ce que je peux télécharger le package necessaire pour la ligne

Code: Tout sélectionner
\usepackage[french]{babel}


et où dois-je le mettre dans l'ordi ?

je précise que je n'ai pas internet sur ce pc et que je ne peux donc pas profiter du téléchargement automatique...
Duche
Déca-utilisateur
 
Messages: 10
Inscription: Dimanche 08 Octobre 2006, 19:29
Localisation: Bruxelles

Publicité

Messagepar rebouxo » Dimanche 08 Octobre 2006, 19:55

Sur CTAN. Mais tu as bien une installation sur CD. Il doit probablement contenir babel.
Tu dois le placer dans le répertoire :
Code: Tout sélectionner
.../tex/generic/babel

ou ... est le chemin depuis la racine.

Olivier
rebouxo
Modérateur
 
Messages: 6938
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Messagepar Duche » Dimanche 08 Octobre 2006, 20:17

Non j'ai télécharger le setup sur le net, et j'ai installé en bonne et due forme...
Duche
Duche
Déca-utilisateur
 
Messages: 10
Inscription: Dimanche 08 Octobre 2006, 19:29
Localisation: Bruxelles

Messagepar guiguiche » Dimanche 08 Octobre 2006, 20:27

Duche a écrit:Non j'ai télécharger le setup sur le net, et j'ai installé en bonne et due forme...

Et tu n'as plus internet maintenant sur ce poste ?
As-tu un autre poste avec internet ? [Question idiote puisque tu es sur le forum donc tu télécharges le package babel].
Sinon, utilises-tu MikTex. Es-il bien configuré ? Peux-tu lancer la reconfiguration ?
Dernière édition par guiguiche le Dimanche 08 Octobre 2006, 20:29, édité 1 fois.
guiguiche
Modérateur
 
Messages: 8067
Inscription: Vendredi 06 Janvier 2006, 15:32
Localisation: Le Mans
Statut actuel: Actif et salarié | Enseignant

Messagepar Duche » Dimanche 08 Octobre 2006, 20:28

Ben je n'ai pas internet sur l'ordi sur lequel j'installe latex...
Duche
Duche
Déca-utilisateur
 
Messages: 10
Inscription: Dimanche 08 Octobre 2006, 19:29
Localisation: Bruxelles

Messagepar guiguiche » Dimanche 08 Octobre 2006, 20:30

Duche a écrit:Ben je n'ai pas internet sur l'ordi sur lequel j'installe latex...

Mais tu as un ordi avec internet donc tu télécharges et tu transferts avec une clé USB.
guiguiche
Modérateur
 
Messages: 8067
Inscription: Vendredi 06 Janvier 2006, 15:32
Localisation: Le Mans
Statut actuel: Actif et salarié | Enseignant

Messagepar Duche » Dimanche 08 Octobre 2006, 20:31

oui c'est ca !
Seulement je ne sais pas ou trouver ce package...
Duche
Duche
Déca-utilisateur
 
Messages: 10
Inscription: Dimanche 08 Octobre 2006, 19:29
Localisation: Bruxelles

Messagepar guiguiche » Dimanche 08 Octobre 2006, 20:32

Sur CTAN (google va te renvoyer où il faut, genre université de Jussieu).
[Edit : Oups, j'ai pas vu que tu étais sur Bruxelles, il doit y avoir un miroir plus près de chez toi. Mais j'ai comme l'impression que tu as mal configuré l'installation car je n'ose imaginer que MikTex puisse ne pas installer babel même en version "small".]
guiguiche
Modérateur
 
Messages: 8067
Inscription: Vendredi 06 Janvier 2006, 15:32
Localisation: Le Mans
Statut actuel: Actif et salarié | Enseignant

Messagepar Duche » Dimanche 08 Octobre 2006, 20:37

Duche
Duche
Déca-utilisateur
 
Messages: 10
Inscription: Dimanche 08 Octobre 2006, 19:29
Localisation: Bruxelles

Messagepar Duche » Dimanche 08 Octobre 2006, 20:39

Je ne sais pas si j'ai bien configuré ou pas, quand je compile avec la commande \usepackage[french]{babel}, il me dit qu'il manque un fichier et il me propose de le télécharger...
Duche
Duche
Déca-utilisateur
 
Messages: 10
Inscription: Dimanche 08 Octobre 2006, 19:29
Localisation: Bruxelles

Messagepar guiguiche » Dimanche 08 Octobre 2006, 20:55

Duche a écrit:Je ne sais pas si j'ai bien configuré ou pas, quand je compile avec la commande \usepackage[french]{babel}, il me dit qu'il manque un fichier et il me propose de le télécharger...

Dans ce cas, si MikTex l'a dit, je m'incline.
guiguiche
Modérateur
 
Messages: 8067
Inscription: Vendredi 06 Janvier 2006, 15:32
Localisation: Le Mans
Statut actuel: Actif et salarié | Enseignant

Messagepar gigiair » Dimanche 08 Octobre 2006, 20:56

Duche a écrit:Je ne sais pas si j'ai bien configuré ou pas, quand je compile avec la commande \usepackage[french]{babel}, il me dit qu'il manque un fichier et il me propose de le télécharger...

Pourquoi pas \usepackage[frenchb]{babel} ?

--
JJR
gigiair
Exa-utilisateur
 
Messages: 2439
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Messagepar Duche » Dimanche 08 Octobre 2006, 20:57

Je n'ai pas essayer... je vous dirai ca demain alors !
Duche
Duche
Déca-utilisateur
 
Messages: 10
Inscription: Dimanche 08 Octobre 2006, 19:29
Localisation: Bruxelles

Messagepar guiguiche » Dimanche 08 Octobre 2006, 20:58

gigiair a écrit:Pourquoi pas \usepackage[frenchb]{babel} ?

Ah oui, pas bête, j'avais pas fait attention (lyx user oblige).
guiguiche
Modérateur
 
Messages: 8067
Inscription: Vendredi 06 Janvier 2006, 15:32
Localisation: Le Mans
Statut actuel: Actif et salarié | Enseignant

Messagepar Duche » Mardi 10 Octobre 2006, 06:53

Ca ne marche pas mieux... il me demande toujours de télécharger un truc...
:cry: Chuis trop un boulet de l'info :oops: La vie est dure :D
Duche
Duche
Déca-utilisateur
 
Messages: 10
Inscription: Dimanche 08 Octobre 2006, 19:29
Localisation: Bruxelles

Messagepar guiguiche » Mardi 10 Octobre 2006, 09:28

Duche a écrit:il me demande toujours de télécharger un truc

Quel truc ?
guiguiche
Modérateur
 
Messages: 8067
Inscription: Vendredi 06 Janvier 2006, 15:32
Localisation: Le Mans
Statut actuel: Actif et salarié | Enseignant

Messagepar gigiair » Mardi 10 Octobre 2006, 09:55

Duche a écrit:Ca ne marche pas mieux... il me demande toujours de télécharger un truc...
:cry: Chuis trop un boulet de l'info :oops: La vie est dure :D


C'est tout à fait normal que tu te fasse jeter en demandant
\usepackage[french]{babel}
babel ne propose pas (plus) l'option french.
Par contre, c'est tout à fait anormal que frenchb soit rejeté.
Je ne vois que deux hypothèses:
-- ton installation est défectueuse grave : il faut la refaire
-- la tentative de compilation de \usepackage[french]{babel} a laissé des traces et il LaTeX continue de réclamer ce package.
Dans ce cas, je te conseille de renommer ton fichier et de le compiler avec la bonne option.
Pour l'histoire, l'option french de babel était possible il y a pas mal d'années.
french existe toujurs sous forme de package, mais n'est pas libre. Cela résout des problèmes bien spécifiques et pour l'utiliser il vaut mieux savoir ce que l'on fait.
Il se peut que tu t'aide d'un ouvrage qui date un peu.
Si tu es débutant, je te conseille le flshort:
http://tug.ctan.org/tex-archive/info/ls ... t-3.20.pdf
\begin{troll}Je sais que ce n'est pas facile de débuter sous LaTeX, en plus avec Ouindoz, ça n'aide pas...\end{troll}
--
JJR.
gigiair
Exa-utilisateur
 
Messages: 2439
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Messagepar Duche » Mardi 10 Octobre 2006, 11:15

Merci bien !
C'est ce tutoriel que j'utilise d'habitude mais dans sa version "LaTeX2e en 88 minutes"
Je suppose qu'il était plus ancien...
Vais relire celui-ci alors ! :D
Duche
Duche
Déca-utilisateur
 
Messages: 10
Inscription: Dimanche 08 Octobre 2006, 19:29
Localisation: Bruxelles

Messagepar gigiair » Mardi 10 Octobre 2006, 23:14

Duche a écrit:Merci bien !
C'est ce tutoriel que j'utilise d'habitude mais dans sa version "LaTeX2e en 88 minutes"
Je suppose qu'il était plus ancien...
Vais relire celui-ci alors ! :D

Effectivement, dans la version de 1999 il n'est fait mention que de french.
J'ai trouvé une version plus récente (2003) qui parle de frenchb
http://omega.enstb.org/eurotex2003/flshort.pdf
Je vous conseille de n'utilser que cette version ou une plus récente, si vous en trouvez une.

Au fait avez-vous réussi à compiler un document avec \usepackage[frenchb]{babel} ?

--
JJR.
gigiair
Exa-utilisateur
 
Messages: 2439
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Messagepar Duche » Mercredi 11 Octobre 2006, 16:34

Non mais je n'ai pas encore essayé de le réinstaller... Je ferai ca ce week-end probablement.
Merci pour le lien de mars 2003 :wink:
Duche
Duche
Déca-utilisateur
 
Messages: 10
Inscription: Dimanche 08 Octobre 2006, 19:29
Localisation: Bruxelles


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Google [Bot], Google Adsense [Bot], Grapeshot [Crawler] et 32 invités