[Résolu???] Je n'arrive pas à installer texlive 2019

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

[Résolu???] Je n'arrive pas à installer texlive 2019

Messagepar gigiair » Vendredi 28 Juin 2019, 17:39

J'essaye depuis deux jours d'installer TL 2019 sur mon PC. Comme l'installation est minimale, je voudrais l'installer sur une SD card.
J'ai téléchargé install-tl-20190628 et lancé dans un interpréteur de commandes
Code: Tout sélectionner
install-tl-windows.bat -expert

J'ai une boîte de dialogue qui s'ouvre et qui me propose de changer de miroir si ça prend trop de temps. Au bout d'une demi-heure, j'ai l'impression que rien ne se passe, aucun message, aucun echo de téléchargement et rien de visible dans le gestionnaire de fichiers. J'ai essayé plusieurs dépôts sans changement. Ma machine est équipée de MS-Windows 10 qui m'a été imposé à l'achat et je ne l'exploite pas en général sous ce système. Mes connaissances dans les OS Microsoft datent de Windows-98, juste un peu d'autoformation sur XP, mais rien sur W10 et je n'ai pas vraiment envie de m'y intéresser. Quelqu'un pourrait-il me donner un conseil pour lancer l'installation ? J'ai installé strawberry-perl-5.30.0.1-64bit sans que ça ne change rien (ma machine est un Asus L203 N notebook qui fonctionne en 64 bits).
Dernière édition par gigiair le Vendredi 05 Juillet 2019, 19:27, édité 2 fois.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2439
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Publicité

Re: je n'arrive pas à installer texlive 2019

Messagepar Denis Bitouzé » Vendredi 28 Juin 2019, 21:16

Que donne :
Code: Tout sélectionner
install-tl-windows -no-gui
Denis
Denis Bitouzé
Hecto-utilisateur
 
Messages: 68
Inscription: Vendredi 27 Octobre 2006, 19:27
Localisation: Dunkerque
Statut actuel: Actif et salarié | Maître de conférence

Re: je n'arrive pas à installer texlive 2019

Messagepar gigiair » Vendredi 28 Juin 2019, 22:01

C'est comme ça que j'installais TeXLive 4 en un temps que les moins de vingt ans ne peuvent pas connaître...
Dans un premier temps ,j'ai lancé tl-install-windows sans décompression préalable. J'ai eu une erreur Perl dont je ne me souviens plus l'intitulé, mais ce n'était pas très explicite pour quelqu'un qui ne cause pas le Perl comme moi.
J'ai échappé à cette erreur en décompressant au préalable. J'ai commencé par l'option -no-gui qui m'a envoyé sur la boîte de dialogue graphique qui bloque. Ce n'est pas vraiment l'idée que j'ai du -no-gui.
J'ai ensuite tenté l'option -expert et je crois avoir lu que c'était la même chose que -no-gui.

MS-Windows, c'est vraiment un système invraisemblable. J'ai eu des avertissements comme quoi j'essayais d'installer un logiciel peu diffusé et que je prenais des risques... J'ai un peu eu l'impression d'être pris pour un irresponsable par un ignorant.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2439
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: je n'arrive pas à installer texlive 2019

Messagepar Hugues » Samedi 29 Juin 2019, 06:39

Etes-vous intéressé par l'installation complète de TexLive 2019 ?
Hugues
Utilisateur
 
Messages: 5
Inscription: Jeudi 27 Juin 2019, 04:18
Statut actuel: Actif et salarié | Enseignant

Re: je n'arrive pas à installer texlive 2019

Messagepar gigiair » Samedi 29 Juin 2019, 07:53

Non, non, c'est juste par curiosité que je souhaite l'installer. Mon système c'est GNU/Llinux et je n'ai aucune raison d'en changer.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2439
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: je n'arrive pas à installer texlive 2019

Messagepar gigiair » Mardi 02 Juillet 2019, 09:18

Denis Bitouzé a écrit:Que donne :
Code: Tout sélectionner
install-tl-windows -no-gui

J'avais du aller trop vite, install-tl-windows.bat -no-gui, ça fonctionne bien, ou presque.. J'avais du oublier le tiret.
Le problème est que l'installateur appelle l'interpréteur de commande cmd.exe qui n'est pas dans le %PATH% !!!
J'ai fait une recherche pour le trouver et j'ai modifié le %PATH% L'installation a démarré.
Avec ma connexion Internet poussive, ça va prendre --un certain temps--, mais l'essentiel est que ça démarre.
Il faudra signaler ce bug, j'imagine ne pas être le seul à devoir le subir. Mon installation MS-Windows est la plus réduite possible, j'ai supprimé tout ce qui pouvait se supprimer. Ma machine est un ASUS L203N acheté en solde 200 euros. Comme il y a 64Go de mémoire de masse, je l'ai divisée en 2 pour faire tourner GNU/Linux sur une moitié et qui tourne comme un charme. Par contre, l'autre il n'arrête pas de râler qu'il lui maque de la place

- deuxième épisode

J'avance ! J'ai refait mon installation, car j'avais choisi le schéma minimal et c'était vraiment minimal...
En plus tlmgr ne voulait pas tlmgr-er, mêmes messages que install-tl concernant l'absence de cmd.exe.
Du coup j'ai changé de stratégie car modifier les variables d'environnement c'est toujours un peu périlleux. J'ai modifié le install-tl.bat en ajojutant au tout début du fichier install-tl-windows.bat la ligne
Code: Tout sélectionner
PATH=c:\Windows\SysWOW64;%PATH%
.Il y a un cmd.exe dans c:\Windows\SysWOW64 . Il y en a d'autres, j'ai choisi au hasard.
Même motif, même punition pour tlmgr.bat et maintenant les deux roulent. Je pense qu'il s'agit d'un bug de TL2019, j'imgine qu'il sera corrigé, ou du moins la doc indiquera la bonne façon de remédier.

J'ai maintenant un gros doute sur le fait que le problème soit résolu. J'ai réussi certes à effectuer une installation de TL2019 et à la maintenir. Mais il y a des « effets de bord » plutôt désagréables. Manifestement, MS-Windows, c'est pas pour moi...
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2439
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Bing [Bot], Yandex [Bot] et 9 invités