[Résolu] Installation de TexLive 2013 en mode graphique

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Re: Installation de TexLive 2013 en mode graphique

Messagepar gigiair » Vendredi 26 Juillet 2013, 18:03

max48 a écrit:2) Tu donnes la ligne:

# /usr/local/texlive/2013/bin/i386-linux/tlmgr option sys_bin

Ce n'est pas la même que la précédente.
Q-1 Est-ce que c'est voulu qu'il n'y ait pas la chaîne /usr/local/bin à la fin de ta ligne?

C'est voulu. Lire le man tlmgr
La réponse devrait indiquer que le lien est bien créé dans /usr/local/bin.
Il y a une contradiction que je ne m'explique pas :
Si le lien /usr/local/bin/tlmgr est créé et si /usr/local/bin est dans le PATH, la commande which tlmgr devrait renvoyer /usr/local/bin.
La commande
Code: Tout sélectionner
ls -l /usr/local/bin/tlmgr

devrait retourner
Code: Tout sélectionner
lrwxrwxrwx 1 root root 44 juil. jj hh:mm /usr/local/bin/tlmgr -> /usr/local/texlive/2013/bin/i386-linux/tlmgr

Si c'est différent (sauf la date et l'heure, bien sûr) peux-tu poster le retour ici ?

Toutes ces commandes sont à exécuter en mode superutilisateur.
en mode USER, la commande
Code: Tout sélectionner
ls -l $(which latex)

renvoie bien
Code: Tout sélectionner
lrwxrwxrwx 1 root root 44 ..... /usr/local/bin/latex -> /usr/local/texlive/2013/bin/i386-linux/latex

?
Tu ne m'as pas dit quel était ton système : Debian, Ubuntu, autre ? c'est important de savoir.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2364
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Publicité

Re: Installation de TexLive 2013 en mode graphique

Messagepar max48 » Vendredi 26 Juillet 2013, 19:30

1) Je roule sous Wheezy (Debian).

2) # ls -l /usr/local/bin/tlmgr (en su)
donne:
ls: cannot access /usr/local/bin/tlmgr: No such file or directory

3) La ligne de commande:
# /usr/local/texlive/2013/bin/i386-linux/tlmgr option sys_bin

donne effectivement:
Destination for symlinks for binaries (sys_bin): /usr/local/bin

4) ls -l $(which latex) (en usager)
Ca me renvoie la liste des fichiers et repertoires( comme ls -l)

Merci
max48
Hecto-utilisateur
 
Messages: 84
Inscription: Samedi 29 Décembre 2012, 19:21
Statut actuel: Actif et salarié | Enseignant

Re: Installation de TexLive 2013 en mode graphique

Messagepar gigiair » Vendredi 26 Juillet 2013, 20:41

max48 a écrit:1) Je roule sous Wheezy (Debian).

2) # ls -l /usr/local/bin/tlmgr (en su)
donne:
ls: cannot access /usr/local/bin/tlmgr: No such file or directory

3) La ligne de commande:
# /usr/local/texlive/2013/bin/i386-linux/tlmgr option sys_bin

donne effectivement:
Destination for symlinks for binaries (sys_bin): /usr/local/bin

4) ls -l $(which latex) (en usager)
Ca me renvoie la liste des fichiers et repertoires( comme ls -l)
Merci

Les liens n'ont donc pas été créés comme je l'imaginais. Je devrais lire le man de tlmgr plus attentivement.
J'ai la flemme de chercher quelle commande il aurait fallu taper,
Je te propose de traiter le problème avec l'interface graphique
Code: Tout sélectionner
$ su
# tlmgr  gui --gui-lang fr

Si tu te fais jeter, tape la commande
Code: Tout sélectionner
# xhosts +
avant de lancer tlmgr
Puis dans le menu Actions sélectionner Gérer les liens symboliques dans les répertoires système
Le choix proposé par défaut est le bon, il suffit de valider.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2364
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Installation de TexLive 2013 en mode graphique

Messagepar max48 » Vendredi 26 Juillet 2013, 21:19

Salut gigiair,

Tu fais mention de la commande xhost +. Eh bien justement, j'ai réussi, grâce a cette commande, à ouvrir mon fichier \home\planck\.profile avec kate. Quelqu'un m'a suggéré la procédure suivante:

1) En usager:
Code: Tout sélectionner
$ xhost +

2) Passer sous root:
Code: Tout sélectionner
# kate \home\planck\.profile

3) Ne fonctionne pas immédiatement. Le shell te suggère:
Code: Tout sélectionner
# export $(dbus-launch)

4) Tu entres cette ligne puis finalement, tu refais:
Code: Tout sélectionner
# kate \home\planck\.profile

et ça ouvre le fichier.

J'ai essayé
Code: Tout sélectionner
$ su
# tlmgr  gui --gui-lang fr

Cependant,le shell ne trouve pas la commande tlmgr.

La commande xhost +, tu la fais sous root ou comme usager?

Merci
max48
Hecto-utilisateur
 
Messages: 84
Inscription: Samedi 29 Décembre 2012, 19:21
Statut actuel: Actif et salarié | Enseignant

Re: Installation de TexLive 2013 en mode graphique

Messagepar gigiair » Samedi 27 Juillet 2013, 05:39

Si tlmgr ne se lance pas, c'est qu'il ne se trouve pas dans le PATH. Il faut créer un lien symbolique qui le soit , c'est là tout le débat. En attendant, il faut lancer tlmgr en indiquant son chemin complet. C'est pour ça que la création des liens est plus facile à faire à l'installation.
Code: Tout sélectionner
/usr/local/texlive/2013/bin/i386-linux/tlmgr gui --gui-lang fr


Si tu veux modifier un fichier système utilises nano, et non kate. Debian décourage le lancement de kate en mode administrateur pour des raisons de sécurité. Une fois de temps à autre il n'y a pas de risque, mais Debian est orienté vers un usage professionnel. Ubuntu n'a pas ce verrou, mais je ne recommande pas cette distribution pour LaTeX car visiblement ils s'en contrefichent.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2364
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Installation de TexLive 2013 en mode graphique

Messagepar max48 » Samedi 27 Juillet 2013, 17:17

Bonjour,

1) # /usr/local/texlive/2013/bin/i386-linux/tlmgr gui --gui-lang fr

Un message indique que perl-tk n'est pas installé et que je dois le faire.

2) Contenu du fichier ~/.profile

Code: Tout sélectionner
# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.
# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022
# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
   . "$HOME/.bashrc"
    fi
fi
# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi


Je croyais trouver un fichier du genre fstab.


3) Modification du fichier /home/planck/.profile avec nano

À la fin de l'installation, il y avait les messages suivants:

Add /usr/local/texlive/2013/texmf-dist/doc/man to MANPATH, if not dynamically found.
Add /usr/local/texlive/2013/texmf-dist/doc/info to INFOPATH.
Most importantly, add /usr/local/texlive/2013/bin/i386-linux
to your PATH for current and future sessions.


Il y a une différence avec les lignes que suggèrent le guide par rapport au MANPATH et INFOPATH. Dans le guide:

MANPATH=/usr/local/texlive/2013/texmf/doc/man:MANPATH; export MANPATH
INFOPATH=/usr/local/texlive/2013/texmf/doc/info:$INFOPATH; export INFOPATH

Q-1 En principe, est-ce que je devrais choisir les chemins donnés par l'installateur et non par le guide?

Merci
max48
Hecto-utilisateur
 
Messages: 84
Inscription: Samedi 29 Décembre 2012, 19:21
Statut actuel: Actif et salarié | Enseignant

Re: Installation de TexLive 2013 en mode graphique

Messagepar gigiair » Dimanche 28 Juillet 2013, 09:46

L'installation de TeXLive2013 sous Linux en mode root est une opération extrêmement simple, la seule chose est qu'il ne faut pas oublier de demander la création des liens symboliques.
J'ai moi aussi fait cette erreur une fois. Je vais essayer de suggérer aux développeurs d'install-tl qu'ils ajoutent un avertissement quand l'installation est lancée sans cette option tant l'oubli est fréquent.
Le mode graphique ne fonctionne que si perl-tk est installé, ce sont les deux remarques que je t'ai faites dès mon premier message.
Le plus simple est sans doute de reprendre l'installation, c'est un peu bourrin, mais à la prochaine version de TL tu n'oubliera peut-être pas.
Je ne te conseille pas de modifier ton fichier .profile, comme je ne conseillerai pas à quelqu'un qui a du mal à atteindre à pied le sommet de la butte Monmartre d'essayer d'atteindre un sommet de plus de 2000m.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2364
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Installation de TexLive 2013 en mode graphique

Messagepar max48 » Dimanche 28 Juillet 2013, 18:40

Salut gigiair,

Eh bien, je crois que je vais tout désinstaller. C'était une suggestion que je voulais justement faire. Mais, je veux revenir à l'origine du problème pour bien comprendre ce qui s'est passé.

Lorsque j'ai fait l'installation, j'ai fait copie/coller des messages qui étaient affichés à l'écran et je les ai gardés dans un fichier.

1. Messages affichés lors de l'installation

======> Letters/digits in <angle brackets> indicate <=======
======> menu items for commands or options <=======

Detected platform: Intel x86 with GNU/Linux
<B> binary platforms: 1 out of 13

<S> set installation scheme (scheme-custom)

<C> customizing installation collections
41 collections out of 45, disk space required: 2833 MB

<D> directories:
TEXDIR (the main TeX directory):
/usr/local/texlive/2013
TEXMFLOCAL (directory for site-wide local files):
/usr/local/texlive/texmf-local
TEXMFSYSVAR (directory for variable and automatically generated data):
/usr/local/texlive/2013/texmf-var
TEXMFSYSCONFIG (directory for local config):
/usr/local/texlive/2013/texmf-config
TEXMFVAR (personal directory for variable and automatically generated data):
~/.texlive2013/texmf-var
TEXMFCONFIG (personal directory for local config):
~/.texlive2013/texmf-config
TEXMFHOME (directory for user-specific files):
~/texmf

<O> options:
[ ] use letter size instead of A4 by default
[X] allow execution of restricted list of programs via \write18
[X] create all format files
[X] install macro/font doc tree
[X] install macro/font source tree
[X] after install, use tlnet on CTAN for package updates

<V> set up for portable installation

Actions:
<I> start installation to hard disk
<H> help
<Q> quit

Je croyais que j'avais fait une erreur concernant l'option <O>. Mais on voit, que seule, une option n'est pas cochée, soit celle qui concerne le choix du format du papier. Ça ne concerne donc pas la création des liens symboliques. Je n'avais donc pas à changer quoi que ce soit dans cette option. Tout était coché. Je n'ai donc pas entré la lettre <O> lors de l'installation.

J'ai cependant entré la lettre <C> pour enlever certains langages.
C'est pour cela, je crois, que scheme-custom est apparu au lieu de scheme-full.

2. Désinstallation

J'ai remarqué, avant l'installation, que Konqueror et Dolphin reconnaissait les fichiers *.tex. En me promenant travers les répertoires, j'ai vu qu'il y avait déjà un répertoire /texmf. Il ne faudrait pas, lors de la désinstallation, que aptitude l'enlève.

Merci
max48
Hecto-utilisateur
 
Messages: 84
Inscription: Samedi 29 Décembre 2012, 19:21
Statut actuel: Actif et salarié | Enseignant

Re: Installation de TexLive 2013 en mode graphique

Messagepar gigiair » Dimanche 28 Juillet 2013, 20:33

L'interface est mal faite. L'option
<L> create symlinks in standard directories: [ ]
n'est accessible que dans le sous-menu O qu'il faut activer.
C'est le seul truc qu'il ne faut pas oublier.
Ceci disparaîtra avec TeXLive 2014 parait-il, un autre système sera adopté.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2364
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Installation de TexLive 2013 en mode graphique

Messagepar max48 » Dimanche 28 Juillet 2013, 21:23

Bonjour,

En relisant tes messages, j'ai vu dans le premier:

Ne pas oublier non plus de créer des liens vers les binaires (option O en mode texte, puis L), sans ça, ça risque d'être un peu sportif pour exécuter latex.

Je comprends maintenant ce que tu as écrit.

Mais, surtout, tu avais aussi écrit:

Après le lancement de l'installation par install-tl, taper O, puis L et valider le choix proposé, trois fois.
Puis taper R, puis I
et c'est tout.

C'est là que j'ai manqué le bateau. :evil:

Dans le guide, il y avait:

Options setup:
============================================================
<P> use letter size instead of A4 by default: [ ]
<E> execution of restricted list of programs: [X]
<F> create format files: [X]
<D> install font/macro doc tree: [X]
<S> install font/macro source tree: [X]
<L> create symlinks in standard directories: [ ]
binaries to:
manpages to:
info to:
<Y> after installation, get package updates from CTAN: [X]

L'option <L> apparaît dans le guide mais pas lors de l'installation. De plus, l'option n'est pas cochée (une des seules) alors qu'elle est essentielle au fonctionnement de Latex... C'est quand même incroyable. Il faut croire que les planètes étaient toutes alignées ce jour-là.

Dans mon cas, ce sera une première désinstallation. Je voudrais la dédier au concepteur(trice) de l'interface graphique (même si j'ai quand même une part de responsabilité dans ma mésaventure). :oops:

Merci beaucoup de l'aide que tu m'as apportée au cours des derniers jours :wink:
max48
Hecto-utilisateur
 
Messages: 84
Inscription: Samedi 29 Décembre 2012, 19:21
Statut actuel: Actif et salarié | Enseignant

Re: Installation de TexLive 2013 en mode graphique

Messagepar rebouxo » Lundi 29 Juillet 2013, 08:48

gigiair a écrit:Je ne te conseille pas de modifier ton fichier .profile, comme je ne conseillerai pas à quelqu'un qui a du mal à atteindre à pied le sommet de la butte Monmartre d'essayer d'atteindre un sommet de plus de 2000m.


Je trouve la comparaison franchement étonnante. Modifier ton .profile n'est quand même pas la mer à boire (ni même la montée à Montmartre !). Il suffit de prendre la précaution de le sauvegarder avant. Là, franchement. Je ne te suis pas. Quels risques ? Au pire, Latex ne fonctionnera pas.


Olivier
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6888
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Re: Installation de TexLive 2013 en mode graphique

Messagepar gigiair » Lundi 29 Juillet 2013, 09:22

Ce n'est pas difficile de modifier le .profile, c'est justement là le problème. Ce qui est difficile, c'est de comprendre le rôle des variables d'environnement, de connaître les multiples endroits où elles peuvent être modifiées et de gérer les éventuels «effets de bord». L'environnement d'une machine, c'est comme l'environnement écologique moins on intervient, mieux ça vaut. L'idéal, c'est de toujours laisser l'endroit dans l'état ou on aimerait le trouver en entrant...

La variable PATH est particulièrement importante, une erreur peut mettre à plat tout un système, et ce n'est pas toujours trivial de la remettre d'aplomb. Suppose par exemple qu'au lieu de
PATH = /var/local/texlive/bin/i386-linux:$PATH
on écrive
PATH = /var/local/texlive/bin/i386-linux:PATH
Je ne te conseille pas d'essayer sauf si tu maîtrise bien le sujet.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2364
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Installation de TexLive 2013 en mode graphique

Messagepar max48 » Lundi 29 Juillet 2013, 20:10

Salut,

Eh, bien je crois que je vais tenter la suggestion de rebouxo. Au pire, je réinstallerai le système. Voici les trois lignes que j’ajouterais à la fin de mon fichier ~/.profile. Je vais l’éditer avec nano. J’aime mieux vous montrer le fichier et avoir vos commentaires avant de l’éditer. Si je ne fais pas d'erreur cette fois-ci, tout devrait bien aller.

Code: Tout sélectionner
# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.
# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022
# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
   . "$HOME/.bashrc"
    fi
fi
# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

PATH=/usr/local/texlive/2013/bin/i386-linux:$PATH; export PATH
MANPATH=/usr/local/texlive/2013/texmf-dist/doc/man:$MANPATH; export MANPATH
INFOPATH=/usr/local/texlive/2013/texmf-dist/doc/info:$INFOPATH; export INFOPATH


Merci
max48
Hecto-utilisateur
 
Messages: 84
Inscription: Samedi 29 Décembre 2012, 19:21
Statut actuel: Actif et salarié | Enseignant

Re: Installation de TexLive 2013 en mode graphique

Messagepar gigiair » Lundi 29 Juillet 2013, 21:14

Ce n'est pas une très bonne idée, il faut prévoir TeXLive2014, un an ça passe vite...
Je te donne le choix de Daniel Flipo (mainteneur de frenchb entre autres packages) :
créer un lien symbolique nommé /usr/local/texlive/current qui pointe sur /usr/local/texlive/2013
Code: Tout sélectionner
# ln -s /usr/local/texlive/2013 /usr/local/texlive/current


Ensuite les trois dernières lignes de ton fichier .profile deviennent
Code: Tout sélectionner
PATH=/usr/local/texlive/current/bin/i386-linux:$PATH; export PATH
MANPATH=/usr/local/texlive/current/texmf-dist/doc/man:$MANPATH; export MANPATH
INFOPATH=/usr/local/texlive/current/texmf-dist/doc/info:$INFOPATH; export INFOPATH

L'an prochain il suffira de faire pointer /usr/local/texlive/current sur /usr/local/texlive/2014 et tout ira bien.

Autre raffinement : s'il te prend le désir de créer des applications personnelles, le répertoire indiqué pour les placer, c'est ~/bin, et ce répertoire doit être parcouru avant les autres. Tes trois lignes doivent donc être placées avant l'inclusion de ~/bin dans le PATH. Ce qui donne la fin de ton .profile
Code: Tout sélectionner
[SNIP]

PATH=/usr/local/texlive/current/bin/i386-linux:$PATH; export PATH
MANPATH=/usr/local/texlive/current/texmf-dist/doc/man:$MANPATH; export MANPATH
INFOPATH=/usr/local/texlive/current/texmf-dist/doc/info:$INFOPATH; export INFOPATH

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

Autre solution (celle que j'ai adoptée)
Placer les trois lignes PATH .... INFOPATH non pas dans le .profile, mais dans le /etc/environment . Comme ça tous les comptes sur ta machine pourront disposer de TeXLive. Du coup, le ~/bin sera automatiquement en premier.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2364
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Installation de TexLive 2013 en mode graphique

Messagepar max48 » Mardi 30 Juillet 2013, 06:10

Salut gigiair,

Dimanche, j'avais écrit :
max48 a écrit:J'ai remarqué, avant l'installation, que Konqueror et Dolphin reconnaissait les fichiers *.tex. En me promenant travers les répertoires, j'ai vu qu'il y avait déjà un répertoire /texmf. Il ne faudrait pas, lors de la désinstallation, que aptitude l'enlève.

Cependant, j'ai oublié quelque chose d'important ...
je n'ai pas installé Tex-Live 2013 avec aptitude!

Donc, je ne crois pas que je puisse désinstaller Tex-Live avec aptitude.

Pour enlever un paquet, c'est une bonne chose de connaître le nom du paquet... Quel serait le nom du paquet ici?

Si je le pouvais, je le désinstallerais avec aptitude et ça ne poserait pas de problème.

Désinstallation à la main

Si je ne peux pas prendre aptitude, il faudra que j'enlève un ou des répertoires.

Si c'est de se mettre sous root et d'enlever un SEUL répertoire, ça va.

Mais, est-ce que le programme install-tl a mis des fichiers dans plusieurs répertoires dispersés un peu partout dans le système?

Si c'est le cas, la désinstallation devient difficile à gérer.

Je crois que la proposition de rebouxo devient très valable en vertu des arguments que j'amène ici (SI, effectivement, il est impossible d'utiliser aptitude).

La chose que j'ai apprise et que je retiens est qu'il est nettement plus avantageux d'installer un programme avec un outil de gestion (aptitude, apt-get) du système installé sur ton ordinateur plutôt que d'y aller à la main (genre Windows).

Question
gigiair a écrit:Autre solution (celle que j'ai adoptée)
Placer les trois lignes PATH .... INFOPATH non pas dans le .profile, mais dans le /etc/environment . Comme ça tous les comptes sur ta machine pourront disposer de TeXLive. Du coup, le ~/bin sera automatiquement en premier.

Q-1 Dans ton autre solution, est-ce que tu as placé tes trois lignes au début ou à la fin de ton fichier /etc/environment?

Q-2 Dans le cas ou j'adopte ta deuxième solution, est-ce qu'il est toujours nécessaire de créer le lien symbolique (méthode de D.Flipo)?

Q-3 Si effectivement il faut créer le lien symbolique, doit-on le faire sous root?

Merci beaucoup,
max48
Hecto-utilisateur
 
Messages: 84
Inscription: Samedi 29 Décembre 2012, 19:21
Statut actuel: Actif et salarié | Enseignant

Re: Installation de TexLive 2013 en mode graphique

Messagepar rebouxo » Mardi 30 Juillet 2013, 09:07

On est dans le monde linux, les programmes n'installent pas n'importe quoi n'importe où.
Aptitude ne peux pas connaître une installation que tu fais à la main. Donc, aptitude ne viendra pas écrire effacer l'installation de texlive.

Pour désinstaller texlive, il suffit de virer le répertoire /usr/local/texlive/2013.

Olivier
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6888
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Re: Installation de TexLive 2013 en mode graphique

Messagepar gigiair » Mardi 30 Juillet 2013, 09:08

Je ne comprends pas trop pourquoi tu voudrais désinstaller TeXLive après avoir eu tant de mal à l'installer !
Le répertoire /texmf n'a pas été créé par install-tl ni par l'installation depuis les dépôts Debian, donc aucune désinstallation ne le supprimera. A mon avis il n'a pas lieu d'être, mais je ne connais pas les détails de ton installation.
install-tl copie toute l'installation de TeXLive dans le répertoire /usr/local/texlive/
Des fichiers cachés sont créés dans le répertoire personnel.
Un mécanisme assez subtil fait que tous les binaires de TeXLive savent trouver les données dont ils ont besoin dans cette arborescence. L'arborescence utilisée par TeXLive est décrite par la commande :
Code: Tout sélectionner
kpsewhich --var-value TEXMF

Lire man kpathsea pour plus de détails.

Le fait que Dolphin ou Konqueror reconnaissent les fichiers .tex n'a rien à voir avec l'installation de TeXLive.

Il faut faire attention aux dépendances. De nombreux paquets exigent la présence de texlive (des dépôts Debian) pour s'installer.
C'est le cas de nombreux éditeurs orientés LaTeX. On peut les installer avec l'option --without-recommends pour éviter une installation intempestive. Si l'installateur est trop insistant, il faut le laisser faire. L'installation de TeXLive depuis install-tl supporte la présence d'une autre installation. En fait, c'est le mécanisme du PATH qui fait que ses binaires sont trouvés en premier, c'est l'ordre dans lequel les entrées sont écrites qui le détermine. Ensuite, comme je le dis plus haut, les binaires de TeXLive2013 se débrouillent tous seuls pour trouver les fichiers dont ils ont besoin, dans la bonne version.

A moins d'être très à court de place, je ne te conseille pas de désinstaller quoi que ce soit «à la main» Si ta machine est récente et si tu n'est pas un collectionneur compulsif de videos et autres multimedia, il y a de la place, et la rapidité des traitements n'est que très peu affectée par la présence de fichiers intutiles. Par contre, une suppression intempestive d'un fichier que l'on croit inutile peut coûter bien des heures de travail pour remettre tout d'aplomb.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2364
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Installation de TexLive 2013 en mode graphique

Messagepar max48 » Mardi 30 Juillet 2013, 18:28

Bonjour,

OK, je vais tenter d'éditer le fichier. J'aurais trois questions à ce sujet.

Q-1 Dans la solution que tu as adoptée, est-ce que tu as placé tes trois lignes au début où à la fin de ton fichier /etc/environment?

Q-2 En adoptant cette solution, est-ce qu'il est toujours nécessaire de créer le lien symbolique (méthode de D.Flipo)?

Q-3 Si, effectivement, il faut créer le lien symbolique, doit-on le faire sous root?

Merci,
max48
Hecto-utilisateur
 
Messages: 84
Inscription: Samedi 29 Décembre 2012, 19:21
Statut actuel: Actif et salarié | Enseignant

Re: Installation de TexLive 2013 en mode graphique

Messagepar gigiair » Mercredi 31 Juillet 2013, 08:49

max48 a écrit:Bonjour,

OK, je vais tenter d'éditer le fichier. J'aurais trois questions à ce sujet.

Q-1 Dans la solution que tu as adoptée, est-ce que tu as placé tes trois lignes au début où à la fin de ton fichier /etc/environment?

Q-2 En adoptant cette solution, est-ce qu'il est toujours nécessaire de créer le lien symbolique (méthode de D.Flipo)?

Q-3 Si, effectivement, il faut créer le lien symbolique, doit-on le faire sous root?

Merci,

  1. Il n'y avait qu'une ligne définissant la variable d'environnement PATH dans mon /etc/environnement, je l'ai désactivée pour redéfinir PATH.
    Quand on fait ce genre de manipulations, il vaut mieux garder l'original, dater et commenter les modifications opérées
  2. La création du lien symbolique est une astuce pour faciliter la mutation. Elle n'est nullement obligatoire, tu peux laisser 2013 à la place de current, ça marchera aussi bien (éventuellement aussi mal :) )
  3. Le répertoire /usr/local/texlive étant la propriété de root, je ne vois pas comment on pourrait créer un lien symbolique dans ce répertoire sans avoir les droits de root
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2364
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Installation de TexLive 2013 en mode graphique

Messagepar max48 » Mercredi 31 Juillet 2013, 21:44

Salut,

Toi, tu avais une ligne dans ton fichier /etc/environment. J'ai regardé sur mes deux installations (Squeeze et Wheezy) et toutes deux ont un fichier /etc/environment vide.

Si je me fie au fichier ~/.profile, c'est le dièse qui crée une ligne de commentaire dans ce genre de fichier.

Donc, je vais rajouter les trois lignes dans le fichier /etc/environment avec nano.

Je vais également créer le lien symbolique.

Si j'ai bien compris, lorsque je vais installer TexLive 2014, je laisse mon fichier /etc/environment intact puis je fais la ligne de commande:

Code: Tout sélectionner
# ln -s /usr/local/texlive/2014 /usr/local/texlive/current


Merci beaucoup
max48
Hecto-utilisateur
 
Messages: 84
Inscription: Samedi 29 Décembre 2012, 19:21
Statut actuel: Actif et salarié | Enseignant

PrécédenteSuivante

Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Ahrefs [Bot], Bing [Bot], Google [Bot], Google Adsense [Bot], Grapeshot [Crawler], Proximic [Spider] et 11 invités