Incompatibilité ucs / biblatex ?

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Incompatibilité ucs / biblatex ?

Messagepar Coumbralhaud » Vendredi 30 Août 2013, 08:22

Bonjour à tous

Encore un souci...

Quand je demande la compilation de cela à Kile (réinstallé hier a-m):
Code: Tout sélectionner
\documentclass[a4paper,12pt]{book}
\usepackage{ucs}
\usepackage[utf8x]{inputenc}
\usepackage[english,francais]{babel}
\usepackage{fontenc}
\usepackage{multicol} % pour faire un document multicolonne : \begin{multicols}{nb col} + \end{multicols}
\usepackage[dvips,pdftex]{hyperref}
\usepackage[toc,page]{appendix}
\usepackage[font=itshape]{quoting}
\usepackage{makeidx}
\usepackage{fancyhdr}
\pagestyle{myheadings} % évite d'avoir le titre du chapitre et de la section en haut des pages
\usepackage[xdvi,draft]{graphicx}
\usepackage{subfig} %pour pouvoir dessiner des figures regroupées dans une seule référence
\usepackage{csquotes}
\usepackage{url}
\usepackage{alltt}
\usepackage[backend=biber]{biblatex}
\usepackage{tocbibind}
%\bibliographystyle{plain}
\bibliography{BibTEST}

\newcommand\guill[1]{\og#1\fg{}} % définit les guillemets français avec une espace obligatoire juste après
\renewcommand{\appendixtocname}{Annexes} % pour renommer les pages des annexes en français dans la TdM
\renewcommand{\appendixpagename}{Annexes} % pour renommer les pages des annexes en français

\title{\textbf{Malheur aux Barbus}}
\author{J et R FAUDERCHE}
\date{29/08/2013}

\begin{document}
%\maketitle
% début de la nouvelle page de titre
\begin{titlepage}
  \fontfamily{phv}\selectfont
  \vspace*{\stretch{1}}
  \begin{flushright}\LARGE
\textsc{Jules et Raphaël} FAUDERCHE
\end{flushright}
\hrule
\begin{flushleft}\huge\bfseries
  Malheur aux Barbus
\end{flushleft}
\vspace*{\stretch{2}}
\begin{center}
éditions du Schmilblick

2013
\end{center}
\end{titlepage}
% fin de la nouvelle page de titre
\part{LE BOUDIN SACRÉ}
\chapter{Malvina}
La nuit tombait. Elle tombait bien d'ailleurs, juste à temps pour remplacer le jour qui, visiblement, ne passerait pas la nuit.

\nocite{*}
\printbibliography

\end{document}

il me répond ceci:
Code: Tout sélectionner
finished with exit code
./TesTEST.tex: :Package biblatex Error: Incompatible package 'ucs'\begin{document}

Bizarre, non ?
D'autant que le paquetage 'ucs' est appelé par défaut par Kile quand on prépare un nouveau document (ce n'est pas mon habitude mais je l'ai constaté hier soir lors d'un test).

SI j'enlève toute référence à une bibliographie quelconque, aucun problème.
Seulement voilà, j'ai besoin de la biblio !
En plus, Latex me dit que "\bibliographystyle{quelle-que-soit-la-mise-en-forme-recherchée}" n'est pas valable, pas plus que "\printbibliography". Ça aussi, je le trouve étrange !

Quelqu'un peut-il m'aider ? Merci d'avance

JF
Dernière édition par Coumbralhaud le Mercredi 30 Octobre 2013, 18:42, édité 1 fois.
Coumbralhaud
Déca-utilisateur
 
Messages: 22
Inscription: Mardi 27 Août 2013, 22:32
Statut actuel: Actif et salarié | Enseignant

Publicité

Re: Incompatibilité ucs / biblatex ?

Messagepar balf » Vendredi 30 Août 2013, 10:45

Lincompatibilité est signalée en p. 6 de la documentation de biblatex. Solution proposée : retire ucs et
— soit se contenter de charger simplement utf8 via inputenc (si vous n'avez pas vraiment besoin de tout ce qu'apporte utf8x) ;
— soit retirer inputenc et compiler avec lualatex ou xelatex ; j'ajoute qu'en ce cas autant retirer aussi fontenc et charger fontspec à la place (il permet de profiter pleinement des fonctionnalités opentype pour les polices de texte).

B.A.
balf
Zetta-utilisateur
 
Messages: 3748
Inscription: Mercredi 02 Janvier 2008, 23:18
Statut actuel: Actif et salarié | Maître de conférence

Re: Incompatibilité ucs / biblatex ?

Messagepar Coumbralhaud » Vendredi 30 Août 2013, 14:29

Merci de ce conseil

Mon préambule devient donc :
Code: Tout sélectionner
    \documentclass[a4paper,12pt]{book}

    \usepackage[utf8]{inputenc}
    \usepackage[english,francais]{babel}
    \usepackage{fontenc}
    \usepackage{multicol} % pour faire un document multicolonne : \begin{multicols}{nb col} + \end{multicols}
    \usepackage[dvips,pdftex]{hyperref}
    \usepackage[toc,page]{appendix}
    \usepackage[font=itshape]{quoting}
    \usepackage{makeidx}
    \usepackage{fancyhdr}
    \pagestyle{myheadings} % évite d'avoir le titre du chapitre et de la section en haut des pages
    \usepackage[xdvi,draft]{graphicx}
    \usepackage{subfig} %pour pouvoir dessiner des figures regroupées dans une seule référence
    \usepackage{csquotes}
    \usepackage{url}
    \usepackage{alltt}
    \usepackage[backend=biber]{biblatex}
    \usepackage{tocbibind}
    %\bibliographystyle{plain}
    \bibliography{BibTEST}

    \newcommand\guill[1]{\og#1\fg{}} % définit les guillemets français avec une espace obligatoire juste après
    \renewcommand{\appendixtocname}{Annexes} % pour renommer les pages des annexes en français dans la TdM
    \renewcommand{\appendixpagename}{Annexes} % pour renommer les pages des annexes en français

    \title{\textbf{Malheur aux Barbus}}
    \author{J et R FAUDERCHE}
    \date{29/08/2013}

    \begin{document}
    %\maketitle
    % début de la nouvelle page de titre
    \begin{titlepage}
      \fontfamily{phv}\selectfont
      \vspace*{\stretch{1}}
      \begin{flushright}\LARGE
    \textsc{Jules et Raphaël} FAUDERCHE
    \end{flushright}
    \hrule
    \begin{flushleft}\huge\bfseries
      Malheur aux Barbus
    \end{flushleft}
    \vspace*{\stretch{2}}
    \begin{center}
    éditions du Schmilblick

    2013
    \end{center}
    \end{titlepage}
    % fin de la nouvelle page de titre
    \part{LE BOUDIN SACRÉ}
    \chapter{Malvina}
    La nuit tombait. Elle tombait bien d'ailleurs, juste à temps pour remplacer le jour qui, visiblement, ne passerait pas la nuit.

    \nocite{*}
    \printbibliography

    \end{document}

L'inconvénient, c'est cela ne résout pas le problème de la bibliographie : elle n'apparaît toujours pas, la compilation refuse la commande \printbibliograhy...
Le fichier de biblio doit être placé dans le même répertoire que le document, n'est-ce pas ?
Alors pourquoi ce blocage ?

JF
Coumbralhaud
Déca-utilisateur
 
Messages: 22
Inscription: Mardi 27 Août 2013, 22:32
Statut actuel: Actif et salarié | Enseignant

Re: Incompatibilité ucs / biblatex ?

Messagepar balf » Vendredi 30 Août 2013, 18:12

La bibliographie (le fichier .bib) s'indique de préférence avec la commande \addbibresource{monfichierSi.bib}, pas avec \bibliography. Essayez cette commande (un seul fichier par commande, avec l'extension), pour voir? Le fichier .bib peut être ailleurs (même sur internet, je crois), mais il faut alors indiquer le chemin d'accès. Donc, pour l'instant laissez-le (ou mettez-le) avec le document principal. De plus, avec biber, je crois bien que le fichier .bib doit aussi être en utf8, assurez-vous de ce point.

B.A.
balf
Zetta-utilisateur
 
Messages: 3748
Inscription: Mercredi 02 Janvier 2008, 23:18
Statut actuel: Actif et salarié | Maître de conférence

Re: Incompatibilité ucs / biblatex ?

Messagepar Coumbralhaud » Vendredi 30 Août 2013, 22:12

Bonsoir et merci pour cette réponse

Mon fichier .bib est bien dans le même dossier que le .tex mais rien n'y fait...

Ma biblio a été faite d'abord avec Kbibtex (Debian 6 puis Debian 7.1) puis avec JabRef sous Windows.
Quand j'ouvre le fichier .bib avec Emacs, je trouve ces 4 lignes en début:
Code: Tout sélectionner
@comment{x-kbibtex-personnameformatting=<%f ><%l><, %s>}

@Preamble{{}}
% This file was created with JabRef 2.9.2.
% Encoding: Cp1252

Quel est donc le rapport entre "Cp1252" et "utf8" ? Est-ce que le souci pourrait venir de là ? Comment alors modifier cet encodage ?
Merci d'avance pour les réponses

JF
Coumbralhaud
Déca-utilisateur
 
Messages: 22
Inscription: Mardi 27 Août 2013, 22:32
Statut actuel: Actif et salarié | Enseignant

Re: Incompatibilité ucs / biblatex ?

Messagepar rebouxo » Vendredi 30 Août 2013, 22:55

Ben des ennuis.
Enregistre ta base de donnée biblio en utf-8 avec emacs et mule, par exemple.

Il vaut mieux que tous tes fichiers soient dans le me encodage.

Olivier
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6861
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Re: Incompatibilité ucs / biblatex ?

Messagepar balf » Vendredi 30 Août 2013, 23:09

Cp1252 désigne l'encodage Windows ANSI (c'est à peu près isolatin 1). Le problème vient peêut-être en effet de là.

Dans le menu « Options -> Préférences -> Général  » de JabRef, vous pouvez mettre l'encodage par défaut à UTF8 (c'est même conseillé si l'on veut utiliser Biber), et tenter de réengistrer le fichier bib, en espérant qu'il sera converti (et supprimez la ligne de commentaires indiquant que c'est du Cp 1252). Toutefois, je ne suis pas sûr que ça ne mette pas le souk dans le fichier (donc faites une version de sauvegarde au préalable). Si avez des utilitaires sous linux pour convertir, faites-le.

Autre solution : utiliser un convertisseur comme Kaboom : vous indiquez le codage d'entrée (maintenant que vous en êtes sûr) et demandez à passer en utf8.

Ou bien vous installez la dernière version de WinEdt (8) (elle est utilisable à titre d'essai durant un mois) et sur le site de WinEdt.org, vous téléchargez une macro qui s'appelle ANSI2UTF8 qui, une fois exécutée, installe un supplément au menu fichier de WinEdt qui permet de faire la conversion. Vous pouvez aussi convertir les fins de ligne au format unix si c'est nécessaire.

Voilà. j'espère que ça finira par marcher !

B.A.
balf
Zetta-utilisateur
 
Messages: 3748
Inscription: Mercredi 02 Janvier 2008, 23:18
Statut actuel: Actif et salarié | Maître de conférence

Re: Incompatibilité ucs / biblatex ?

Messagepar Coumbralhaud » Samedi 31 Août 2013, 13:41

Bonjour

Merci de la réponse.
Malheureusement, cela n'a rien changé. Le fichier est bien passé en utf8. Mais il ne s'affiche toujours pas dans le document.

Petite question connexe : Emacs, quand il ouvre le fichier *.bib, permet de lui ajouter un préambule : "Entry-types" > "Preamble".
À quoi cela sert-il ? Est-ce que cela pourrait être utile pour mon souci ?

Le souci pourrait-il se situer ailleurs, du côté de biber ou de biblatex, par exemple ?

Bonne journée.

JF
Coumbralhaud
Déca-utilisateur
 
Messages: 22
Inscription: Mardi 27 Août 2013, 22:32
Statut actuel: Actif et salarié | Enseignant

Re: Incompatibilité ucs / biblatex ?

Messagepar balf » Samedi 31 Août 2013, 14:16

Pour Emacs : je ne sais pas, je n'ai jamais réussi à me faire à Emacs.
Pour Biber ou Biblatex : personnellement, quand j'ai eu des problèmes, c'était mon fichier .bib qui posait problème. Avez-vous jeté un œil au fichier .blg ? D'autre part, si vous pouviez fournir un extrait de votre fichier .bib, il serait possible de tester.

B.A.
balf
Zetta-utilisateur
 
Messages: 3748
Inscription: Mercredi 02 Janvier 2008, 23:18
Statut actuel: Actif et salarié | Maître de conférence

Re: Incompatibilité ucs / biblatex ?

Messagepar Coumbralhaud » Lundi 02 Septembre 2013, 06:53

Bonjour
Merci des conseils. Apparemment, mon fichier bib est désormais codé en utf8. Mais cela ne change rien : dans un message des logs, j'ai lu "empty bibliography". Le fichier bibliographique serait donc vide ? Il contient pourtant plus de 300 référrences...

J'en ferai un extrait ce soir.

JF
Coumbralhaud
Déca-utilisateur
 
Messages: 22
Inscription: Mardi 27 Août 2013, 22:32
Statut actuel: Actif et salarié | Enseignant

Re: Incompatibilité ucs / biblatex ? [Résolu]

Messagepar Coumbralhaud » Mercredi 30 Octobre 2013, 18:38

Bonsoir
Désolé de ne pas avoir continué le fil de discussion. Mais les ennuis se sont abattus sur moi comme une grosse averse. Alors, les problèmes de Latex sont passés au dernier rang.
J'ai quand même résolu le souci en éliminant ucs et en utilisant Komascript. Je n'ai pas vraiment compris mais l'essentiel est que cela fonctionne !
JFM
Coumbralhaud
Déca-utilisateur
 
Messages: 22
Inscription: Mardi 27 Août 2013, 22:32
Statut actuel: Actif et salarié | Enseignant

Re: Incompatibilité ucs / biblatex ?

Messagepar balf » Mercredi 30 Octobre 2013, 19:03

J'ai eu il n'y a pas très longtemps un problème d'« empty bibliography », alors que le fichier était bien là, à la suite d'une compilation qui bloquait. Outre le vidage des fichiers auxiliaires, il a fallu supprimer un cache binaire corrompu, créé (sous Windows 7) dans
C:\Username\ApppData\Local\Temp\par-(et une série de chiffres et lettres). J'ai cru comprendre que le fichier .bib disparaissait des écrans radar s'il advenait que ce cache fût corrompu.

B.A?
balf
Zetta-utilisateur
 
Messages: 3748
Inscription: Mercredi 02 Janvier 2008, 23:18
Statut actuel: Actif et salarié | Maître de conférence

[résolu] Re: Incompatibilité ucs / biblatex ?

Messagepar Coumbralhaud » Mercredi 30 Octobre 2013, 20:23

Je crois que le problème était dû surtout à mon incompréhension du système. Je l'ai résolu à force d'essayer ceci ou cela ou autre chose mais je n'ai pas noté, agacé par des problèmes exterieurs. J'ai eu de la chance, c'est tout mais c'est ennuyeux de ne pas se rappeler comment on est arrivé à quelque chose...
Je n'utilise pas Windows 7, je travaille sous Debian (Wheezy maintenant).
Bonne soirée
Coumbralhaud
Déca-utilisateur
 
Messages: 22
Inscription: Mardi 27 Août 2013, 22:32
Statut actuel: Actif et salarié | Enseignant


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Ahrefs [Bot], Bing [Bot], Google [Bot], Google Adsense [Bot], Proximic [Spider] et 31 invités