gummi

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

gummi

Messagepar jobonne » Vendredi 15 Septembre 2017, 11:53

Bonjour,

Je suis sur Linux Ubuntu 16.04 LTS. J'ai téléchargé TeXlive 2017 qui fonctionne très bien avec TeXmaker.
/usr/local/texlive/2017/bin/x86_64-linux/pdflatex est le chemin que j'ai déclaré dans le fichier de configuration de TeXmaker et qui ne pose pas de problème.

Par contre, j'ai téléchargé et installé gummi qui donne satisfaction avec un fichier.tex basique mais qui ne fonctionne pas avec toute sorte de packages comme si la compilation ne trouvait pas le chemin vers TeXlive cité précédemment. Je suis allé dans .config/gummi/gummi.conf' pour tenter de modifier le chemin vers texlive mais sans succès.

Est-ce que quelqu'un a une idée, comment faire pour que gummi fonctionne comme texmaker?
Merci.
Jo
jobonne
Déca-utilisateur
 
Messages: 34
Inscription: Vendredi 22 Novembre 2013, 12:31
Localisation: Bruxelles
Statut actuel: Actif et salarié | Enseignant

Publicité

Re: gummi

Messagepar gigiair » Vendredi 15 Septembre 2017, 14:19

Sans doute que le mode de compilation n'est pas le même. Ni TeXMaker ni gummi n'ont le contrôle de la compilation LaTeX et n'exécutent aucune commande. Ils se contentent d'envoyer une commande via le système. Le résultat sera le même quelque soit l'éditeur, à condition que la commande soit la même.
Dans le cas de gummi, les possibilités de configuration sont bien limitées, via le menu édition/préférences/compilation.
gummi paraît quand même plutôt léger. Curieux aussi que shell-escape soit proposée par défaut.
TeXMaker offre une palette de modes de compilation beaucoup plus complète.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2286
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: gummi

Messagepar jobonne » Lundi 18 Septembre 2017, 08:51

Bonjour,

De tempérament obstiné, je ne me suis pas satisfait de la réponse précédente... et je suis arrivé à mon but!
1) J'avais une vieille version de TeXlive 2015 installée depuis les dépôts Ubuntu que j'ai supprimée grâce au gestionnaire de paquets Synaptic
Résultat: Gummi ne trouvait plus aucun moyen de compiler. La situation était donc moins bonne qu'avant puisque Gummi compilait à partir de ma version 2015 installée à partir des dépôts.
2) Je suis allé à la racine de mon disque (2 fois cd .. avec le Terminal) puis cd etc pour rentrer dans le dossier etc puis sudo chmod 777 environment pour avoir les droits de faire ce que je veux dans ce fichier après introduction du mot de passe demandé. J'ai ensuite modifié la ligne suivante:
3) PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games" modifié comme suit:
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/local/texlive/2017/bin/x86_64-linux"
complément qui donne le chemin permettant de lancer la compilation comme avec TeXmaker. C'est le chemin par défaut d'installation de TeXlive à partir du site officiel http://www.tug.org
4) redémarrage. Surprise Gummi fonctionne mais avec Xelatex par défaut. Pour lancer pdflatex: menu Document, options de compilation, réinitialiser. Et là, le bonheur! çà marche!

En espérant que cela puisse éventuellement servir à quelqu'un!
Gummi n'est pas mal notamment quand on utilise TikZ pour effectuer un dessin: voir en live c'est pas mal!

Bien à vous
Jo
jobonne
Déca-utilisateur
 
Messages: 34
Inscription: Vendredi 22 Novembre 2013, 12:31
Localisation: Bruxelles
Statut actuel: Actif et salarié | Enseignant

Re: gummi

Messagepar gigiair » Mardi 19 Septembre 2017, 21:16

jobonne a écrit:2) Je suis allé à la racine de mon disque (2 fois cd .. avec le Terminal) puis cd etc pour rentrer dans le dossier etc puis sudo chmod 777 environment pour avoir les droits de faire ce que je veux dans ce fichier après introduction du mot de passe demandé. J'ai ensuite modifié la ligne suivante:

Je ne suis pas sûr que ce soit la meilleure idée. Tu n'est pas le seul à avoir le droit de faire ce que tu veux dans ce fichier qui est un fichier très sensible pour la sécurité.
La procédure à suivre est décrite en fin d'installation de texlive2017.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2286
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: gummi

Messagepar jobonne » Mercredi 20 Septembre 2017, 06:41

Merci pour cet avertissement!
Jo
jobonne
Déca-utilisateur
 
Messages: 34
Inscription: Vendredi 22 Novembre 2013, 12:31
Localisation: Bruxelles
Statut actuel: Actif et salarié | Enseignant


Retourner vers LaTeX

Qui est en ligne

Utilisateurs parcourant ce forum: Google [Bot], Proximic [Spider] et 15 invités