[Résolu] Gros bug

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

[Résolu] Gros bug

Messagepar Mikelenain » Lundi 22 Janvier 2018, 22:55

Bonjour à tous

j'ai fait, je crois, une grosse erreur. J'avais installé texlive 2017 correctement et proprement, il y a deux mois, avec ./install-tl. Ça fonctionnait nickel.

Ce soir, j'ai voulu mettre pyromaths qui, apparemment, est entré en conflit avec texlive. Du coup, j'ai autoremove pyromaths mais ça m'a fait une autre erreur (il ne retrouvait plus /usr/bin/latex). Bref, j'ai réinstallé texlive avec la commande ./install-tl et ... et là, j'ai un problème avec dvips. En effet, quand je lance la commande dvips, il me sort ceci :

Code: Tout sélectionner
$ dvips Vecteurs01.dvi
This is dvips(k) 5.997 Copyright 2017 Radical Eye Software (www.radicaleye.com)
' TeX output 2018.01.22:2248' -> Vecteurs01.ps
dvips: ! Couldn't find header file: pstricks.pro


Bref, il ne trouve pas ce header et je ne sais comment le lui faire retrouver :s

Du coup, si vous pouviez m'aider à résoudre mon problème, cela m'aiderait grandement.

Merci d'avance
Mike
Dernière édition par Mikelenain le Mardi 23 Janvier 2018, 17:09, édité 1 fois.
"L'ignorance n'est pas ne pas connaître, c'est ne pas vouloir connaître."

Une ch'tio peu d'pub :Ina-Ich

Ubuntu | LibreOffice | GnuPlot | PidGin | irssi | Mozilla | VLC ...
Mikelenain
Exa-utilisateur
 
Messages: 2627
Inscription: Dimanche 28 Février 2010, 11:54
Localisation: Région Lyonnaise
Statut actuel: Actif et salarié | Enseignant

Publicité

Re: Gros bug

Messagepar gigiair » Lundi 22 Janvier 2018, 23:37

Pas facile de réparer à distance comme ça. Normalement la réinstallation de TeXLive aurait du réinstaller pstricks.pro.
Pourrait-tu poster ici le retour des commandes :
Code: Tout sélectionner
kpsewhich texmf.cnf
ls -l $(which pdftex)

Si tu ne comprends pas la signification de ce code, exécute-le par copier-coller et poste le retour de ces deux commandes de la même façon.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2340
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Gros bug

Messagepar Mikelenain » Lundi 22 Janvier 2018, 23:39

Je viens de tester pdflatex. Ça fonctionne correctement. Mais étrangement, un compilation Latex, dvips, ps2pdf plante à la deuxième étape comme annoncé précédemment ... :o
"L'ignorance n'est pas ne pas connaître, c'est ne pas vouloir connaître."

Une ch'tio peu d'pub :Ina-Ich

Ubuntu | LibreOffice | GnuPlot | PidGin | irssi | Mozilla | VLC ...
Mikelenain
Exa-utilisateur
 
Messages: 2627
Inscription: Dimanche 28 Février 2010, 11:54
Localisation: Région Lyonnaise
Statut actuel: Actif et salarié | Enseignant

Re: Gros bug

Messagepar Mikelenain » Lundi 22 Janvier 2018, 23:41

Voici ce que j'obtiens :

Code: Tout sélectionner
mike@la-haute-tour:~$ kpsewhich texmf.cnf
/etc/texmf/web2c/texmf.cnf
mike@la-haute-tour:~$ ls -l $(which pdftex)
-rwxr-xr-x 1 root root 825784 août  11 00:45 /usr/bin/pdftex
"L'ignorance n'est pas ne pas connaître, c'est ne pas vouloir connaître."

Une ch'tio peu d'pub :Ina-Ich

Ubuntu | LibreOffice | GnuPlot | PidGin | irssi | Mozilla | VLC ...
Mikelenain
Exa-utilisateur
 
Messages: 2627
Inscription: Dimanche 28 Février 2010, 11:54
Localisation: Région Lyonnaise
Statut actuel: Actif et salarié | Enseignant

Re: Gros bug

Messagepar gigiair » Mardi 23 Janvier 2018, 10:16

Je m'en doutait un peu install-tl n'a pas été exécuté complètement. Il faut modifier l'environnement « à la main » après l'exécution du script install-tl.
La désinstallation de pyromath n'a pas supprimé l'installation de TeXLive depuis les dépôts Ubuntu, d'où le conflit.
Je suis prêt à parier que la variable d'environnement PATH n'a pas été modifiée.

Vérifier que la variable $PATH ne fait pas référence à TeXLive 2017 :
Code: Tout sélectionner
echo $PATH


Suivant que install-tl a été lancé en mode USER ou en mode super utilisateur, les modifications de l'environnement sont faites dans le fichier ~/.profile ou dans le fichier /etc/environment.
J'ai réalisé un petit script qui se trouve sur ce serveur.
Je l'ai testé sur ma machine gnu/Linux (Debian buster). Il est sans doute valide pour n'importe quelle autre distribution et peut-être même sous OS/X mais je n'ai jamais effectué d'installation TeXLive sous cet OS.
Pour l'installer sur une machine (linux) exécuter les commandes (lire le fichier avant par sécurité ! ) :
Code: Tout sélectionner
wget http://ix.io/EHD  -O post-install-tl.sh
bash  ./post-install-tl.sh
#ou si l'installation a été faite en mode super utilisateur
 sudo bash  ./post-install-tl.sh&&source /etc/environment

Le script prévoit une copie du fichier de configuration avant les modifications.
En cas de malheur
Code: Tout sélectionner
cp ~/.profile-initial ~/.profile
#ou sudo cp /etc/environment-initial /etc/environment

Pour remettre tout en place. La modification de l'environnement est une opération dangereuse. J'ai testé toutes les opérations que je conseille sur ma machine, mais pas sur les machines que je ne connais pas.
Dernière édition par gigiair le Vendredi 26 Janvier 2018, 14:58, édité 3 fois.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2340
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Gros bug

Messagepar Mikelenain » Mardi 23 Janvier 2018, 15:04

Bonjour, tout d'abord, merci de votre aide.

Quand je demande d'afficher $PATH, il me répond :
Code: Tout sélectionner
mike@la-haute-tour:~$ echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/usr/local/texlive/2017/bin/x86_64-linux/

En voyant la dernière entrée, je ne m'étais pas inquiété outre mesure :s

Dans le fichier /etc/environnement, j'ai ceci :
Code: Tout sélectionner
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"


L'installation a été faite en superuser, sur une machine Xubuntu 17.10.
"L'ignorance n'est pas ne pas connaître, c'est ne pas vouloir connaître."

Une ch'tio peu d'pub :Ina-Ich

Ubuntu | LibreOffice | GnuPlot | PidGin | irssi | Mozilla | VLC ...
Mikelenain
Exa-utilisateur
 
Messages: 2627
Inscription: Dimanche 28 Février 2010, 11:54
Localisation: Région Lyonnaise
Statut actuel: Actif et salarié | Enseignant

Re: Gros bug

Messagepar gigiair » Mardi 23 Janvier 2018, 15:52

Lorsque l'usager envoie une commande, le système la recherche en parcourant l'arborescence décrite par la variable d'environnement PATH.
Le système parcourt cette arborescence de la gauche vers la droite, et la recherche s'arrête à la première entrée trouvée.
C'est pourquoi sur ton système, l'appel de pdftex est trouvé dans /usr/local/bin qui est visité avant /usr/local/texlive/2017/bin/x86_64-linux.
le pdftex dans ce dernier répertoire sera purement et simplement ignoré. Mais ce n'est pas ce qui est voulu !

Il faut donc modifier le PATH pour que /usr/local/texlive/2017/bin/x86_64-linux soit à gauche de /usr/local/bin/pdftex.

IL faut trouver où a été défini ce PATH (j'imagine que c'est dans ~/.profile mais sa place serait mieux dans /etc/environment).
Faire une copie de sauvegarde en cas de pépin, ou pour rétablir l'environnement en cas de désinstallation.
Code: Tout sélectionner
PATH=/usr/local/texlive/2017/bin/x86_64-linux:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:

Après modification du fichier de configuration (~/.pofile, ~/.bashrc ou /etc/environment), il faut relancer la session, ou taper
Code: Tout sélectionner
source <fichier de configuration>
pour que la modification du PATH soit effective.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2340
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Gros bug

Messagepar Mikelenain » Mardi 23 Janvier 2018, 16:53

gigiair a écrit:Lorsque l'usager envoie une commande, le système la recherche en parcourant l'arborescence décrite par la variable d'environnement PATH.

Ça je le savais.

gigair a écrit:Le système parcourt cette arborescence de la gauche vers la droite, et la recherche s'arrête à la première entrée trouvée.
C'est pourquoi sur ton système, l'appel de pdftex est trouvé dans /usr/local/bin qui est visité avant /usr/local/texlive/2017/bin/x86_64-linux.
le pdftex dans ce dernier répertoire sera purement et simplement ignoré. Mais ce n'est pas ce qui est voulu !

Par contre, ça tu me l'apprends

gigair a écrit:Il faut donc modifier le PATH pour que /usr/local/texlive/2017/bin/x86_64-linux soit à gauche de /usr/local/bin/pdftex.

IL faut trouver où a été défini ce PATH (j'imagine que c'est dans ~/.profile mais sa place serait mieux dans /etc/environment).


Ce qui m'ennuie c'est que je ne vois /usr/local/texlive/2017/bin/x86_64-linux ni dans le ~/.profile, ni dans le /etc/environment. Pourtant il apparaît bien dans le PATH.

dans ~/.profile :

Code: Tout sélectionner
# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
   . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi


dans /etc/environment :

Code: Tout sélectionner
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"


Par contre, je l'ai trouvé dans ~/.bashrc

Code: Tout sélectionner
[...]

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

PATH=$PATH:/usr/local/texlive/2017/bin/x86_64-linux/


Si je modifie la dernière ligne en mettant ainsi :
Code: Tout sélectionner
PATH=/usr/local/texlive/2017/bin/x86_64-linux/:$PATH
. Cela fonctionnerait-il ? Ou est-ce obligatoire (ou plus propre) de le faire dans /etc/environment ?
"L'ignorance n'est pas ne pas connaître, c'est ne pas vouloir connaître."

Une ch'tio peu d'pub :Ina-Ich

Ubuntu | LibreOffice | GnuPlot | PidGin | irssi | Mozilla | VLC ...
Mikelenain
Exa-utilisateur
 
Messages: 2627
Inscription: Dimanche 28 Février 2010, 11:54
Localisation: Région Lyonnaise
Statut actuel: Actif et salarié | Enseignant

Re: Gros bug

Messagepar Mikelenain » Mardi 23 Janvier 2018, 17:09

Finalement, j'ai fait la dernière modification que j'ai proposé : modifier la dernière ligne dans la ~/.bashrc pour mettre
Code: Tout sélectionner
PATH=/usr/local/texlive/2017/bin/x86_64-linux/:$PATH


Ça fonctionne parfaitement. Maintenant, je me demande s'il ne serait finalement pas plus propre de le faire dans le fichier /etc/environment :o


Quoi qu'il en soit, comme cela fonctionne, j'édite le message de départ pour signaler que le problème a été résolu.

Un grand merci à toi, grand maître gigiair :)
"L'ignorance n'est pas ne pas connaître, c'est ne pas vouloir connaître."

Une ch'tio peu d'pub :Ina-Ich

Ubuntu | LibreOffice | GnuPlot | PidGin | irssi | Mozilla | VLC ...
Mikelenain
Exa-utilisateur
 
Messages: 2627
Inscription: Dimanche 28 Février 2010, 11:54
Localisation: Région Lyonnaise
Statut actuel: Actif et salarié | Enseignant

Re: Gros bug

Messagepar gigiair » Mardi 23 Janvier 2018, 19:48

Mikelenain a écrit:Ça fonctionne parfaitement. Maintenant, je me demande s'il ne serait finalement pas plus propre de le faire dans le fichier /etc/environment :o

dans /etc/environment, la modification du PATH c'est pour tous les USER de la machine, dans ~/.profile ,~/.bashrc ou dans d'autres fichiers de configuration c'est juste pour leur propriétaire. Si tu te connecte toujours sur le même compte, ça ne change absolument rien. Par contre, si tu loupe ta configuration de /etc/environment, pour réparer, i va falloir booter sur une clé USB ou un CD live ou en mode récupération (texte). Autrement, il suffit de se connecter sous un autre compte. Peu de différence en vérité pour la plupart des utilisateurs, il vaut mieux ne pas faire d'erreur quand on modifie son .profile.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2340
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: [résolu] Gros bug

Messagepar Mikelenain » Mardi 23 Janvier 2018, 19:56

effectivement. Autant le faire dans ~/.bashrc

et quelle différence entre ~/.bashrc et ~/.profile ?
"L'ignorance n'est pas ne pas connaître, c'est ne pas vouloir connaître."

Une ch'tio peu d'pub :Ina-Ich

Ubuntu | LibreOffice | GnuPlot | PidGin | irssi | Mozilla | VLC ...
Mikelenain
Exa-utilisateur
 
Messages: 2627
Inscription: Dimanche 28 Février 2010, 11:54
Localisation: Région Lyonnaise
Statut actuel: Actif et salarié | Enseignant

Re: [résolu] Gros bug

Messagepar gigiair » Mardi 23 Janvier 2018, 22:59

Je ne suis pas sûr que la question ait vraiment sa place sur un forum dédié à LaTeX. Un shell est un programme permettant de se connecter à un système. Il en existe pas mal, sh, csh, ksh etc..
et chacun d'eux a un fichier de configuration qui est lu à la connexion. .profile est le script de connexion de sh, .bashrc celui de bash. Comme bash a hérité de sh, .profile est également lu par bash.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2340
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: [résolu] Gros bug

Messagepar Mikelenain » Mercredi 24 Janvier 2018, 15:09

D'accord. Merci de la réponse même si elle est effectivement un peu HS.
"L'ignorance n'est pas ne pas connaître, c'est ne pas vouloir connaître."

Une ch'tio peu d'pub :Ina-Ich

Ubuntu | LibreOffice | GnuPlot | PidGin | irssi | Mozilla | VLC ...
Mikelenain
Exa-utilisateur
 
Messages: 2627
Inscription: Dimanche 28 Février 2010, 11:54
Localisation: Région Lyonnaise
Statut actuel: Actif et salarié | Enseignant


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 10 invités

cron