Gestion d'accents en Texshop

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Gestion d'accents en Texshop

Messagepar marito » Jeudi 26 Octobre 2006, 15:54

Bonjour,

Je suis nouveau à ce forum et je me tourne vers vous dans l'éspoir de faire refonctionner mon TexShop!

J'ai travaillé en Texshop pour mes travaux et, après un peu de "bricolage", j,ai même réussi à le faire fonctionner en français! Cependant, j'ai fait une petite pause dans l'utilisation du programme, pause pendant laquelle j'ai fait une mise à jour du système vers OSX 10.4.7. Maintenant que je veux recommencer à écrire en Latex, voilà que je vois mon Texshop se comporter bizarrement: il ne gère plus les caractère spéciaux, ni à l'affichage, ni en compilant.

Dans les vieux fichier .tex, ces lettres deviennent 'invisibles', c'est à dire qu'on ne les voit plus et ils n'occupent plus d'espace mais le document les compiles correctement. Si j'ouvre un nouveau document, là je les vois, mais ça ne compile pas! J'ai essayé de changer le codage (j'étais en isolatin2 avant, quand ça fonctionnait) vers macroman, mais c'est pareil.

Que faire? J'imagine que la mise à jour du OS a changé quelque chose dans la structure des fichiers tex. Y a-t-il des modification simple à faire pour regler le problème.

Je suis réticent à l'idée de tout réinstaller Tex et TexShop, parce que ça m'a pris pas mal de temps et de travail pour le faire fonctionner en français.

Quelqu'un qui peut me dire quel logiciel (Texmac, Lyx, etc.) qui est le plus facile à faire fonctionner correctement en français et/ou si on change fréquemment de langue? J'écris surtout en français, mais souvent en suédois et anglais également. Je n'écris plus tellement de formules mathématiques mais j'aime LaTex pour la gestion des références bibliographiques alors la gestion de caractères nationaux est critique!

Merci pour un conseil ou à défaut, une recommendation d' un logiciel.

Marito Olsson-Forsberg
Université Paris 8 Saint Denis.
marito
Utilisateur
 
Messages: 1
Inscription: Jeudi 26 Octobre 2006, 15:30

Publicité

Messagepar Arnaud » Jeudi 26 Octobre 2006, 16:12

Il s'agit à mon avis d'un problème d'encodage dû au changement d'environnement.

Peut-être qu'avec :

Code: Tout sélectionner
\usepackage[latin1]{inputenc}


Cela donnera qqch de mieux.
Si l'encodage de l'OS n'est pas 'latin1', il faut mettre autre chose, mais je n'ai pas la liste sous les yeux.
Arnaud

Un peu d'info - Pyromaths
LaTeX - Exemples de formules LaTeX

Pas d'aide en MP (non plus)
Arnaud
Modérateur
 
Messages: 7115
Inscription: Lundi 28 Août 2006, 12:18
Localisation: Allemagne
Statut actuel: Actif et salarié | Enseignant

Messagepar olivion » Jeudi 26 Octobre 2006, 21:23

Ce n'est pas simplement un problème d'encodage à régler dans le document par un \usepackage[latin1]{inputenc} (latin1 ou autre).
Le problème existant aussi à l'affichage (et pas seulement à la compilation), c'est à l'ouverture du fichier qu'il faut voir quel est le format d'encodage.
Donc dans le menu fichier, option Ouvrir, pour obtenir la fenêtre de choix de fichier à ouvrir, et en bas choisir le format d'encodage dans le menu déroulant encoding. Si l'affichage des caractères spéciaux est mauvais, fermer et réouvrir en choisissant un autre encodage, jusqu'à trouver le bon (dans l'ordre à mon avis, MacOSRoman - Iso Latin 1 - UTF-8 Unicode, pour trouver le bon encodage).
Ensuite, le sauvegarder dans le format d'encodage qu'on préfère.

Dans les préférences, à l'onglet document, on fixe l'encodage préféré.

Et ensuite, quand tout est réglé de cette façon, on peut aussi régler l'encodage dans le document par le \usepackage[utf8]{inputenc} par exemple pour la compilation...

En espérant avoir été clair,

cordialement,

Olivier
olivion
Hecto-utilisateur
 
Messages: 57
Inscription: Jeudi 01 Juin 2006, 23:59
Localisation: Buenos Aires
Statut actuel: Actif et salarié | Enseignant

Messagepar Madzone » Vendredi 27 Octobre 2006, 10:27

Salut,
j'ai eu des problèmes similaires au départ.
je suis également nouveau sous LaTeX.
en feuilletant un livre dans un magasin j'ai résolu mon problème en rentrant le code suivant dans le préambule.

%Reconnaissance des lettre du clavier
\usepackage[applemac]{inputenc}

%Langue utilisée
\usepackage[francais]{babel}
\usepackage[T1]{fontenc}


Ca marche bien ca te permet de taper les accents sans faire le \'e mais directement é donc gain de temps en perspective.

Sinon, j'enregistre en macroman.
Pour info je suis sous Mac (iBookG4) si jamais ca change quelque chose pour vos conseils
Madzone
Déca-utilisateur
 
Messages: 14
Inscription: Mercredi 18 Octobre 2006, 18:49
Localisation: Toulouse

Messagepar Arnaud » Vendredi 27 Octobre 2006, 11:02

Pour ma part, sous linux, ce que j'ai cité en haut avait résolu le problème qui avait les mêmes symptômes.

Je ne suis pas spécialiste de mac, heureusement que Madzone nous partage sa solution :D
Arnaud

Un peu d'info - Pyromaths
LaTeX - Exemples de formules LaTeX

Pas d'aide en MP (non plus)
Arnaud
Modérateur
 
Messages: 7115
Inscription: Lundi 28 Août 2006, 12:18
Localisation: Allemagne
Statut actuel: Actif et salarié | Enseignant


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Baidu [Spider], Exabot [Bot], Grapeshot [Crawler] et 25 invités