Francisation de mon document LaTeX

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Francisation de mon document LaTeX

Messagepar amelie » Dimanche 07 Septembre 2008, 15:47

Bonjour,

Je suis en train de taper un texte en français sur LaTeX.
Voici comment je procède :

Code: Tout sélectionner
\documentclass[11pt,a4paper, titlepage]{article}
\usepackage[latin1]{inputenc}
\usepackage[francais, english]{babel}
\usepackage[onehalfspacing]{setspace}
\usepackage{indentfirst}
\usepackage{booktabs}
\usepackage{array}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{amsthm}
\usepackage{lscape}
\usepackage[left=2.5cm, right=2.5cm]{geometry}

\begin{document}
\title{\textsc{xxxxxxxxxxxxxx}}
\author{ \textsc{xxxxxxxxxxx}\\
Laboratoire xxxxxxxxxxxxx \\} \maketitle


J'ai un problème avec la "francisation" de mon document. En particulier:

1) Lorsque je compile, j'ai ma date qui apparait en anglais, i.e. September 7, 2008, alors que je veux avoir 8 septembre 2008.
2) les guillemets sont inversés! Quand j'ouvre les guillemets je constate après compilation qu'il le guillemet du commencement regarde vers/s'ouvre dans le sens inverse.
3) Quand je tape mon texte sur Winedit, la plupart de mes mots (90%) apparaissent en rouge comme s'il y avait des fautes d'orthographe alors que ce n'est pas le cas. Pourquoi?

Une idée SVP?
Merci
Dernière édition par MB le Dimanche 07 Septembre 2008, 15:56, édité 4 fois.
Raison: Balises Code.
amelie
Déca-utilisateur
 
Messages: 45
Inscription: Dimanche 20 Janvier 2008, 15:25
Statut actuel: Post-bac

Publicité

Re: Francisation de mon document LaTeX

Messagepar MB » Dimanche 07 Septembre 2008, 15:59

amelie a écrit:1) Lorsque je compile, j'ai ma date qui apparait en anglais, i.e. September 7, 2008, alors que je veux avoir 8 septembre 2008.


Tu charges aussi la langue anglaise dans babel. Tu en as besoin ou ton document n'est qu'en français ?

amelie a écrit:2) les guillemets sont inversés! Quand j'ouvre les guillemets je constate après compilation qu'il le guillemet du commencement regarde vers/s'ouvre dans le sens inverse.


Pour les guillemets, utiliser \og et \fg.

amelie a écrit:3) Quand je tape mon texte sur Winedit, la plupart de mes mots (90%) apparaissent en rouge comme s'il y avait des fautes d'orthographe alors que ce n'est pas le cas. Pourquoi?


Il faut voir si c'est bien le dictionnaire français qui est utilisé.
MB (Pas d'aide en Message Privé)
Merci d'utiliser $\LaTeX$ (voir ici) et d'éviter le style SMS pour la lisibilité des messages.
MB
Administrateur
 
Messages: 6861
Inscription: Samedi 28 Mai 2005, 13:23
Localisation: Créteil
Statut actuel: Actif et salarié | Enseignant

Re: Francisation de mon document LaTeX

Messagepar amelie » Dimanche 07 Septembre 2008, 16:03

Mon document est en français mais il contient des passages en anglais.
Le dictionnaire utilisé est l'anglais. On fait comment pour le changer ?
amelie
Déca-utilisateur
 
Messages: 45
Inscription: Dimanche 20 Janvier 2008, 15:25
Statut actuel: Post-bac

Re: Francisation de mon document LaTeX

Messagepar MB » Dimanche 07 Septembre 2008, 16:11

amelie a écrit:Mon document est en français mais il contient des passages en anglais.


Dans ce cas tu devrais utiliser :

Code: Tout sélectionner
\usepackage[english,francais]{babel}


La dernière langue chargée est la langue principale (activée par défaut dans le document). Pour passer d'une langue à l'autre au cours du document, il faut utiliser la commande \selectlanguage{langue}.

amelie a écrit:Le dictionnaire utilisé est l'anglais. On fait comment pour le changer ?


Je ne sais pas trop car je n'utilise pas WinEdt (mais ça ne doit pas être bien compliqué). :wink:
MB (Pas d'aide en Message Privé)
Merci d'utiliser $\LaTeX$ (voir ici) et d'éviter le style SMS pour la lisibilité des messages.
MB
Administrateur
 
Messages: 6861
Inscription: Samedi 28 Mai 2005, 13:23
Localisation: Créteil
Statut actuel: Actif et salarié | Enseignant

Re: Francisation de mon document LaTeX

Messagepar balf » Mardi 09 Septembre 2008, 15:20

Pour utiliser automatiquement le dictionnaire de français (à installer d'abord à l'endroit ad hoc), il faut aller dans le menu Options, sous-menu Dictionary Manager et demander que fr.dic soit associé au sous-mode :FR (en demandant bien entendu que les documents latex en français aient le mode TEX et le sous-mode :FR. On peut même créer ses dictionnaires personnels qui se complètent peu à peu (p.ex. un dictionnaire des noms propres, ou des termes techniques français). Les détails sont expliqués dans l'aide en ligne de WinEdt. À signaler : le dictionnaire français fourni, créé à partir de celui de Word, semble-t-il, est assez incomplet (il connaît billevesée, mais pas coquecigrue, ni les imparfaits du subjonctifs...)

B.A.
balf
Zetta-utilisateur
 
Messages: 3748
Inscription: Mercredi 02 Janvier 2008, 23:18
Statut actuel: Actif et salarié | Maître de conférence


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Bing [Bot], Grapeshot [Crawler] et 13 invités