Font cmex9 at 600 not found

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Messagepar lebendre » Lundi 29 Mai 2006, 07:50

Tryphon a écrit:Il y a pas mal de gens ici qui pensent à toi et qui attendent sagement que tu aies récupéré ta machine Lundi...

Ah bien ça c'est gentil !!!
J'ai donc récupéré mon ordi, et regardé si le package cm était installé (c'était le cas :) ), réinstallé ce package pour vois si ça irait mieux (mais ce n'était pas le cas :( ).
Donc pour simplifier les choses et ne pas perdre trop de temps, j'ai réinstallé MikTeX et maintenant tout fonctionne à merveille!
Mes racines carrées s'affichent normalement, mon dvi ne bogue plus du tout, bref, tout le monde il est beau (ou du moins aujourd'hui...) :D

Bonne journée!
lebendre
Kilo-utilisateur
 
Messages: 153
Inscription: Jeudi 20 Avril 2006, 13:07

Publicité

Messagepar lebendre » Lundi 29 Mai 2006, 15:45

Tryphon a écrit:Tu peux aussi utiliser les versions Postscript des fontes Computer Modern en mettant dans ton entête \usepackage{lmodern} et en installant le package lm.

J'ai crié trop vite victoire ce matin... Lorsque j'utilise lmodern, les lettres accentuées sont simplement inexistantes lorsque je compile? Y'aurait-il une raison? J'ai pourtant bien installé le package lm!
lebendre
Kilo-utilisateur
 
Messages: 153
Inscription: Jeudi 20 Avril 2006, 13:07

Messagepar Tryphon » Lundi 29 Mai 2006, 20:40

Poste un Exemple complet Minimal, c'est-à-dire un code LaTeX court qui compile et qui produit le problème, histoire qu'on voit si c'est un problème de code, ou d'installation.

autre question : As-tu un répertoire \texmf\fonts\type1\public\lm ?
Tryphon
Péta-utilisateur
 
Messages: 1840
Inscription: Mercredi 01 Juin 2005, 17:39
Localisation: Un peu plus à l'Ouest
Statut actuel: Actif et salarié | Enseignant

Messagepar lebendre » Lundi 29 Mai 2006, 21:59

Je crois que j'ai trouvé le problème...
J'utilise en même temps \usepackage[T1]{fontenc} et \usepackage{lmodern}. Si je ne charge pas le premier, les accents s'affichent.

Par contre, il me dit:
LaTeX Font Warning: Font shape OT1/lmr/m/n undefined using OT1/cmr/m/n instead on input line 8

quand je compile
Code: Tout sélectionner
\documentclass[a4paper,11pt,oneside]{article}

%\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc}
\usepackage[frenchb]{babel}
\usepackage{lmodern}

\begin{document}
aà eé iï oô uù
\end{document}
lebendre
Kilo-utilisateur
 
Messages: 153
Inscription: Jeudi 20 Avril 2006, 13:07

Messagepar Tryphon » Lundi 29 Mai 2006, 22:10

Pourquoi commentes-tu le \usepackage[T1]{fontenc} ?
Tryphon
Péta-utilisateur
 
Messages: 1840
Inscription: Mercredi 01 Juin 2005, 17:39
Localisation: Un peu plus à l'Ouest
Statut actuel: Actif et salarié | Enseignant

Messagepar lebendre » Lundi 29 Mai 2006, 22:15

En fait, j'ai fait deux essais:
- avec fontenc : les lettres accentuées ne s'affichent pas
- sans fontenc : les lettres accentuées s'affichent
Et j'ai copié le code du deuxième essai tel quel, donc c'est pour ça que la ligne est en commentaire...
Mais est-ce que c'est incompatible d'utiliser en même temps [T1]{fontenc} et {lmodern}???
lebendre
Kilo-utilisateur
 
Messages: 153
Inscription: Jeudi 20 Avril 2006, 13:07

Messagepar rebouxo » Mardi 30 Mai 2006, 07:07

lebendre a écrit:Mais est-ce que c'est incompatible d'utiliser en même temps [T1]{fontenc} et {lmodern}???


Non, au contraire. Il doit te manquer les fichiers des fontes. C'est bizarre puisque tu as fais une installation complète de MiKteX.
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6859
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Messagepar lebendre » Mardi 30 Mai 2006, 09:52

Non, j'ai pas installé Full-MikTeX, mais seulement Small, donc peu de packages. Tu sais lesquels il faut que j'installe en plus pour que mes accents s'affichent?
Parce que lorsque je compile, il me fait 0 warning et 0 error donc je sais pas quel package manque!
(d'habitude je suis content, quand il n'y a ni erreur, ni avertissement, mais là, j'aimerais bien qu'il y en ait)
lebendre
Kilo-utilisateur
 
Messages: 153
Inscription: Jeudi 20 Avril 2006, 13:07

Messagepar rebouxo » Mardi 30 Mai 2006, 10:28

Ce que je sais c'est que ce n'est pas un package. Le package c'est lmodern et comme il n'y a pas de message d'erreur c'est bon.

Il faut récupérer les fontes lm (avec le MiKTeX package manager) ce doit être possible, mais je ne sais pas comment. Ce qui est bizarre c'est qu'il n'y est pas gestion des dépendances, installer lmodern sans les fontes qui vont avec cela n'a aucun intérêt.

Olivier
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6859
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Messagepar lebendre » Mardi 30 Mai 2006, 10:53

J'ai trouvé quelque part sur le net (merci google) un petit tutoriel pour utiliser lmodern. Et ils installaient également le package "cm-super".
J'ai donc essayé (parce que cm-super fait aussi partie des polices Type1) et... ô miracle... ça fonctionne! :D

Bon appétit!
lebendre
Kilo-utilisateur
 
Messages: 153
Inscription: Jeudi 20 Avril 2006, 13:07

Messagepar la main gauche » Mardi 30 Mai 2006, 11:52

Pour information, il me semble que les fontes Latin Modern ont vocation à remplacer les fontes cm-super (versions de type 1 des fontes de Jorg Knappen European Computer Modern); elles bénéficient notamment d'une meilleure finition.
la Main Gauche
la main gauche
Méga-utilisateur
 
Messages: 274
Inscription: Jeudi 30 Mars 2006, 07:44
Localisation: selon l'idéal de la liberté

Messagepar rebouxo » Mardi 30 Mai 2006, 14:30

Pour TeX la référence est les sites CTAN : Comprehensive TeX Archive Network
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6859
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Messagepar Tryphon » Mardi 30 Mai 2006, 18:19

Rassurez-moi : mis à part l'encodage et le format Postscript ou Metafont (et donc le fait que les courbes composant les glyphes sont légèrement différentes, ce qui doit produire des écarts de 1 pixel avec des imprimantes à 12000000 dpi), il n'y a pas de différence entre lmodern et cmr, si ?
Tryphon
Péta-utilisateur
 
Messages: 1840
Inscription: Mercredi 01 Juin 2005, 17:39
Localisation: Un peu plus à l'Ouest
Statut actuel: Actif et salarié | Enseignant

Messagepar rebouxo » Mardi 30 Mai 2006, 20:04

Ben l'encodage c'est déjà important. Beaucoup plus que la forme des glyphes.
Visuellement je trouve les latin modern très proche des computer modern de Knuth.

Olivier
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6859
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Messagepar Tryphon » Mercredi 31 Mai 2006, 20:26

Oui bien sûr, l'encodage est important. Mais les polices ecmr sont des versions Métafont des polices cmr respectant l'encodage T1.

Réciproquement, il existe des fontes virtuelles pour à peu près toutes les fontes Postscript classiques qui permettent de les utiliser comme des polices T1.

Je voulais être sûr que les fontes latin modern sont basées, au niveau du dessin des caractères, sur les fontes Computer Modern de Knuth (et Zapf je crois).
Tryphon
Péta-utilisateur
 
Messages: 1840
Inscription: Mercredi 01 Juin 2005, 17:39
Localisation: Un peu plus à l'Ouest
Statut actuel: Actif et salarié | Enseignant

Messagepar la main gauche » Jeudi 01 Juin 2006, 09:01

lebendre a écrit:j'ai plus ou moins trouvé l'erreur, qui vient de Miktex et non d'un quelconque manque de dollars


Mixtex est gratuit hi hi.
la Main Gauche
la main gauche
Méga-utilisateur
 
Messages: 274
Inscription: Jeudi 30 Mars 2006, 07:44
Localisation: selon l'idéal de la liberté

Précédente

Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Grapeshot [Crawler] et 14 invités