[Résolu] Erreur étrange

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

[Résolu] Erreur étrange

Messagepar pavel_vikanov » Dimanche 25 Novembre 2012, 23:31

Bonsoir,

Je suis en train de compiler un article et depuis que j'ai changé des P<0.05 en P=0.05 LaTeX me fait cette erreur étrange qui pourtant ne semble pas affecter le rendu du *.pdf final :

Code: Tout sélectionner
! LaTeX Error: \mathrm allowed only in math mode.
See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
...
l.6 ... are significantly different (P=0.05)}}{42}
You're in trouble here. Try typing <return> to proceed.
If that doesn't work, type X <return> to quit.


J'avoue rester un peu perplexe puisqu'en plus l'erreur pointe sur la ligne 6 de mon document (\documentclass[preprint,review,authoryear,12pt]{elsarticle} % doublespacing) malgré le fait que le "are significantly different blablabla" fait parti de mon texte et notamment d'une zone à laquelle j'ai touchée pour cette histoire de changement de < en =.

Si quelqu'un a une idée.

Au cas où mon préambule :

Code: Tout sélectionner
%pdflatex


%\documentclass[preprint,authoryear,12pt]{elsarticle}
% \documentclass[preprint,12pt]{elsarticle}
\documentclass[preprint,review,authoryear,12pt]{elsarticle}  % doublespacing
% \documentclass[final,1p,times]{elsarticle}
% \documentclass[final,1p,times,twocolumn]{elsarticle}
% \documentclass[final,3p,times]{elsarticle}
% \documentclass[final,3p,times,twocolumn]{elsarticle}
% \documentclass[final,5p,times]{elsarticle}
% \documentclass[final,5p,authoryear,times,twocolumn]{elsarticle}

\usepackage{amssymb}
\usepackage{array}
\usepackage{booktabs}
\usepackage{endfloat}
\usepackage{epsfig}
\graphicspath{{}}
%\usepackage[showframe]{geometry}
\usepackage{graphicx}
\usepackage{lineno}
\usepackage[squaren,Gray,cdot]{SIunits}
\usepackage{tabularx}
%\usepackage{hyperref}

\newcommand{\lup}{\emph{Lupinus albus}}
\newcommand{\lupam}{\emph{Lupinus albus cv. Amiga}}
\newcommand{\U}{UO$_{2}$\-(NO$_{3}$)$_{2}$}

\journal{X}


\begin{document}


Merci d'avance !


****** EDIT ******
Bon en fait je crois que c'est parce que j'ai mis des unités avec SIunits dans le \caption d'une figure... Fallait les mettre en mode maths... :roll:
Il vaut mieux être saoul que con, ça dure moins longtemps.
pavel_vikanov
Kilo-utilisateur
 
Messages: 141
Inscription: Mercredi 09 Décembre 2009, 13:17
Localisation: Aix en Provence
Statut actuel: Post-bac | Doctorat

Publicité

Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Google [Bot] et 11 invités