[Résolu] Compilation impossible avec latex

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

[Résolu] Compilation impossible avec latex

Messagepar Fabrice Couvreur » Dimanche 21 Juillet 2013, 11:34

Bonjour,
Suite à une mise à jour de TeXlive 2013, mais aussi de Ghostscript (sur Debian Sid, version 9.05), je ne sais plus compiler un seul fichier avec : latex -> dvips -> ps2pdf. Par contre, une compilation avec pdflatex fonctionne. La compilation avec latex ne produit pas de fichier au format dvi. Le problème vient peut-être de Ghostscript.
Par exemple, la compilation de celui-ci :

Code: Tout sélectionner
\documentclass[a4paper,11pt]{article}
\usepackage{etex}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{mathtools,amsmath,amsfonts,amssymb,amsthm,mathrsfs,nccmath}
\usepackage[frenchb]{babel}
\begin{document}
Résoudre dans $\mathbb{R}$ l'équation suivante :
\[x^2+4x-3=0.\]
\end{document}


retourne le message suivant :
Code: Tout sélectionner
Running `Dvips' on `forum_14' with ``dvips forum_14.dvi''
This is dvips(k) 5.993 Copyright 2013 Radical Eye Software (www.radicaleye.com)
dvips: DVI file can't be opened: forum_14.dvi: No such file or directory

Dvips exited abnormally with code 1 at Sun Jul 21 12:25:10


Si cela peut aider, voici le résultat de la compilation étape par étape :
Code: Tout sélectionner
fab@debian:~$ latex forum_14.tex
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013)
 restricted \write18 enabled.
entering extended mode
(./forum_14.tex
LaTeX2e <2011/06/27>
Babel <3.9f> and hyphenation patterns for 78 languages loaded.
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/size11.clo))
(/home/fab/texlive/2013/texmf-dist/tex/latex/etex-pkg/etex.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/inputenc.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/utf8.def
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/t1enc.dfu)
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/ot1enc.dfu)
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/omsenc.dfu)))
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/fontenc.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/t1enc.def))
(/home/fab/texmf/tex/latex/mathtools.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/graphics/keyval.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/tools/calc.sty)
(/home/fab/texmf/tex/latex/mhsetup.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsmath/amsmath.sty
For additional information on amsmath, use the `?' option.
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsmath/amstext.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsmath/amsgen.sty))
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsmath/amsbsy.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsmath/amsopn.sty)))
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsfonts/amsfonts.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsfonts/amssymb.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/amscls/amsthm.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/jknapltx/mathrsfs.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/ncctools/nccmath.sty)
(/home/fab/texlive/2013/texmf-dist/tex/generic/babel/babel.sty
(/home/fab/texlive/2013/texmf-dist/tex/generic/babel-french/frenchb.ldf
(/home/fab/texlive/2013/texmf-dist/tex/generic/babel/babel.def)))
(/home/fab/texlive/2013/texmf-dist/tex/latex/carlisle/scalefnt.sty)
(./forum_14.aux)
(/home/fab/texlive/2013/texmf-dist/tex/latex/graphics/graphicx.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/graphics/graphics.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/graphics/trig.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/latexconfig/graphics.cfg)
(/home/fab/texlive/2013/texmf-dist/tex/latex/graphics/dvips.def)))
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsfonts/umsa.fd)
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsfonts/umsb.fd)
(/home/fab/texlive/2013/texmf-dist/tex/latex/jknapltx/ursfs.fd) [1]
(./forum_14.aux) )
Output written on forum_14.dvi (1 page, 536 bytes).
Transcript written on forum_14.log.
fab@debian:~$ dvips forum_14.dvi
This is dvips(k) 5.993 Copyright 2013 Radical Eye Software (www.radicaleye.com)
' TeX output 2013.07.21:1244' -> forum_14.ps

kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag 1+0/600 --dpi 600 ecrm1095
mktexpk: don't know how to create bitmap font for ecrm1095.
mktexpk: perhaps ecrm1095 is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.
dvips: Font ecrm1095 not found; using cmr10
</usr/share/texlive/texmf-dist/fonts/pk/ljfour/public/cm/dpi600/cmr10.pk>
dvips: Design size mismatch in font ecrm1095
dvips: Checksum mismatch in font ecrm1095
dvips: ! invalid char 233 from font ecrm1095
fab@debian:~$ ps2pdf forum_14.ps
Error: /undefinedfilename in (forum_14.ps)
Operand stack:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push
Dictionary stack:
   --dict:1164/1684(ro)(G)--   --dict:0/20(G)--   --dict:77/200(L)--
Current allocation mode is local
Last OS error: No such file or directory
GPL Ghostscript 9.05: Unrecoverable error, exit code 1
fab@debian:~$ xpdf forum_14.pdf


Le problème semble venir d'ici :

Code: Tout sélectionner
dvips: Font ecrm1095 not found; using cmr10
</usr/share/texlive/texmf-dist/fonts/pk/ljfour/public/cm/dpi600/cmr10.pk>
dvips: Design size mismatch in font ecrm1095
dvips: Checksum mismatch in font ecrm1095
dvips: ! invalid char 233 from font ecrm1095

Merci.
Dernière édition par Fabrice Couvreur le Mercredi 24 Juillet 2013, 13:12, édité 3 fois.
Fabrice Couvreur
Giga-utilisateur
 
Messages: 601
Inscription: Samedi 18 Août 2007, 00:55

Publicité

Re: Compilation impossible avec latex

Messagepar gigiair » Lundi 22 Juillet 2013, 07:23

les fontes lmodern ou cm-super sont installées ?
Code: Tout sélectionner
# aptitude search lmodern cm-super
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2441
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Compilation impossible avec latex

Messagepar rebouxo » Lundi 22 Juillet 2013, 09:35

gigiair a écrit:les fontes lmodern ou cm-super sont installées ?
Code: Tout sélectionner
# aptitude search lmodern cm-super


Si c'est TexLive 2013, ce n'est pas via les dépôts de Debian. Où alors, je comprends cette soudaine hausse des températures :D .

Bon, cela dit, il y a manifestement un problème d'installation des fontes cmputer modern.
Essaye en mettant une extension gérant les fontes (lmodern, kpfonts, fourier, ...)

Olivier
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6949
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Re: Compilation impossible avec latex

Messagepar gigiair » Lundi 22 Juillet 2013, 10:19

rebouxo a écrit:Si c'est TexLive 2013, ce n'est pas via les dépôts de Debian.

Ben si. Debian (sid) fournit TeXLive2013 . C'est la distribution idéale pour les latexiens.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2441
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Compilation impossible avec latex

Messagepar rebouxo » Lundi 22 Juillet 2013, 10:25

Ben M**** alors. Après la canicule, on va avoir 40 jours de pluies, puis les 7 plaies d'Égypte :D . Qu'est-ce qui leur prend chez Debian ? TexLive 2013 n'est pas encore sorties officiellement (où alors j'ai loupé un épisode).


Olivier

Edit : Texlive 2013 est sortie. Bon, je vais allé chez mon Ophatalmo, moi.

Olivier
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6949
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Re: Compilation impossible avec latex

Messagepar gigiair » Lundi 22 Juillet 2013, 10:42

rebouxo a écrit:Ben M**** alors. Après la canicule, on va avoir 40 jours de pluies, puis les 7 plaies d'Égypte :D . Qu'est-ce qui leur prend chez Debian ? TexLive 2013 n'est pas encore sorties officiellement (où alors j'ai loupé un épisode).


Faut sortir des clichés. Normalement un matheux, ça n'a pas de préjugé. Il y a trois versions Debian : stable, testing, et sid (still in developpement). sid est une version très réactive. TL2013 est sortie le 21 juin, mais ça faisait un moment que c'était disponible pour tests.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2441
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Compilation impossible avec latex

Messagepar Fabrice Couvreur » Lundi 22 Juillet 2013, 11:02

Bonjour à tous,
Merci à ceux qui ont pris le temps de se pencher sur le problème.
Quelques précisions sur l'installation de TeXlive 2013 :
- installation en suivant les instructions du site http://www.tug.org/texlive/doc/texlive-fr/texlive-fr.html
- installation en mode user et non en mode root, ceci pour toujours avoir la dernière version d'Asymptote. Voici une partie du contenu du fichier /home/fab/.profile :
Code: Tout sélectionner
export PATH=$PATH:/home/fab/Asymptote/asymptote/bin
export PATH=$PATH:/home/fab/texlive/2013/bin/x86_64-linux
export MANPATH=$MANPATH:/home/fab/texlive/2013/texmf/doc/man
export INFOPATH=$INFOPATH:/home/fab/texlive/2013/texmf/doc/info
export PATH=$PATH:/home/fab/algobox_linux64
export PATH=$PATH:/home/fab/R-3.0.0/bin/R
export PATH=$PATH:/home/fab/sigil-0.7.2/build/bin/sigil
export LIBGS=/usr/lib/libgs.so.9


Devant ce problème, je suis repassé à TeXlive 2012 (que je garde en réserve) et là, surprise, le même constat alors que je n'avais jamais rencontré ce problème jusqu'ici. Voilà pourquoi, j'ai pensé que cela pouvait éventuellement provenir de Ghostscript qui a été récemment mis à jour sur Debian Sid avec, si ma mémoire est bonne, des dépendances non satisfaites.

@ rebouxo
rebouxo a écrit:Essaye en mettant une extension gérant les fontes (lmodern, kpfonts, fourier, ...)

Toujours le même problème. D'ailleurs, j'utilise toujours Kpfonts, et j'ai pensé que c'était cette extension l'origine du problème (d'où son absence dans l'ECM)

@ gigiair que je suis content de retrouver :wink:
Code: Tout sélectionner
fab@debian:~$ aptitude search lmodern cm-super
p   cm-super                        - TeX font package (full version) with CM (E
p   cm-super-minimal                - TeX font package (minimal version) with CM
p   cm-super-x11                    - Make the cm-super fonts available to X11 
i A fonts-lmodern                   - OpenType fonts based on Computer Modern   
i A lmodern                         - scalable PostScript and OpenType fonts bas
Fabrice Couvreur
Giga-utilisateur
 
Messages: 601
Inscription: Samedi 18 Août 2007, 00:55

Re: Compilation impossible avec latex

Messagepar rebouxo » Lundi 22 Juillet 2013, 13:57

Soit tu utilises les paquets de ta distrib (et donc aptitude machin bidule) soit tu utilises texlive à la main. Tu l'as fais à la main, puisque tu as utilisé le site de TUG pour l'installer. Ce que tu fais sur l'une des installations, n'a aucune influence sur l'autre.

Manifestement, tu as un problème avec tes fontes sur ton installation. Quelque chose ne s'est pas bien passé.

Je tenterais bien un
Code: Tout sélectionner
tlmgr install --reinstall kpfonts


Olivier
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6949
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Re: Compilation impossible avec latex

Messagepar Fabrice Couvreur » Lundi 22 Juillet 2013, 16:04

rebouxo a écrit:Ce que tu fais sur l'une des installations, n'a aucune influence sur l'autre.

Imaginons que je fasse deux installations, une via les paquets de ma distribution, l'autre via le site de TUG. Celle qui est installée en mode root est "prioritaire" sur l'autre, et donc la version d'Asymptote n'est pas la plus récente. Or, j'utilise beaucoup Asymptote, et j'aime avoir la version la plus récente. J'ai donc installé Asymptote en mode user et TeXlive 2013 en mode user dans mon /home/fab/.
Je le répète, je n'ai jamais eu de problèmes de mise à jour jusqu'ici, donc que c'est-il passé ?
J'ai donc refait l'installation complète, mais la situation empire, et j'ai d'autres problèmes :boat:
Si je compile maintenant le fichier avec latex, j'obtiens ceci :
Code: Tout sélectionner
fab@debian:~$ latex forum_14.tex
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian)
 restricted \write18 enabled.

kpathsea: Running mktexfmt latex.fmt
I can't find the format file `latex.fmt'!
fab@debian:~$ locate latex.fmt
locate: AVERTISSEMENT : la base de données ""/var/cache/locate/locatedb"" est plus vieille de 8 jours (âge actuel 283,9 jours)
/home/fab/texlive/2012/texmf-var/web2c/eptex/platex.fmt
/home/fab/texlive/2012/texmf-var/web2c/euptex/uplatex.fmt
/home/fab/texlive/2012/texmf-var/web2c/luatex/dvilualatex.fmt
/home/fab/texlive/2012/texmf-var/web2c/luatex/lualatex.fmt
/home/fab/texlive/2012/texmf-var/web2c/pdftex/cslatex.fmt
/home/fab/texlive/2012/texmf-var/web2c/pdftex/latex.fmt
/home/fab/texlive/2012/texmf-var/web2c/pdftex/mllatex.fmt
/home/fab/texlive/2012/texmf-var/web2c/pdftex/pdfcslatex.fmt
/home/fab/texlive/2012/texmf-var/web2c/pdftex/pdflatex.fmt
/home/fab/texlive/2012/texmf-var/web2c/xetex/xelatex.fmt
fab@debian:~$

Bref, que faut-il faire ? J'ai testé beaucoup de solutions proposées sur le net, mais aucune aboutit.
Merci.
Fabrice Couvreur
Giga-utilisateur
 
Messages: 601
Inscription: Samedi 18 Août 2007, 00:55

Re: Compilation impossible avec latex

Messagepar gigiair » Lundi 22 Juillet 2013, 18:37

Fabrice Couvreur a écrit:
Imaginons que je fasse deux installations, une via les paquets de ma distribution, l'autre via le site de TUG. Celle qui est installée en mode root est "prioritaire" sur l'autre,
Tu as lu ça quelque part ou c'est ce que tu as constaté ? Chez moi, rien de tel, Chez moi, c'est moi qui décide.
et donc la version d'Asymptote n'est pas la plus récente. Or, j'utilise beaucoup Asymptote, et j'aime avoir la version la plus récente. J'ai donc installé Asymptote en mode user et TeXlive 2013 en mode user dans mon /home/fab/.

Et ou as-tu placé les liens vers les exécutables ?
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2441
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Compilation impossible avec latex

Messagepar Fabrice Couvreur » Lundi 22 Juillet 2013, 21:04

Bonsoir,
@gigiair
J'ai constaté que si je faisais l'installation de TeXlive (via TUG) en mode root et celle d'Asymptote en mode user dans mon home, à l'invite de la commande
Code: Tout sélectionner
fab@debian:~$ asy
c'était le binaire d'Asymptote de TeXlive qui était pris en compte. D'où l'idée d'une installation de TeXlive et d'Asymptote dans mon /home/fab/. Jusqu'ici, cela avait toujours fonctionné.
Il faut absolument que je répare mon système, car je dois travailler pendant les vacances.
Je reprends ce que j'ai fait (et toujours fait, peut-être de façon incorrecte) :
Code: Tout sélectionner
fab@debian:~$ cd texlive/2013/install-tl-20130721/
fab@debian:~/texlive/2013/install-tl-20130721$ ./install-tl
Loading http://ctan.mines-albi.fr/systems/texlive/tlnet/tlpkg/texlive.tlpdb
Installing TeX Live 2013 from: http://ctan.mines-albi.fr/systems/texlive/tlnet
Platform: x86_64-linux => 'x86_64 with GNU/Linux'
Distribution: net  (downloading)
Using URL: http://ctan.mines-albi.fr/systems/texlive/tlnet
Directory for temporary files: /tmp

======================> TeX Live installation procedure <=====================

======>   Letters/digits in <angle brackets> indicate   <=======
======>   menu items for commands or options            <=======

 Detected platform: x86_64 with GNU/Linux
 
 <B> binary platforms: 1 out of 21

 <S> set installation scheme (scheme-full)

 <C> customizing installation collections
     44 collections out of 45, disk space required: 3307 MB

 <D> directories:
   TEXDIR (the main TeX directory):
     !! default location: /usr/local/texlive/2013
     !! is not writable or not allowed, please select a different one!
   TEXMFLOCAL (directory for site-wide local files):
     /usr/local/texlive/texmf-local
   TEXMFSYSVAR (directory for variable and automatically generated data):
     /usr/local/texlive/2013/texmf-var
   TEXMFSYSCONFIG (directory for local config):
     /usr/local/texlive/2013/texmf-config
   TEXMFVAR (personal directory for variable and automatically generated data):
     ~/.texlive2013/texmf-var
   TEXMFCONFIG (personal directory for local config):
     ~/.texlive2013/texmf-config
   TEXMFHOME (directory for user-specific files):
     ~/texmf

 <O> options:
   [ ] use letter size instead of A4 by default
   [X] allow execution of restricted list of programs via \write18
   [X] create all format files
   [X] install macro/font doc tree
   [X] install macro/font source tree

 <V> set up for portable installation

Actions:
 <I> start installation to hard disk
 <H> help
 <Q> quit

Enter command:

Je tape ensuite D, puis 1 pour mettre TEXDIR =~/texlive/2013, puis R et I, et c'est tout.
Une fois que l'installation est terminée, j'ai rajouté le répertoire des binaires de TeXlive 2013 dans mon PATH dans le fichier ./profile :
Code: Tout sélectionner
export PATH=$PATH:/home/fab/Asymptote/asymptote/bin
export PATH=$PATH:/home/fab/texlive/2013/bin/x86_64-linux
export MANPATH=$MANPATH:/home/fab/texlive/2013/texmf/doc/man
export INFOPATH=$INFOPATH:/home/fab/texlive/2013/texmf/doc/info
export PATH=$PATH:/home/fab/algobox_linux64
export PATH=$PATH:/home/fab/R-3.0.0/bin/R
export PATH=$PATH:/home/fab/sigil-0.7.2/build/bin/sigil
export LIBGS=/usr/lib/libgs.so.9

Y-a-t-il une étape que j'ai omise ?
Merci.
PS : j'ai peut-être résolu le problème. J'ai parcouru l'arborescence de mon système, et j'ai trouvé dans /usr/share/ les paquets texlive-base et texlive-common (ancienne installation ?) qui, à priori, n'avaient pas à être là puisque ma TeXlive 2013 est installée dans mon /home. J'ai purgé ces deux paquets, et cela semble rentrer dans l'ordre.
Définitif ? Provisoire ?

Code: Tout sélectionner
fab@debian:~$ latex forum_14.tex
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013)
 restricted \write18 enabled.
entering extended mode
(./forum_14.tex
LaTeX2e <2011/06/27>
Babel <3.9f> and hyphenation patterns for 78 languages loaded.
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/size11.clo))
(/home/fab/texlive/2013/texmf-dist/tex/latex/etex-pkg/etex.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/inputenc.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/utf8.def
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/t1enc.dfu)
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/ot1enc.dfu)
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/omsenc.dfu)))
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/fontenc.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/base/t1enc.def))
(/home/fab/texlive/2013/texmf-dist/tex/generic/babel/babel.sty
(/home/fab/texlive/2013/texmf-dist/tex/generic/babel-french/frenchb.ldf
(/home/fab/texlive/2013/texmf-dist/tex/generic/babel/babel.def)))
(/home/fab/texlive/2013/texmf-dist/tex/latex/carlisle/scalefnt.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/graphics/keyval.sty)
(/home/fab/texmf/tex/latex/mathtools.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/tools/calc.sty)
(/home/fab/texmf/tex/latex/mhsetup.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsmath/amsmath.sty
For additional information on amsmath, use the `?' option.
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsmath/amstext.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsmath/amsgen.sty))
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsmath/amsbsy.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsmath/amsopn.sty)))
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsfonts/amsfonts.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsfonts/amssymb.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/amscls/amsthm.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/jknapltx/mathrsfs.sty)
(./forum_14.aux)
(/home/fab/texlive/2013/texmf-dist/tex/latex/graphics/graphicx.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/graphics/graphics.sty
(/home/fab/texlive/2013/texmf-dist/tex/latex/graphics/trig.sty)
(/home/fab/texlive/2013/texmf-dist/tex/latex/latexconfig/graphics.cfg)
(/home/fab/texlive/2013/texmf-dist/tex/latex/graphics/dvips.def)))
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsfonts/umsa.fd)
(/home/fab/texlive/2013/texmf-dist/tex/latex/amsfonts/umsb.fd)
(/home/fab/texlive/2013/texmf-dist/tex/latex/jknapltx/ursfs.fd) [1]
(./forum_14.aux) )
Output written on forum_14.dvi (1 page, 536 bytes).
Transcript written on forum_14.log.
fab@debian:~$ dvips forum_14.dvi
This is dvips(k) 5.993 Copyright 2013 Radical Eye Software (www.radicaleye.com)
' TeX output 2013.07.22:2312' -> forum_14.ps
</home/fab/texlive/2013/texmf-dist/dvips/base/tex.pro>
</home/fab/texlive/2013/texmf-dist/fonts/enc/dvips/cm-super/cm-super-t1.enc>
</home/fab/texlive/2013/texmf-dist/dvips/base/texps.pro>.
</home/fab/texlive/2013/texmf-dist/fonts/type1/public/amsfonts/cm/cmsy10.pfb>
</home/fab/texlive/2013/texmf-dist/fonts/type1/public/amsfonts/cm/cmr10.pfb>
</home/fab/texlive/2013/texmf-dist/fonts/type1/public/amsfonts/cm/cmr8.pfb>
</home/fab/texlive/2013/texmf-dist/fonts/type1/public/amsfonts/cm/cmmi10.pfb>
</home/fab/texlive/2013/texmf-dist/fonts/type1/public/amsfonts/symbols/msbm10.pfb>
</home/fab/texlive/2013/texmf-dist/fonts/type1/public/cm-super/sfrm1095.pfb>
[1]
fab@debian:~$ ps2pdf forum_14.ps
fab@debian:~$
Dernière édition par Fabrice Couvreur le Vendredi 26 Juillet 2013, 12:12, édité 1 fois.
Fabrice Couvreur
Giga-utilisateur
 
Messages: 601
Inscription: Samedi 18 Août 2007, 00:55

Re: Compilation impossible avec latex

Messagepar gigiair » Mardi 23 Juillet 2013, 07:59

Fabrice Couvreur a écrit:Bonsoir,
@gigiair
J'ai constaté que si je faisais l'installation de TeXlive (via TUG) en mode root et celle d'Asymptote en mode user dans mon home, à l'invite de la commande
Code: Tout sélectionner
fab@debian:~$ asy
c'était le binaire d'Asymptote de TeXlive qui était pris en compte. D'où l'idée d'une installation de TeXlive et d'Asymptote dans mon /home/fab/. Jusqu'ici, cela avait toujours fonctionné.
L'empirisme a ses limites. La preuve en est dans ton dysfonctionnement. la commande
Code: Tout sélectionner
fab@debian:~$ which asy
est faite pour savoir savoir quel fichier est atteint par la commande asy
Il faut absolument que je répare mon système, car je dois travailler pendant les vacances.
<snip>
Je tape ensuite D, puis 1 pour mettre TEXDIR =~\texlive\2013, puis R et I, et c'est tout.
Une fois que l'installation est terminée, j'ai rajouté le répertoire des binaires de TeXlive 2013 dans mon PATH dans le fichier ./profile :

Il est plus simple, et plus propre de créer le répertoire ~/bin que l'on ajoute au PATH ( Il suffit de décommenter deux lignes dans le .profile) et de choisir l'option «Créer des liens symboliques» dans ~/bin
À ta place, dans le .profile je supprimerais tes ajouts et je décommenterais les lignes ajoutant ~/bin au PATH puis je créerais les liens avec tlmgr en mode gui (menu Actions)


La prochaine version de TeXLive, il suffira de créer de nouveaux liens et la version 2013 sera masquée sans risque de conflit.
Personnellement, je fais toujours mes installations en root, ça ne présente aucun inconvénient, même avec une installation depuis les dépôts exigée par les dépendances. La double installation telle que tu l'as faite, résulte d'un désir d'auto-punition. Tu dois avoir beaucoup de choses à te reprocher dans ton inconscient. C'est à coup sûr l'assurance d'avoir un jour ou l'autre les soucis que tu as rencontré. Tu devrais en parler à ton analyste.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2441
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: [Résolu] Compilation impossible avec latex

Messagepar Fabrice Couvreur » Mardi 23 Juillet 2013, 16:03

Bonjour,
gigiair a écrit:L'empirisme a ses limites. La preuve en est dans ton dysfonctionnement.

Je connais le fonctionnement de la commande which, mais à l'invite de la commande asy, la console affiche le message suivant :
Code: Tout sélectionner
fab@debian:~$ asy
Welcome to Asymptote version 2.23 (to view the manual, type help)
>

donc suffisant pour savoir quelle est la version utilisée !
Comme tu peux le voir, la version est celle du binaire de TeXlive 2013 et non 2.25, celle du binaire d'Asymptote que j'avais installé dans mon /home/fab/.
Pourquoi ?
Parce que j'ai suivi tes recommandations, et que l'option «Créer des liens symboliques» dans ~/bin a eu pour effet d'écraser le binaire d'Asymptote qui se trouvait déjà dans le répertoire ~/bin (ce répertoire, je l'avais déjà créé, justement pour l'installation d'Asymptote dans mon /home/fab/).
Résumons :
- installation de TeXlive 2013 dans /home/fab/texlive/2013 avec la méthode que tu préconises ;
- installation d'Asymptote dans /home/fab/Asymptote.
Comment faire pour que ce soit la version de /home/fab/Asymptote qui soit prioritaire ?
Voici, si cela peut aider, le contenu de mon .profile :
Code: Tout sélectionner
# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
   . "$HOME/.bashrc"
    fi
fi
# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

export PATH=$PATH:/home/fab/Asymptote/asymptote/asy
export PATH=$PATH:/home/fab/algobox_linux64
export PATH=$PATH:/home/fab/R-3.0.0/bin/R
export PATH=$PATH:/home/fab/sigil-0.7.2/build/bin/sigil
export LIBGS=/usr/lib/libgs.so.9


gigiair a écrit: La double installation telle que tu l'as faite, résulte d'un désir d'auto-punition. Tu dois avoir beaucoup de choses à te reprocher dans ton inconscient. C'est à coup sûr l'assurance d'avoir un jour ou l'autre les soucis que tu as rencontré. Tu devrais en parler à ton analyste.

http://forum.mathematex.net/post122343.html?hilit=ASYMPTOTE%20ET%20LINUX%20installation#p122343

Pour ce qui est de consulter un analyste, je te remercie de te soucier de ma santé, mais je vais bien (je ne suis jamais malade, et ne prend aucun médicament).
Fabrice Couvreur
Giga-utilisateur
 
Messages: 601
Inscription: Samedi 18 Août 2007, 00:55

Re: Compilation impossible avec latex

Messagepar gigiair » Mardi 23 Juillet 2013, 21:22

C'est la version 2.24 d'asymptote que tu souhaite devenir active ? Si c'est une compilation maison, un make install la remettra en place. Si c'est une version précompilée, il suffit de recopier les fichiers asy et xasy au bon endroit.
Que renvoie
Code: Tout sélectionner
ls -l $(which asy)
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2441
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Compilation impossible avec latex

Messagepar Fabrice Couvreur » Mercredi 24 Juillet 2013, 11:00

Bonjour,
C'est une compilation maison, et j'ai refait un make install :

Code: Tout sélectionner
fab@debian:~$ ls -l $(which asy)
-rwxr-xr-x 1 fab fab 33957337 juil. 24 11:37 /home/fab/bin/asy
fab@debian:~$


Code: Tout sélectionner
fab@debian:~$ asy
Welcome to Asymptote version 2.25svn-r5576 (to view the manual, type help)
>

Merci.
Fabrice Couvreur
Giga-utilisateur
 
Messages: 601
Inscription: Samedi 18 Août 2007, 00:55

Re: Compilation impossible avec latex

Messagepar gigiair » Mercredi 24 Juillet 2013, 13:01

Sans doute que la version 2.24 ne va pas tarder à être livrée avec texlive2013. Utiliser une version en cours de développement, c'est aussi prendre le risque d'essuyer les plâtres. Tu peux toujours, avec un coup de tlmgr remettre les liens vers la version TeXLive. Je trouve que c'est la solution la plus souple, bien préférable à la modification du PATH.
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2441
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Bing [Bot], Grapeshot [Crawler], pg, Yandex [Bot] et 24 invités