[Résolu] Classe beamer : trait de séparation des colonnes

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

[Résolu] Classe beamer : trait de séparation des colonnes

Messagepar nzdqrc » Mercredi 19 Juin 2019, 09:13

Bonjour à tous,
Lorsque je suis en classe article, dans l'environnement multicolonnes, j'ai un trait de séparation entre mes colonnes, comme le montre l'exemple simple ci-dessous.
Code: Tout sélectionner
\documentclass[a4paper,12pt,french]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage[left=0.25cm,right=0.25cm,top=0.25cm,bottom=0.25cm]{geometry}
\usepackage{multicol}

\begin{document}
\begin{multicols}{2}
\setlength{\columnseprule}{2.5pt}
Le trait de séparation est présent.\par
\columnbreak
Le trait de séparation est présent.\par
\end{multicols}
\end{document}


Même chose mais cette fois en classe beamer : le trait de séparation disparaît (voir exemple ci-dessous).
Code: Tout sélectionner
\documentclass[french]{beamer}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{multicol}

\begin{document}
\begin{frame}
\begin{multicols}{2}
\setlength{\columnseprule}{2.5pt}
Le trait de séparation a disparu !\par
\columnbreak
Le trait de séparation a disparu !\par
\end{multicols}
\end{frame}
\end{document}


Comment remédier à ce problème : faire réapparaître mon trait de séparation en classe beamer ?
Merci à ceux qui me répondront.
Dernière édition par nzdqrc le Dimanche 30 Juin 2019, 17:13, édité 2 fois.
nzdqrc
Déca-utilisateur
 
Messages: 49
Inscription: Lundi 11 Avril 2016, 07:43
Statut actuel: Actif et salarié | Enseignant

Publicité

Re: Classe beamer : trait de séparation des colonnes

Messagepar nzdqrc » Dimanche 30 Juin 2019, 17:11

Bonjour à tous,
J'ai finalement trouvé la solution (un peu par hasard) pour ceux que cela intéresse.
Il suffit simplement de mettre la commande \setlength{\columnseprule}{2.5pt} avant le \begin{frame}. Comme ceci :
Code: Tout sélectionner
\documentclass[french]{beamer}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{multicol}

\begin{document}
\setlength{\columnseprule}{2.5pt}
\begin{frame}
\begin{multicols}{2}
Le trait de séparation n'a pas disparu !\par
\columnbreak
Le trait de séparation n'a pas disparu !\par
\end{multicols}
\end{frame}
\end{document}

Bonne journée !
nzdqrc
Déca-utilisateur
 
Messages: 49
Inscription: Lundi 11 Avril 2016, 07:43
Statut actuel: Actif et salarié | Enseignant


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Bing [Bot], Google [Bot], MSN [Bot] et 6 invités