Caractères bizarres avec Texmaker

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Caractères bizarres avec Texmaker

Messagepar claire » Vendredi 19 Septembre 2014, 22:29

bonjour,

j'ai changé depuis quelques mois pour Texmaker (après avoir utilisé winshell) et si j'apprécie cet éditeur, des caractères bizarres viennent ralentir la frappe.

De temps à autre mais suffisamment régulièrement pour que j'en sois gênée, sans que j'ai pu trouver un lien logique, un caractère ( • ○ ♠ entre autres ...). vient se rajouter dans les lignes entre balises. Evidemment, cela provoque des erreurs de compilation qd je ne les repère pas à temps.

Quelqu'un pourrait-il m'expliquer éviter qu'ils apparaissent ? J'ai l'impression que cela ne se passe pas de la même façon sur les ordis du lycée où je viens de le faire installer sur 2 postes (je n'ai toutefois pas encore eu le temps de beaucoup les utiliser)

Il n'y a pas d'urgence mais j'avoue que je commence à m'agacer

merci de bien vouloir partager vos solutions
claire
Déca-utilisateur
 
Messages: 20
Inscription: Jeudi 25 Septembre 2008, 17:51
Statut actuel: Actif et salarié | Enseignant

Publicité

Re: caractères bizarres avec Texmaker

Messagepar touhami » Vendredi 19 Septembre 2014, 23:59

bonjour. Moi aussi j'ai ce problème, peut-être bug, avec les anciennes versions je n'avait pas ça.
touhami
Méga-utilisateur
 
Messages: 381
Inscription: Dimanche 11 Février 2007, 11:45
Statut actuel: Post-bac

Re: Caractères bizarres avec Texmaker

Messagepar rebouxo » Samedi 20 Septembre 2014, 20:30

Problème d'encodage. Cela se passe sur les caractères accentués ?

Olivier
A line is a point that went for a walk. Paul Klee
Par solidarité, pas de MP
rebouxo
Modérateur
 
Messages: 6785
Inscription: Mercredi 15 Février 2006, 13:18
Localisation: le havre
Statut actuel: Actif et salarié | Enseignant

Re: Caractères bizarres avec Texmaker

Messagepar claire » Dimanche 21 Septembre 2014, 10:11

Non, pas du tout. Les caractères accentués sont parfaitement écrits.
Ce sont bien des caractères qui s'ajoutent au code : on veut taper \newpage et il s'écrit par exemple \♥newpage.
Du coup, si on n'enlève pas le caractère ajouté, évidemment, cela ne compile pas.
Je voudrais donc savoir ce que je dois modifier dans mon TexMaker pour ne pas avoir ces ajouts.

merci
claire
Déca-utilisateur
 
Messages: 20
Inscription: Jeudi 25 Septembre 2008, 17:51
Statut actuel: Actif et salarié | Enseignant

Re: Caractères bizarres avec Texmaker

Messagepar gigiair » Dimanche 21 Septembre 2014, 11:24

Il s'agit visiblement d'un bug. Tu peux essayer de recompiler texmaker, si tu as les sources et un environnement de compilation, et si tu sais faire, en corrigeant le bug.
Autrement, il faut attendre. S'il existe une liste de diffusion pour texmaker, tu peux signaler le problème. L'auteur Pascal Brachet passait souvent par ici, peut-être est-il en train de corriger le bug. Autrement TeXStudio est paraît-il très semblable (et même supérieur mais ça le fâche de dire ça).
JJR.
LaTeXien migrateur.
gigiair
Exa-utilisateur
 
Messages: 2286
Inscription: Samedi 08 Juillet 2006, 19:56
Localisation: Saint Bonnet Elvert
Statut actuel: Actif et salarié

Re: Caractères bizarres avec Texmaker

Messagepar kojak » Dimanche 21 Septembre 2014, 12:22

Bonjour,

Il est tout à fait possible de contacter l'auteur de Texmaker par mail, vu qu'il se trouve sur son site. Mais bien lui préciser la version utilisée, l'OS, etc. de façon à faire avancer le scmilblick.
pas d'aide par MP
kojak
Modérateur
 
Messages: 10331
Inscription: Samedi 18 Novembre 2006, 19:50
Statut actuel: Actif et salarié | Enseignant

Re: Caractères bizarres avec Texmaker

Messagepar claire » Dimanche 21 Septembre 2014, 14:20

Merci de vos conseils. Je vais en effet essayer de contacter l'auteur sur son site. Je posterai la solution donnée pour clore la discussion.
claire
Déca-utilisateur
 
Messages: 20
Inscription: Jeudi 25 Septembre 2008, 17:51
Statut actuel: Actif et salarié | Enseignant

Re: Caractères bizarres avec Texmaker

Messagepar texmaker » Dimanche 21 Septembre 2014, 18:22

1) Il y a un lien contact sur chaque page du site de Texmaker (difficile à rater!!)
2) Il y a aussi un lien vers le tracker sur chaque page du site
3) Impossible de reproduire le problème que ce soit sous windows (ce qui doit être l'os utilisé vu que winshell n'existe que sous windows - testé sous seven ou 8 ), macosx ou linux
4) Depuis 1 mois et demi qu'est sorti la dernière version personne d'autre n'a jamais signalé ce problème que ce soit via le tracker ou par mail
5) Rien n'a changé concernant l'entrée/sortie de l'éditeur depuis la dernière version

Pistes probables :
- document corrompu ou enregistré/ouvert sous des encodages différents
- le fichier de config de Texmaker a été bidouillé et/ou corrompu
Suggére de réinitialiser la config : Option -> Fichier de configuration -> Réinitialiser la config (voir de désinstaller Texmaker, de le re-télécharger et de le réinstaller) et de tester avec un document vierge
Texmaker (version courante : 5.0) : éditeur LaTeX libre et multi-plateforme avec afficheur pdf.
PdfAdd : Tableaux variations, courbes, arbres, graphes, loi binomiale, cercle trigo, suites pour pdflatex et Asymptote
Site de documentation sur LaTeX
texmaker
Kilo-utilisateur
 
Messages: 226
Inscription: Vendredi 30 Juillet 2010, 11:19
Statut actuel: Actif et salarié | Enseignant

Re: Caractères bizarres avec Texmaker

Messagepar raphkebab » Lundi 22 Septembre 2014, 10:33

J'ai le même souci sous Textudio quand je suis sous windows. Il ne me s'emble pas avoir eu ce problème sous linux.
raphkebab
Kilo-utilisateur
 
Messages: 227
Inscription: Mardi 31 Décembre 2013, 12:37
Localisation: Caen
Statut actuel: Post-bac | Doctorat

Re: Caractères bizarres avec Texmaker

Messagepar guiguiche » Lundi 22 Septembre 2014, 12:11

Je sens venir un problème sous windows (seven en ce qui me concerne) car j'ai aussi parfois l'apparition aléatoire de tels symboles sous LyX après un backslash depuis environ un mois.
Pas d'aide par MP : les questions sont publiques, les réponses aussi.
Tu as apprécié l'aide qui t'a été fournie ? Alors n'hésite pas à rendre la pareille à quelqu'un d'autre.
Un peu d'autopromotion.
guiguiche
Modérateur
 
Messages: 8019
Inscription: Vendredi 06 Janvier 2006, 15:32
Localisation: Le Mans
Statut actuel: Actif et salarié | Enseignant

Re: Caractères bizarres avec Texmaker

Messagepar Euher » Samedi 11 Avril 2015, 07:36

Bonjour à tous,
Nouveau sur ce forum (que je consulte régulièrement depuis trois ans...),
je me permets de remonter ce post sur les caractères qui apparaissent aléatoirement après un backslash avec Texmaker.
Depuis la dernière mise à jour (4.4.1), j'ai moi aussi ce problème.
Quelqu'un a-t-il trouvé une solution ?
Merci d'avance.
Euher
Utilisateur
 
Messages: 4
Inscription: Samedi 11 Avril 2015, 07:30
Statut actuel: Actif et salarié | Enseignant

Re: Caractères bizarres avec Texmaker

Messagepar touhami » Samedi 11 Avril 2015, 09:40

Je pense que ce n'est pas un problème de Texmaker. Il s'agit peut être à un problème du système ou de clavier (je ne sais pas). j'ai rencontré ça sur d'autres applications et même dans la zone d'édition des forums. Je pense que le problème et en relation avec
Alt Gr.
Pour votre question: je n'ai pas chercher une solution.
touhami
Méga-utilisateur
 
Messages: 381
Inscription: Dimanche 11 Février 2007, 11:45
Statut actuel: Post-bac

Re: Caractères bizarres avec Texmaker

Messagepar Euher » Samedi 11 Avril 2015, 10:23

J'ai des doutes : chez moi le problème ne se pose qu'avec Texmaker,
et il est apparu précisément le jour où j'ai installé la version 4.4.1
Merci pour les retours.
Euher
Utilisateur
 
Messages: 4
Inscription: Samedi 11 Avril 2015, 07:30
Statut actuel: Actif et salarié | Enseignant

Re: Caractères bizarres avec Texmaker

Messagepar romm » Lundi 01 Mai 2017, 11:09

Bonjour,

Ce post date un peu mais j'ai également ce problème. Personne n'en a trouvé de solution ?
J'utilise Windows 7, tekmaker 4.5 et un clavier Logitech K120.
romm
Utilisateur
 
Messages: 1
Inscription: Lundi 01 Mai 2017, 11:07
Statut actuel: Actif et salarié | Enseignant

Re: Caractères bizarres avec Texmaker

Messagepar balf » Lundi 01 Mai 2017, 15:34

Je ne me sers pas habituellement de TeXmaker, mais je l'ai sur mon système (Windows 7) pour tester le cas échéant. Je n'ai pas constaté cet étrange phénomène. Pourriez-vous poster un exemple de code qui pose ce problème en expliquant ce que vous avez voulu tapé (p. ex. avec un autre éditeur) et ce que vous obtenez.

B. A.
balf
Zetta-utilisateur
 
Messages: 3640
Inscription: Mercredi 02 Janvier 2008, 23:18
Statut actuel: Actif et salarié | Maître de conférence

Re: Caractères bizarres avec Texmaker

Messagepar guiguiche » Jeudi 18 Mai 2017, 09:27

Le problème persiste chez moi sous LyX (j'utilise très rarement TeXmaker mais je me demande s'il n'est pas apparu lorsque j'ai installé TeXmaker), win10, langue FRA clavier MAEL.
Je pense qu'il y a un conflit WIN qui apparait lors de l'installation de TeXmaker (lié à l'extension linguistique MAEL ???)
Pas d'aide par MP : les questions sont publiques, les réponses aussi.
Tu as apprécié l'aide qui t'a été fournie ? Alors n'hésite pas à rendre la pareille à quelqu'un d'autre.
Un peu d'autopromotion.
guiguiche
Modérateur
 
Messages: 8019
Inscription: Vendredi 06 Janvier 2006, 15:32
Localisation: Le Mans
Statut actuel: Actif et salarié | Enseignant


Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Ahrefs [Bot], Google Adsense [Bot] et 27 invités