[Résolu] Bibliographies fantomes avec Bibunits

Tout ce qui concerne l'utilisation ou l'installation de LaTeX.

Modérateur: gdm_tex

Règles du forum
Merci d'éviter le style SMS dans vos messages et de penser à utiliser la fonction Recherche avant de poster un message. Pour joindre des fichiers à vos messages, consulter ce sujet.
> Penser à utiliser les balises Code pour poster du code.

Re: bibliographies fantomes avec Bibunits

Messagepar Remek » Dimanche 18 Avril 2010, 09:37

Bonjour fp,

je viens de chercher le fichier dans le repertoire mentionne (il se trouve dans "C:\Users\Remek\AppData\Local\VirtualStore\Program Files (x86)\WinEdt Team\WinEdt\Exec\MiKTeX" chez moi car ma machine tourne sous Windows 7), mais grande surprise la ligne a inserer s'y trouvait deja !
J'ai retente la compilation, toujours le meme resultat...

Pa contre j'ai relance la compilation sur mon exemple minimal, et la une petite fenetre d'information s'ouvre lorsque je lance BibTex, me disant simplement: "BibTeX-bibunits".
Je commence un peu a desesperer... Je n'arrive toujours pas a comprendre pourquoi cela fonctionne sur l'exemple minimal mais pas sur mon document principal.

Encore une fois merci !
Remek
Kilo-utilisateur
 
Messages: 111
Inscription: Samedi 02 Février 2008, 15:54
Statut actuel: Post-bac | Doctorat

Publicité

Re: bibliographies fantomes avec Bibunits

Messagepar fp » Dimanche 18 Avril 2010, 10:06

Bon, on va continuer à explorer ce fichier BibTeX.edt.
Il semble qu'il y ait une copie automatique de C:\Program Files....\MiKTeX\ vers C:\Users\...\MiKTeX (je ne peux pas le savoir, car je n'utilise pas de profil personnel sous WinEdt).

En tout début du fichier C:\Users\...\MiKTeX\BibTeX.edt, écrivez :

Code: Tout sélectionner
Prompt("Hello !");


(c'est simplement pour voir si ce fichier est bien utilisé par WinEdt)

Sauvez le fichier et lancez BibTeX sur Dissertation_version1

S'il y a la boîte d'alerte avec Hello ! c'est que ce fichier est bien utilisé par WinEdt.

Dans ce cas, allez vers la ligne 143 de BibTeX.edt et repérez la ligne :
Code: Tout sélectionner
GetPreamble("\begin{document}",9);

Après cette ligne, insérez une ligne vierge et tapez
Code: Tout sélectionner
Prompt("Bonjour !");


Sauvez le fichier et lancez BibTeX sur Dissertation_version1

S'il y a les deux boîtes d'alerte (Hello ! puis Bonjour !), pouvez-vous me dire si, dans BibTeX.edt, 3 lignes plus bas que le Prompt("Bonjour !");, il y a la ligne
Code: Tout sélectionner
Assign("BibTeX-package","bibunits");  Call("BibTeX-do");


Si oui, pouvez-vous me dire si, vers la ligne 81, il y a une ligne
Code: Tout sélectionner
:BibTeX-do::


Si oui, deux lignes plus bas, avant la ligne
Code: Tout sélectionner
 IfNum(%!7,%!8,"<",!">

insérez une ligne blanche et tapez :
Code: Tout sélectionner
 Prompt("%!7");Prompt("%!8");

Sauvez le fichier et lancez BibTeX sur Dissertation_version1

Que se passe-t-il ?

FP.
fp
Giga-utilisateur
 
Messages: 752
Inscription: Mercredi 24 Février 2010, 08:04
Statut actuel: Actif et salarié | Enseignant

Re: bibliographies fantomes avec Bibunits

Messagepar Remek » Dimanche 18 Avril 2010, 10:41

J'ai suivi a la lettre toutes les indications: les fenetres "Hello !" et "Bonjour !" s'affichent bien. Quant a la derniere manipulation, la compilation BibTeX affiche des fenetres successives ou les nombres 143 puis 142 alternent 6 fois de suite. Pour etre plus clair, voici le contenu exact des fenetres qui se suivent: "Hello !", "Bonjour !", "143", "142", "143", "142", "143", "142", "143", "142", "143", "142", "143", "142".

J'ai fait le meme test sur mon exemple minimal, et voici ce que j'obtiens:
"Hello !", "Bonjour !", "5830", "5829", "5830", "5829", "381", "413", "BibTeX-bibunits".

J'espere que cela peut nous faire avancer un peu ! Meme si cela reste tres obscur pour moi...
Remek
Kilo-utilisateur
 
Messages: 111
Inscription: Samedi 02 Février 2008, 15:54
Statut actuel: Post-bac | Doctorat

Re: bibliographies fantomes avec Bibunits

Messagepar fp » Dimanche 18 Avril 2010, 10:54

OK, on progresse.

Les boîtes d'alerte Hello ! et Bonjour ! sont là pour voir si la macro passe bien par les endroits voulus.
Les boîtes d'alerte %!7 et %!8 sont là pour voir pourquoi la macro ne voit pas bibunits.

Vous pouvez enlever les lignes

Prompt("Hello !");

Prompt("Bonjour !");

Prompt("%!7"); Prompt("%!8");


Pouvez-vous poster le préambule de votre document Dissertation_version1.tex (depuis le début jusqu'à \begin{document}) ?

FP.
fp
Giga-utilisateur
 
Messages: 752
Inscription: Mercredi 24 Février 2010, 08:04
Statut actuel: Actif et salarié | Enseignant

Re: bibliographies fantomes avec Bibunits

Messagepar Remek » Dimanche 18 Avril 2010, 11:18

Le preambule de mon document principal est malheureusement extremement long (il consiste en fait en plusieurs fichiers inseres avec \input{}: un fichier contenant la liste des packages utilises, un autres les definitions de mes notations mathematiques, etc.), je ne suis pas sur qu'il soit bienvenu de poster ce genre de choses ici.

En revanche, j'ai pris les devants et je pense avoir trouve le probleme ! En essayant d'inserer le preambule de mon document principal dans mon exemple minimal, j'ai decouvert quelque chose d'interessant: lorsque je copie-colle l'integralite des fichiers inseres dans le preambule, tout se passe correctement. Mais lorsque j'inclus ces fichiers separement avec \input{}, comme c'est le cas dans mon document principal, le meme probleme se pose. Je me suis alors dit que BibTeX avait un probleme a lire les fichiers avec \input{}. J'ai donc juste deplace le "\usepackage[sectionbib]{bibunits}" du fichier annexe vers le fichier principal, et la tout fonctionne sans probleme ! Mais est-ce bien BibTeX qui ne lit pas les fichiers inseres avec \input{}, ou bien le probleme vient-il d'ailleurs ? Y-a-t'il un moyen de modifier ce comportement etrange de LaTeX/BibTeX ?
Remek
Kilo-utilisateur
 
Messages: 111
Inscription: Samedi 02 Février 2008, 15:54
Statut actuel: Post-bac | Doctorat

Re: bibliographies fantomes avec Bibunits

Messagepar fp » Dimanche 18 Avril 2010, 11:25

Je me doutais de quelque chose comme ça, c'est pour ça que je vous demandais le préambule de votre document.

Cela vient de la façon qu'a WinEdt de chercher si le package bibunits est utilisé.
En effet, la ligne 82 de BibTeX.edt qui est :

Code: Tout sélectionner
 FindInString("%!9","<@{ }\\usepackage@{\[+^{\]}\]}\{@^{\}|%%|%$('BibTeX-package');}%$('BibTeX-package');{,| |\}}",7,8,11);


Consiste à chercher dans la mémoire %!9 (qui contient l'intégralité du préambule de votre document) la chaîne de caractères :

\usepackage{bibunits} (ou \usepackage{biblatex} ou \usepackage{bibtopic} ou \usepackage{multibbl} ou \usepackage{multibib} ou \usepackage{chapterbib})
(avec éventuellement des options [...]).

Comme il ne trouve pas cette chaîne de caractères (puisque le \usepackage{bibunits} est dans un autre fichier appelé par \input), WinEdt ne lance pas BibTeX sur les fichier bu*.aux...

FP.
fp
Giga-utilisateur
 
Messages: 752
Inscription: Mercredi 24 Février 2010, 08:04
Statut actuel: Actif et salarié | Enseignant

Re: bibliographies fantomes avec Bibunits

Messagepar fp » Dimanche 18 Avril 2010, 11:32

Remarque : Vous pouvez maintenant supprimer la ligne

Code: Tout sélectionner
Prompt('BibTeX-%$(|BibTeX-package|);');>



Dans vos deux fichiers C:_Program files\WinEdt Team\WinEdt\Exec\MiKTeX\BibTeX.edt

et C:\USers\....\BibTeX.edt.

FP.
fp
Giga-utilisateur
 
Messages: 752
Inscription: Mercredi 24 Février 2010, 08:04
Statut actuel: Actif et salarié | Enseignant

Re: bibliographies fantomes avec Bibunits

Messagepar Remek » Dimanche 18 Avril 2010, 11:37

Un grand merci pour votre aide et votre patience fp ! Vos explications detaillees sont tres utiles.

Si je peux me permettre une derniere question : comment faire pour obtenir une bibliographie generale en fin d'ouvrage (reprenant toutes les citations des bibliographies de chaque chapitre) ? J'ai suivi les instructions du manuel, mais la commande \bibliography{} ne produit rien d'autre que le mot "Bibliography".

Encore merci et bonne journee !

Remek
Remek
Kilo-utilisateur
 
Messages: 111
Inscription: Samedi 02 Février 2008, 15:54
Statut actuel: Post-bac | Doctorat

Re: bibliographies fantomes avec Bibunits

Messagepar fp » Dimanche 18 Avril 2010, 12:00

si je comprends bien le manuel de bibunits :

Remplacer \defaultbibliographystyle par \bibliographystyle
Supprimer le \defaultbibliography{./bib/texlit}
Mettre juste parès \begin{document} : \nocite*{}
Mettre, à l'endroit où vous voulez votre bibliographie globale :

\bibliography{./bib/texlit}

FP.

PS : mettez [Résolu] dans le titre du topic.
fp
Giga-utilisateur
 
Messages: 752
Inscription: Mercredi 24 Février 2010, 08:04
Statut actuel: Actif et salarié | Enseignant

Re: [Résolu] bibliographies fantomes avec Bibunits

Messagepar Remek » Dimanche 18 Avril 2010, 13:50

Ca marche impeccable maintenant, merci !! Exactement le resultat que je recherchais !

Bonne journee encore,
Remek
Remek
Kilo-utilisateur
 
Messages: 111
Inscription: Samedi 02 Février 2008, 15:54
Statut actuel: Post-bac | Doctorat

Précédente

Retourner vers LaTeX

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Google [Bot], Google Adsense [Bot], Proximic [Spider] et 22 invités